Subject: [secdir] Secdir review of draft-ietf-detnet-tsn-vpn-over-mpls-05

From: Magnus Nyström <[email-masked]>
Date: Mon, 8 Feb 2021 23:26:23 -0800

I have reviewed this document as part of the security directorate's
ongoing effort to review all IETF documents being processed by the IESG.
These comments were written primarily for the benefit of the security area
directors.  Document editors and WG chairs should treat these comments just
like any other last call comments.

This document describes a deterministic network data plane when
time-sensitive networks are interconnected.

The security considerations section seems adequate though the integration
of a protocol (TSN) on top of another protocol (DetNet/MPLS) sometimes can
yield new results so it is just a question to the authors if  no new
security consideration results from the application of TSN over DetNet/MPLS?

Editorial:

   - "TSN" is used as an acronym in the abstract as is DetNet (and MPLS,
   although that is perhaps more common knowledge). Would be goot to spell out
   these acronyms directly in the abstract.
   - Section 6, "challanges" -> "challenges"
   - Section 6, "are member" -> "are members"

Thanks,
-- Magnus

---

From: Balázs Varga A <[email-masked]>
Date: Tue, 9 Feb 2021 16:17:13 +0000

Hi Magnus,
Many thanks for your review.
Security related aspects are covered in a dedicated draft (draft-ietf-detnet-security-14),
so no new security considerations were needed here in this draft.
All your editorial comments are welcome and will be updated in the new version.
Thanks
Bala’zs

From: Magnus Nyström <[email-masked]>
Sent: Tuesday, February 9, 2021 8:26 AM
To: [email-masked]; [email-masked]
Subject: Secdir review of draft-ietf-detnet-tsn-vpn-over-mpls-05

I have reviewed this document as part of the security directorate's ongoing effort to review all IETF documents being processed by the IESG. These comments were written primarily for the benefit of the security area directors.  Document editors and WG chairs should treat these comments just like any other last call comments.

This document describes a deterministic network data plane when time-sensitive networks are interconnected.

The security considerations section seems adequate though the integration of a protocol (TSN) on top of another protocol (DetNet/MPLS) sometimes can yield new results so it is just a question to the authors if  no new security consideration results from the application of TSN over DetNet/MPLS?

Editorial:

  *   "TSN" is used as an acronym in the abstract as is DetNet (and MPLS, although that is perhaps more common knowledge). Would be goot to spell out these acronyms directly in the abstract.
  *   Section 6, "challanges" -> "challenges"
  *   Section 6, "are member" -> "are members"
Thanks,
-- Magnus