Subject: [secdir] Secdir last call review of draft-ietf-calext-valarm-extensions-04

From: Valery Smyslov via Datatracker <[email-masked]>
Date: Wed, 10 Feb 2021 04:44:47 -0800

Reviewer: Valery Smyslov
Review result: Ready

I have reviewed this document as part of the security directorate's ongoing
effort to review all IETF documents being processed by the IESG.  These
comments were written primarily for the benefit of the security area directors.
Document editors and WG chairs should treat these comments just like any other
last call comments.

The draft defines a set of extensions to the VALARM component of iCalendar.
The document is short and well written, its Security Considerations and Privacy Considerations
sections are sensible. I found the document ready.

Nit: I would recommend adding a sentence to the Security Considerations section saying that 
these VALARM extensions inherited security properties of iCalendar [RFC5545].

---

From: Ken Murchison <[email-masked]>
Date: Wed, 10 Feb 2021 08:18:28 -0500

Hi Valery,

Thank you for the review.  Per your recommendation, I have added the 
following phrase to the beginning of the Security Considerations section:

"In addition to the security properties of iCalendar (see Section of 
[RFC5545] <https://xml2rfc.tools.ietf.org/cgi-bin/xml2rfc.cgi#RFC5545>), 
..."

Is this sufficient, or do you have alternative text that you'd like to see?

-- 
Kenneth Murchison
Senior Software Developer
Fastmail US LLC

---

From: Ken Murchison <[email-masked]>
Date: Wed, 10 Feb 2021 08:20:47 -0500

On 2/10/21 8:18 AM, Ken Murchison wrote:
> [RFC5545] 
> <https://xml2rfc.tools.ietf.org/cgi-bin/xml2rfc.cgi#RFC5545>), ..."
>
Copy and paste error above: this should say "Section 7 of"

---

From: "Valery Smyslov" <[email-masked]>
Date: Wed, 10 Feb 2021 16:33:00 +0300

Hi Kenneth,

I think this addition is OK.

Thank you,

Valery.

Hi Valery,

Thank you for the review.  Per your recommendation, I have added the following phrase to the beginning of the Security Considerations section:

"In addition to the security properties of iCalendar (see Section of [RFC5545] <https://xml2rfc.tools.ietf.org/cgi-bin/xml2rfc.cgi#RFC5545> ), ..."

Reviewer: Valery Smyslov
Review result: Ready