Subject: [secdir] Secdir last call review of draft-ietf-regext-unhandled-namespaces

From: "Konda, Tirumaleswar Reddy" <[email-masked]>
Date: Sun, 21 Feb 2021 11:48:37 +0000

Reviewer: Tirumaleswar Reddy
Review result: Has nits

This document does not define any new EPP protocol elements, it specifies an operational practice using the existing EPP protocol. It does not discuss any security aspects other than relying on the security considerations in EPP protocol [RFC5730].

The security considerations described in these other specifications apply to this specification as well.

Comment> What other specifications are you referring to ?

-Tiru

---

From: "Gould, James" <[email-masked]>
Date: Mon, 22 Feb 2021 16:41:05 +0000

Tiru,

In re-looking at it, it was intended to reference the set of normative EPP RFC’s used in the draft, which originally included RFC 5730, 5731, 3915, 5910, and 8590.  We moved all of the EPP RFCs 3915, 5910, and 8590 from normative references to informational references because they’re only used in the examples, which leaves the RFC 5730 and 5731 normative references.  I believe that the RFC 5731 normative reference can also be made an informational reference, since it’s only used in the examples.  If that was to be done, it would only leave RFC 5730, which is the target of the statement in the Security Considerations section.  This is a long way of proposing moving RFC 5731 to be informational and remove the second sentence “The security considerations described in these other specifications apply to this specification as well. “ from the Security Considerations section, since the first sentence covers RFC 5730 and no other EPP RFCs apply.

Thanks,

--

JG

James Gould
Fellow Engineer
[email-masked]<applewebdata://13890C55-AAE8-4BF3-A6CE-B4BA42740803/[email-masked]>

703-948-3271
12061 Bluemont Way
Reston, VA 20190

Verisign.com<http://verisigninc.com/>

From: "Konda, Tirumaleswar Reddy" <[email-masked]>
Date: Sunday, February 21, 2021 at 6:48 AM
To: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: [EXTERNAL] Secdir last call review of draft-ietf-regext-unhandled-namespaces
Resent-From: <[email-masked]>
Resent-To: James Gould <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, David Smith <[email-masked]>, David Smith <[email-masked]>
Resent-Date: Sunday, February 21, 2021 at 6:48 AM

-Tiru

---

From: "Konda, Tirumaleswar Reddy" <[email-masked]>
Date: Tue, 23 Feb 2021 08:53:30 +0000

Thanks James for the clarification and update to the draft.

Cheers,
-Tiru

From: Gould, James <[email-masked]>
Sent: Monday, February 22, 2021 10:11 PM
To: Konda, Tirumaleswar Reddy <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Subject: Re: Secdir last call review of draft-ietf-regext-unhandled-namespaces

CAUTION: External email. Do not click links or open attachments unless you recognize the sender and know the content is safe.

________________________________
Tiru,

Thanks,

--

JG

James Gould
Fellow Engineer

703-948-3271
12061 Bluemont Way
Reston, VA 20190

From: "Konda, Tirumaleswar Reddy" <[email-masked]<mailto:[email-masked]>>
Date: Sunday, February 21, 2021 at 6:48 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [EXTERNAL] Secdir last call review of draft-ietf-regext-unhandled-namespaces
Resent-From: <[email-masked]<mailto:[email-masked]>>
Resent-To: James Gould <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>, David Smith <[email-masked]<mailto:[email-masked]>>, David Smith <[email-masked]<mailto:[email-masked]>>
Resent-Date: Sunday, February 21, 2021 at 6:48 AM

-Tiru