Subject: [secdir] Secdir review of draft-ietf-ace-oauth-params-13

From: Charlie Kaufman <[email-masked]>
Date: Sat, 13 Mar 2021 04:29:27 +0000

I have reviewed this document as part of the security directorate's ongoing effort to review all IETF documents being processed by the IESG.  These comments were written primarily for the benefit of the security area directors.  Document editors and WG chairs should treat these comments just like any other last call comments.

This is a re-review; I reviewed version -06 in December 2019.

In the intervening versions, the specification was simplified somewhat at the cost of removing support for key rollover of asymmetric keys in certain scenarios. A section was added "Requirements when using asymmetric keys" which contained what I considered a confusing reference to DTLS, but it does not make the spec ambiguous.

This is a small extension to [I-D.ietf-ace-oauth-authz] and is separate from that document for technical reasons that I don't understand but which seem plausible.

The security considerations section says simply (and I agree):

This document is an extension to [I-D.ietf-ace-oauth-authz]. All security considerations from that document apply here as well.

All of the nits mentioned in the previous review have been corrected.

---

From: Benjamin Kaduk <[email-masked]>
Date: Wed, 17 Mar 2021 21:40:31 -0700

Hi Charlie,

Thanks for the re-review; I'm glad that things lined up so that you could
revisit the document (and that it looks to be in good shape to you).

-Ben