Subject: Re: [secdir] Secdir telechat review of draft-ietf-alto-path-vector-22

From: Qin Wu <[email-masked]>
Date: Wed, 2 Mar 2022 10:57:34 +0000

Thanks Kai for clarification and proposed text
@Samuel, would you like to confirm that the changes work for you or you have better suggested text.
Thanks Samuel.

-Qin (on behalf of chairs)
-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 
发送时间: 2022年3月1日 16:15
收件人: Samuel Weiler <[email-masked]>
抄送: [email-masked]; [email-masked]; [email-masked]; [email-masked]
主题: Re: Secdir telechat review of draft-ietf-alto-path-vector-22

Hi Samuel,

Thanks for the feedback. Please see our replies inline.

Best,
Kai

> -----Original Messages-----
> From: "Samuel Weiler via Datatracker" <[email-masked]> &gt; Sent Time: 2022-02-26 05:38:53 (Saturday) &gt; To: [email-masked] &gt; Cc: [email-masked], [email-masked], [email-masked] &gt; Subject: Secdir telechat review of 
> draft-ietf-alto-path-vector-22 &gt; &gt; Reviewer: Samuel Weiler &gt; Review result: Not Ready &gt; &gt; The security considerations text in this document has changed markedly - and &gt; multiple times - from when I reviewed it at version -19.  I'm 
> flagging this as &gt; "Not Ready" mostly because I think it deserves another set of eyes (e.g. the &gt; ADs').

Thanks for the comment. Indeed we have revised the security section but these changes are to address the DISCUSS raised in the IEST reviews. The proposed texts are mainly based on our discussions with Roman [1].

[1] https://mailarchive.ietf.org/arch/msg/alto/PSjlTNhHKGdcjIHC8XYkxdulMzU/

> An intermediate version (-20) required the use of Digital Right Management &gt; (DRM).  In -22, that's toned down to a recommendation.  What other non-DRM &gt; technical solutions might help?

Thanks for the comment. The requirement on DRM is toned down based on the IESG reviews [2]. Note that we have already instructed in the document that ALTO server/client should follow the guideline in RFC 7285 to protect the confidentiality in communication. The DRM approach in this document is used for the case where an authorized client, after it retrieves the information from the ALTO server, leaks the information to an unauthorized client. We feel this problem is not specific to path vector and the use of DRM is inherited from RFC 7285.

[2] https://mailarchive.ietf.org/arch/msg/alto/Q6XiR0N9LZJxPjyJQvJEDaH_KyM/

>
> It feels weird to have the the server being instructed do out-of-band things, &gt; e.g.:
>  
>            The ALTO server MUST carefully verify that the deployment
>             scenario satisfies the security assumptions of these methods before
>            applying them to protect Path Vector services with sensitive network
>             information.
> 
> This sounds like a requirement for the operator of the server, which the server &gt; is in no position to enforce - and we're providing no technical measure for &gt; enforcing.
>
We agree. It should the operator of the ALTO server who verifies the conditions. How about we use the following texts:

    The ALTO service provider MUST carefully verify that the deployment
    scenario satisfies the security assumptions of these methods before
    applying them to protect Path Vector services with sensitive network
    information.</[email-masked]>

---

From: [email-masked]
Date: Sun, 6 Mar 2022 01:24:34 +0800 (GMT+08:00)

Hi Samuel,

Sorry to bother you again but we have just submitted a new version of the path vector document. See the diff in [1].

[1] https://www.ietf.org/rfcdiff?url1=draft-ietf-alto-path-vector-22&amp;url2=draft-ietf-alto-path-vector-23

Ben gave some suggestions on the security consideration part. Could you please also take a look and see if the changes are OK?

Thanks a lot!

Best,
Kai

&gt; -----Original Messages-----
&gt; From: "Qin Wu" <bill.wu=[email-masked]>
&gt; Sent Time: 2022-03-02 18:57:34 (Wednesday)
&gt; To: "[email-masked]" <[email-masked]>, "Samuel Weiler" <[email-masked]>
&gt; Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
&gt; Subject: Re: [alto] Secdir telechat review of draft-ietf-alto-path-vector-22
&gt; 
&gt; Thanks Kai for clarification and proposed text
&gt; @Samuel, would you like to confirm that the changes work for you or you have better suggested text.
&gt; Thanks Samuel.
&gt; 
&gt; -Qin (on behalf of chairs)
&gt; -----邮件原件-----
&gt; 发件人: [email-masked] [mailto:[email-masked]] 
&gt; 发送时间: 2022年3月1日 16:15
&gt; 收件人: Samuel Weiler <[email-masked]>
&gt; 抄送: [email-masked]; [email-masked]; [email-masked]; [email-masked]
&gt; 主题: Re: Secdir telechat review of draft-ietf-alto-path-vector-22
&gt; 
&gt; Hi Samuel,
&gt; 
&gt; Thanks for the feedback. Please see our replies inline.
&gt; 
&gt; Best,
&gt; Kai
&gt; 
&gt; 
&gt; &gt; -----Original Messages-----
&gt; &gt; From: "Samuel Weiler via Datatracker" <[email-masked]> &gt; Sent Time: 2022-02-26 05:38:53 (Saturday) &gt; To: [email-masked] &gt; Cc: [email-masked], [email-masked], [email-masked] &gt; Subject: Secdir telechat review of 
&gt; &gt; draft-ietf-alto-path-vector-22 &gt; &gt; Reviewer: Samuel Weiler &gt; Review result: Not Ready &gt; &gt; The security considerations text in this document has changed markedly - and &gt; multiple times - from when I reviewed it at version -19.  I'm 
&gt; &gt; flagging this as &gt; "Not Ready" mostly because I think it deserves another set of eyes (e.g. the &gt; ADs').
&gt; 
&gt; Thanks for the comment. Indeed we have revised the security section but these changes are to address the DISCUSS raised in the IEST reviews. The proposed texts are mainly based on our discussions with Roman [1].
&gt; 
&gt; [1] https://mailarchive.ietf.org/arch/msg/alto/PSjlTNhHKGdcjIHC8XYkxdulMzU/
&gt; 
&gt; &gt; An intermediate version (-20) required the use of Digital Right Management &gt; (DRM).  In -22, that's toned down to a recommendation.  What other non-DRM &gt; technical solutions might help?
&gt; 
&gt; Thanks for the comment. The requirement on DRM is toned down based on the IESG reviews [2]. Note that we have already instructed in the document that ALTO server/client should follow the guideline in RFC 7285 to protect the confidentiality in communication. The DRM approach in this document is used for the case where an authorized client, after it retrieves the information from the ALTO server, leaks the information to an unauthorized client. We feel this problem is not specific to path vector and the use of DRM is inherited from RFC 7285.
&gt; 
&gt; [2] https://mailarchive.ietf.org/arch/msg/alto/Q6XiR0N9LZJxPjyJQvJEDaH_KyM/
&gt; 
&gt; &gt;
&gt; &gt; It feels weird to have the the server being instructed do out-of-band things, &gt; e.g.:
&gt; &gt;  
&gt; &gt;            The ALTO server MUST carefully verify that the deployment
&gt; &gt;             scenario satisfies the security assumptions of these methods before
&gt; &gt;            applying them to protect Path Vector services with sensitive network
&gt; &gt;             information.
&gt; &gt; 
&gt; &gt; This sounds like a requirement for the operator of the server, which the server &gt; is in no position to enforce - and we're providing no technical measure for &gt; enforcing.
&gt; &gt;
&gt; We agree. It should the operator of the ALTO server who verifies the conditions. How about we use the following texts:
&gt; 
&gt;     The ALTO service provider MUST carefully verify that the deployment
&gt;     scenario satisfies the security assumptions of these methods before
&gt;     applying them to protect Path Vector services with sensitive network
&gt;     information.</[email-masked]>
&gt; _______________________________________________
&gt; alto mailing list
&gt; [email-masked]
&gt; https://www.ietf.org/mailman/listinfo/alto
</[email-masked]></[email-masked]></[email-masked]></[email-masked]></[email-masked]></[email-masked]></[email-masked]></bill.wu=[email-masked]>