Subject: [Syslog] RE: Framing...

From: David Harrington <[email-masked]>
Date: Mon, 18 Dec 2006 11:18:56 -0500

Hi,

The chairs believe there is consensus, and will ask Miao to change the
-tls- document to say that FRAME-LEN is the count of the octets of the
SYSLOG-MSG. 

dbh 

> -----Original Message-----
> From: Rainer Gerhards [mailto:[email-masked]] 
> Sent: Monday, December 18, 2006 9:55 AM
> To: Chris Lonvick; David Harrington; Miao Fuyou
> Subject: Framing...
> 
> Hi all,
> 
> I just wonder if we have reached consensus to change the octet
counter
> to just cover the SYSLOG-MSG len. I have to admit that I am 
> hesitant to
> release the open source software with the "wrong" framing. I know
that
> it is not appropriate to claim anything of an implementation 
> of a draft,
> but as it looks we have consensus, I'd like to release what will
most
> probable become reality. Of course, I'll include big 
> disclaimers on that
> functionality. But on the other hand, I would really like to get
some
> feedback from practice. I am also preparing a document that
describes
> why I have implemented the framing and why it is a big advantage
over
> traditional syslog/tcp.
> 
> If we have a consensus, could we declare it?
> 
> Rainer
> 

_______________________________________________
Syslog mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/syslog

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 18 Dec 2006 17:58:22 +0100

> -tls- document to say that FRAME-LEN is the count of the octets of the

Perhaps also consider to change FRAME-LEN to MSG-LEN to better reflect
the purpose of the value.

/js

-- 
Juergen Schoenwaelder		 {International|Jacobs} University Bremen
<http://www.eecs.iu-bremen.de/>	 P.O. Box 750 561, 28725 Bremen, Germany

---

From: Miao Fuyou <[email-masked]>
Date: Tue, 19 Dec 2006 08:59:09 +0800

Yes, exactly.  

Thanks,
Miao

> From: Juergen Schoenwaelder [mailto:[email-masked]] 
> Sent: Tuesday, December 19, 2006 12:58 AM
> To: David Harrington
> Cc: 'Rainer Gerhards'; 'Chris Lonvick'; 'Miao Fuyou'; [email-masked]
> Subject: Re: [Syslog] RE: Framing...
> 
> Perhaps also consider to change FRAME-LEN to MSG-LEN to 
> better reflect the purpose of the value.
> 
> /js
> 
> --