Subject: [Syslog] RFC 3164 in syslog-sign?

From: Chris Lonvick <[email-masked]>
Date: Wed, 20 Dec 2006 18:19:57 -0800 (PST)

Hi,

We started syslog-sign before we had Structured Data, and the original 
author was creating a mechanism that could be used within the RFC 3164 
framework.  However, times have changed.  We now have syslog-protocol with 
SDs.

Does the WG feel that syslog-sign should contain normative information on 
how to utilize the syslog-sign mechanism in the RFC 3164 format?

Answers can be:
__ Yes - leave it, it forms a bridge for transition,
__ No - take it out, we need to move the world along,
__ Maybe - move it to a non-normative appendix

Thanks,
Chris

---------- Forwarded message ----------
Date: Wed, 20 Dec 2006 15:51:25 +0100
From: Rainer Gerhards <[email-masked]>
To: Chris Lonvick <[email-masked]>
Cc: [email-masked]
Subject: RE: APP-NAME,
     PROCID and MSGID in syslog sign - was: RE: [Syslog] clonvick WGLC Review of
     draft-ietf-syslog-sign-20.txt

Chris,

> -----Original Message-----
> From: Chris Lonvick [mailto:[email-masked]]
> Sent: Wednesday, December 20, 2006 3:37 PM
> To: Rainer Gerhards
> Cc: [email-masked]
> Subject: APP-NAME, PROCID and MSGID in syslog sign - was: RE: [Syslog]
> clonvick WGLC Review of draft-ietf-syslog-sign-20.txt

---some elided for brevity---

With RFC 3164 syslog, we obviously can not totally be assured that the
SD-ID will be valid. But we should keep in mind that we most probably
will try to obsolete 3164 either via -protocol or a follow-up RFC. I
already questioned the point in supporting this (informational!)
document in a new standard. Is this really a wise idea?

Rainer
---remainder elided for brevity---

_______________________________________________
Syslog mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/syslog

---

From: Miao Fuyou <[email-masked]>
Date: Thu, 21 Dec 2006 11:48:09 +0800

Option 2 may be a better choice for a cohesive set of Syslog specifications.
And, a seperated informational document can be included as work item when
rechartering to address the 3164 signature issue. Is it possible? The
drawback is the implementer has to do something different for -protocol and
3164.

Thanks,
Miao

> Sent: Thursday, December 21, 2006 10:20 AM
> To: [email-masked]
> Subject: [Syslog] RFC 3164 in syslog-sign?
> 
> Hi,
> 
> We started syslog-sign before we had Structured Data, and the 
> original author was creating a mechanism that could be used 
> within the RFC 3164 framework.  However, times have changed.  
> We now have syslog-protocol with SDs.
> 
> Does the WG feel that syslog-sign should contain normative 
> information on how to utilize the syslog-sign mechanism in 
> the RFC 3164 format?
> 
> Answers can be:
> __ Yes - leave it, it forms a bridge for transition, __ No - 
> take it out, we need to move the world along, __ Maybe - move 
> it to a non-normative appendix
> 
> Thanks,
> Chris
> 
> 
> 
> With RFC 3164 syslog, we obviously can not totally be assured 
> that the SD-ID will be valid. But we should keep in mind that 
> we most probably will try to obsolete 3164 either via 
> -protocol or a follow-up RFC. I already questioned the point 
> in supporting this (informational!) document in a new 
> standard. Is this really a wise idea?
> 
> Rainer

---

From: "Rainer Gerhards" <[email-masked]>
Date: Thu, 21 Dec 2006 08:01:18 +0100

Chris,

I would prefer

> __ No - take it out, we need to move the world along,

as this removes a lot of complexity and guesswork. It will also be
cleaner if rfc3164 is actually obsoleted by -syslog-protocol. 

If that is not WG consensus, I would recommend
> __ Maybe - move it to a non-normative appendix

As a formal note, I am not sure if we can create normative text based on
a non-normative document (rfc 3164). This sounds kind of wrong to me...

Rainer

> Sent: Thursday, December 21, 2006 3:20 AM
> To: [email-masked]

---

From: Balazs Scheidler <[email-masked]>
Date: Thu, 21 Dec 2006 09:08:23 +0100

> __ Maybe - move it to a non-normative appendix

No. We should give reasons to migrate to the new protocol, syslog-sign
might be one of them, and I doubt there'd be real-world implementations
of syslog-sign over RFC3164

-- 
Bazsi