Subject: [Syslog] certificate version question

From: "Rainer Gerhards" <[email-masked]>
Date: Mon, 26 May 2008 11:46:26 +0200

Hi all,

maybe a dumb question: is any certificate version to be supported. Or is
it x.509 v3 or v3+ only? I am asking because some of the references seem
to be assume v3. I have to admit I do not know what is the difference
between e.g. v2 and v3, and so I thought I just ask...

So far I accept any version, as long as it has the required fields.

Rainer
_______________________________________________
Syslog mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/syslog

---

From: <[email-masked]>
Date: Mon, 26 May 2008 14:42:29 +0300

TLS supports only X509v3 certificates (*) -- but this doesn't 
really matter, because nobody has used v1 or v2 in ages.

(* It also supports OpenPGP certificates, but I guess this
detail isn't relevant here.)

Best regards,
Pasi 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of ext Rainer Gerhards
> Sent: 26 May, 2008 12:46
> To: [email-masked]
> Subject: [Syslog] certificate version question
> 
> Hi all,
> 
> maybe a dumb question: is any certificate version to be
> supported. Or is it x.509 v3 or v3+ only? I am asking because some
> of the references seem to be assume v3. I have to admit I do not
> know what is the difference between e.g. v2 and v3, and so I thought
> I just ask...
>

---

From: "Rainer Gerhards" <[email-masked]>
Date: Mon, 26 May 2008 13:48:38 +0200

> From: [email-masked] [mailto:[email-masked]]
> Sent: Monday, May 26, 2008 1:42 PM
> To: Rainer Gerhards; [email-masked]
> Subject: RE: [Syslog] certificate version question
> 

OK, as I said: a dumb question ;)

> detail isn't relevant here.)

Well... I think there is no MUST NOT in -transport-tls that prohibits to
use them? I am thinking about adding support for them as an extended
option.

Rainer