Subject: [webfinger] OpenID Connect now using WebFinger

From: Mike Jones <[email-masked]>
Date: Wed, 23 Jan 2013 17:10:34 +0000

FYI, for its most recent specification release, the OpenID Connect working group decided to switch from using Simple Web Discovery to WebFinger for identity provider discovery, since WebFinger now meets the OpenID Connect discovery requirements previously discussed in the working group.  See http://self-issued.info/?p=937 and http://openid.net/specs/openid-connect-discovery-1_0-12.html for details.

                                                            -- Mike

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 23 Jan 2013 10:12:39 -0700

On 1/23/13 10:10 AM, Mike Jones wrote:
> FYI, for its most recent specification release, the OpenID Connect 
> working group decided to switch from using Simple Web Discovery to 
> WebFinger for identity provider discovery, since WebFinger now
> meets the OpenID Connect discovery requirements previously
> discussed in the working group.  See http://self-issued.info/?p=937
> and http://openid.net/specs/openid-connect-discovery-1_0-12.html
> for details.

Mike, thanks for the information!

Peter

- -- 
Peter Saint-Andre
https://stpeter.im/

---

From: Mike Jones <[email-masked]>
Date: Wed, 23 Jan 2013 17:15:27 +0000

Oh, and I should add, it's now using the acct: scheme as well.

				-- Mike

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Peter Saint-Andre
Sent: Wednesday, January 23, 2013 9:13 AM
To: [email-masked]
Subject: Re: [webfinger] OpenID Connect now using WebFinger

On 1/23/13 10:10 AM, Mike Jones wrote:
> WebFinger for identity provider discovery, since WebFinger now meets 
> the OpenID Connect discovery requirements previously discussed in the 
> working group.  See http://self-issued.info/?p=937 and 
> http://openid.net/specs/openid-connect-discovery-1_0-12.html
> for details.

Peter

- --
Peter Saint-Andre
https://stpeter.im/

_______________________________________________
webfinger mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/webfinger

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 23 Jan 2013 10:17:36 -0700

> Oh, and I should add, it's now using the acct: scheme as well.

Even better. I'll update draft-ietf-appsawg-acct-uri accordingly. :-)

Peter

- -- 
Peter Saint-Andre
https://stpeter.im/

---

From: Gonzalo Salgueiro <[email-masked]>
Date: Wed, 23 Jan 2013 12:18:35 -0500

Great to hear, Mike.  A single discovery mechanism was the goal, so thanks for helping to make that happen.

Cheers,

Gonzalo

---

From: Brad Fitzpatrick <[email-masked]>
Date: Wed, 23 Jan 2013 09:56:15 -0800

Nice!  This is great news.

On Wed, Jan 23, 2013 at 9:15 AM, Mike Jones <[email-masked]>wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG/MacGPG2 v2.0.18 (Darwin)
> Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/
>
> iEYEARECAAYFAlEAGgcACgkQNL8k5A2w/vzhVwCfcfKCb+ToW3bK35zFEQs8621T
> t/AAoPZA8/hNd0eID0vfUsmgPNQ6RwaW
> =MM7d
> -----END PGP SIGNATURE-----

---

From: Evan Prodromou <[email-masked]>
Date: Wed, 23 Jan 2013 13:17:27 -0500

Awesome news!

-Evan

On Wed 23 Jan 2013 12:56:15 PM EST, Brad Fitzpatrick wrote:
> On Wed, Jan 23, 2013 at 9:15 AM, Mike Jones
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     From: [email-masked]
>     <mailto:[email-masked]>
>     [mailto:[email-masked]
>     <mailto:[email-masked]>] On Behalf Of Peter Saint-Andre
>     To: [email-masked] <mailto:[email-masked]>
>     [email-masked] <mailto:[email-masked]>
>     [email-masked] <mailto:[email-masked]>

---

From: Barry Leiba <[email-masked]>
Date: Wed, 23 Jan 2013 15:49:55 -0500

> Even better. I'll update draft-ietf-appsawg-acct-uri accordingly. :-)

...which means adding an "Implementation Status" section, yes?
:-)

Barry

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 23 Jan 2013 13:56:16 -0700

On 1/23/13 1:49 PM, Barry Leiba wrote:
> ...which means adding an "Implementation Status" section, yes? :-)

If draft-farrell-ft itself gets fast-tracked to RFC, perchance. Is
there running code for that spec? ;-)

Peter

- -- 
Peter Saint-Andre
https://stpeter.im/

---

From: Barry Leiba <[email-masked]>
Date: Wed, 23 Jan 2013 15:58:13 -0500

> there running code for that spec? ;-)

No, that's different.  I'm talking about Yaron Sheffer's draft,
https://datatracker.ietf.org/doc/draft-sheffer-running-code/

Much simpler, and more useful.

b

---

From: Melvin Carvalho <[email-masked]>
Date: Wed, 23 Jan 2013 23:17:30 +0100

> for helping to make that happen.

There is no single discovery mechanism on the web.  But consolodation is
beneficial to developers.  Good stuff.

> WebFinger for identity provider discovery, since WebFinger now meets the
> OpenID Connect discovery requirements previously discussed in the working
> group.  See http://self-issued.info/?p=937 and
> http://openid.net/specs/openid-connect-discovery-1_0-12.html for details.
> >
> >                                                             -- Mike
> >