Subject: [webfinger] The "expires" member of the JRD

From: "Paul E. Jones" <[email-masked]>
Date: Thu, 7 Feb 2013 15:28:59 -0500

Folks,

Questions have been raised about the "expires" member of the JRD two or
three times now, with concerns related to the fact that HTTP has multiple
ways of also indicating how long a resource representation should be cached.

This element is exists for historical reason, but it's not clear to me if
anyone is using it or cares to use it.

Shall we keep it or just remove it from the spec entirely?

Paul

---

From: Brad Fitzpatrick <[email-masked]>
Date: Thu, 7 Feb 2013 12:35:14 -0800

I'd be happy seeing it removed.

HTTP seems sufficient.

On Thu, Feb 7, 2013 at 12:28 PM, Paul E. Jones <[email-masked]>wrote:

> Folks,****
>
> ** **
>
> Questions have been raised about the “expires” member of the JRD two or
> ****
> ** **
> This element is exists for historical reason, but it’s not clear to me if
> anyone is using it or cares to use it.****
>
> ** **
>
> Shall we keep it or just remove it from the spec entirely?****
>
> ** **
>
> Paul****
>
> ** **
>
> --
>
> ---
> You received this message because you are subscribed to the Google Groups
> "WebFinger" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to [email-masked].
> For more options, visit https://groups.google.com/groups/opt_out.
>
>
>

---

From: Gonzalo Salgueiro <[email-masked]>
Date: Thu, 7 Feb 2013 15:36:06 -0500

+1

Gonzalo

On Feb 7, 2013, at 3:35 PM, Brad Fitzpatrick <[email-masked]> wrote:

> On Thu, Feb 7, 2013 at 12:28 PM, Paul E. Jones <[email-masked]> wrote:
> Folks,
> 
>  
> 
> Questions have been raised about the “expires” member of the JRD two or three times now, with concerns related to the fact that HTTP has multiple ways of also indicating how long a resource representation should be cached.
> 
>  
> 
> This element is exists for historical reason, but it’s not clear to me if anyone is using it or cares to use it.
> 
>  
> 
> You received this message because you are subscribed to the Google Groups "WebFinger" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to [email-masked].
> _______________________________________________
> webfinger mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/webfinger

---

From: Tim Bray <[email-masked]>
Date: Thu, 7 Feb 2013 12:52:21 -0800

+1

---

From: John Bradley <[email-masked]>
Date: Thu, 7 Feb 2013 16:21:53 -0700

Yes it is a XRI legacy.  Get rid of it. 

John B.

On 2013-02-07, at 1:52 PM, Tim Bray <[email-masked]> wrote:

> +1
> 
> 
> On Thu, Feb 7, 2013 at 12:35 PM, Brad Fitzpatrick <[email-masked]> wrote:

---

From: Mike Jones <[email-masked]>
Date: Thu, 7 Feb 2013 23:55:28 +0000

+1

From: [email-masked] [mailto:[email-masked]] On Behalf Of John Bradley
Sent: Thursday, February 07, 2013 3:22 PM
To: [email-masked]
Cc: Brad Fitzpatrick; [email-masked]
Subject: Re: [webfinger] The "expires" member of the JRD

John B.

On 2013-02-07, at 1:52 PM, Tim Bray <[email-masked]<mailto:[email-masked]>> wrote:

+1

On Thu, Feb 7, 2013 at 12:35 PM, Brad Fitzpatrick <[email-masked]<mailto:[email-masked]>> wrote:
I'd be happy seeing it removed.

HTTP seems sufficient.

On Thu, Feb 7, 2013 at 12:28 PM, Paul E. Jones <[email-masked]<mailto:[email-masked]>> wrote:
Folks,

Questions have been raised about the "expires" member of the JRD two or three times now, with concerns related to the fact that HTTP has multiple ways of also indicating how long a resource representation should be cached.

This element is exists for historical reason, but it's not clear to me if anyone is using it or cares to use it.

Paul

--

---
You received this message because you are subscribed to the Google Groups "WebFinger" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email-masked]<mailto:[email-masked]>.
For more options, visit https://groups.google.com/groups/opt_out.

_______________________________________________
webfinger mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/webfinger

--

---
You received this message because you are subscribed to the Google Groups "WebFinger" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email-masked]<mailto:[email-masked]>.
For more options, visit https://groups.google.com/groups/opt_out.

---

From: "Paul E. Jones" <[email-masked]>
Date: Thu, 7 Feb 2013 22:30:46 -0500

Seems to be overwhelming support.  It's gone.

From: [email-masked] [mailto:[email-masked]] On
Behalf Of Mike Jones
Sent: Thursday, February 07, 2013 6:55 PM
To: John Bradley; [email-masked]
Cc: Brad Fitzpatrick; [email-masked]
Subject: RE: [webfinger] The "expires" member of the JRD

+1

From: [email-masked] [mailto:[email-masked]] On
Behalf Of John Bradley

John B.

+1

On Thu, Feb 7, 2013 at 12:35 PM, Brad Fitzpatrick <[email-masked]>
wrote:

HTTP seems sufficient.

On Thu, Feb 7, 2013 at 12:28 PM, Paul E. Jones <[email-masked]>
wrote:

Folks,

Paul

-- 
 
--- 
You received this message because you are subscribed to the Google Groups
"WebFinger" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to [email-masked]
<mailto:[email-masked]> .
For more options, visit https://groups.google.com/groups/opt_out.

 

-- 
 
--- 

-- 
 
---

---

From: Evan Prodromou <[email-masked]>
Date: Fri, 08 Feb 2013 09:29:12 -0500

Unless there are earth-shatteringly critical problems with the spec, I 
feel like it's time to ship what we've got.

The presence or absence of the optional "expires" element in JRD is of 
microscopic importance; let's get this thing out.

-Evan

On 13-02-07 03:28 PM, Paul E. Jones wrote:
>
> Folks,
>
> Questions have been raised about the "expires" member of the JRD two 
> or three times now, with concerns related to the fact that HTTP has 
> multiple ways of also indicating how long a resource representation 
> should be cached.
>
> This element is exists for historical reason, but it's not clear to me 
> if anyone is using it or cares to use it.
>

---

From: "Paul E. Jones" <[email-masked]>
Date: Fri, 8 Feb 2013 10:14:52 -0500

It took me only few seconds to remove.  If nobody is using it, I agree we
should remove it.

I'll get out a new version within 12 hours.

Paul

From: [email-masked] [mailto:[email-masked]] On
Behalf Of Evan Prodromou
Sent: Friday, February 08, 2013 9:29 AM
To: Paul E. Jones
Cc: [email-masked]; [email-masked]
Subject: Re: [webfinger] The "expires" member of the JRD

Unless there are earth-shatteringly critical problems with the spec, I feel
like it's time to ship what we've got.

-Evan

Folks,

Paul

---

From: nov matake <[email-masked]>
Date: Sat, 9 Feb 2013 00:32:39 +0900

My webfinger ruby gem is using "expires" parameter for built-in caching mechanism,
but I think it's not too late to remove the functionality from my library.
So I'm +1 for simplifying spec by removing it.

ps.
It tooks few minutes to remove them from my gem :p

On 2013/02/09, at 0:14, "Paul E. Jones" <[email-masked]> wrote:

> It took me only few seconds to remove.  If nobody is using it, I agree we should remove it.
>  
> I’ll get out a new version within 12 hours.
>  
> Paul
>  
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Evan Prodromou
> Unless there are earth-shatteringly critical problems with the spec, I feel like it's time to ship what we've got.
> 
> The presence or absence of the optional "expires" element in JRD is of microscopic importance; let's get this thing out.
> 
> -Evan
>

---

From: nov matake <[email-masked]>
Date: Sat, 9 Feb 2013 00:37:39 +0900

# Oops, I've replied from wrong email address and rejected by google groups.
# Sending from correct one again.

ps.