Subject: [webfinger] Renaming the "resource" parameter

From: "Paul E. Jones" <[email-masked]>
Date: Thu, 7 Feb 2013 15:48:14 -0500

Folks,

In the most recent round of edits (I hope to publish tomorrow) I made a pass
through the text to try to use the word "resource" or "WebFinger resource"
rather than "WebFinger server" where it made sense.  ("Server" is still
used, but hopefully only when speaking of the web server itself.)

But, as I did that, I noticed that in at least one place the word "resource"
(referring to the parameter that gets passed in) seemed to make the text
confusing.  I put quotes around "resource" when I'm referring to the
parameter.

The question is this: should we rename the "resource" parameter to something
else?

SWD used "principal" and the JRD uses the term "subject".  I think either of
those would work as alternatives.

Or, shall we continue with "resource"?  I think it's worded so that it's not
confusing now, but I'm probably a poor judge of that since I know is meant.

Paul

---

From: Tim Bray <[email-masked]>
Date: Thu, 7 Feb 2013 12:53:09 -0800

“resource” is fine. -T

On Thu, Feb 7, 2013 at 12:48 PM, Paul E. Jones <[email-masked]>wrote:

> Folks,****
>
> ** **
>
> In the most recent round of edits (I hope to publish tomorrow) I made a
> pass through the text to try to use the word “resource” or “WebFinger
> resource” rather than “WebFinger server” where it made sense.  (“Server” is
> still used, but hopefully only when speaking of the web server itself.)***
> *
>
> ** **
>
> But, as I did that, I noticed that in at least one place the word
> “resource” (referring to the parameter that gets passed in) seemed to make
> the text confusing.  I put quotes around “resource” when I’m referring to
> the parameter.****
>
> ** **
>
> The question is this: should we rename the “resource” parameter to
> something else?****
>
> ** **
>
> SWD used “principal” and the JRD uses the term “subject”.  I think either
> of those would work as alternatives.****
>
> ** **
>
> Or, shall we continue with “resource”?  I think it’s worded so that it’s
> not confusing now, but I’m probably a poor judge of that since I know is
> meant.****
>
> ** **
>
> Paul****
>
> ** **
>
> _______________________________________________
> webfinger mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/webfinger
>
>

---

From: Brad Fitzpatrick <[email-masked]>
Date: Thu, 7 Feb 2013 12:53:11 -0800

I like "subject".

I dislike "principal".

I also don't really care.

On Thu, Feb 7, 2013 at 12:48 PM, Paul E. Jones <[email-masked]>wrote:

> --
> ---
> You received this message because you are subscribed to the Google Groups
> "WebFinger" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to [email-masked].
> For more options, visit https://groups.google.com/groups/opt_out.
>
>
>

---

From: Gonzalo Salgueiro <[email-masked]>
Date: Thu, 7 Feb 2013 15:59:42 -0500

At this point "resource" is cemented in my mind as the name for the parameter.  My preference is  to stick with it.  Using quotes seems a sufficient clarification of its usage as a parameter.

Gonzalo

On Feb 7, 2013, at 3:48 PM, Paul E. Jones <[email-masked]> wrote:

> Folks,
>  
> In the most recent round of edits (I hope to publish tomorrow) I made a pass through the text to try to use the word “resource” or “WebFinger resource” rather than “WebFinger server” where it made sense.  (“Server” is still used, but hopefully only when speaking of the web server itself.)
>  
> But, as I did that, I noticed that in at least one place the word “resource” (referring to the parameter that gets passed in) seemed to make the text confusing.  I put quotes around “resource” when I’m referring to the parameter.
>  
> The question is this: should we rename the “resource” parameter to something else?
>  
> SWD used “principal” and the JRD uses the term “subject”.  I think either of those would work as alternatives.
>  
> Or, shall we continue with “resource”?  I think it’s worded so that it’s not confusing now, but I’m probably a poor judge of that since I know is meant.
>  
> Paul
>

---

From: Mike Jones <[email-masked]>
Date: Fri, 8 Feb 2013 03:30:31 +0000

I wouldn't rename it at this point "resource" is fine.

				-- Mike

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Gonzalo Salgueiro
Sent: Thursday, February 07, 2013 1:00 PM
To: Paul E. Jones
Cc: [email-masked]; [email-masked]
Subject: Re: [webfinger] Renaming the "resource" parameter

Gonzalo

On Feb 7, 2013, at 3:48 PM, Paul E. Jones <[email-masked]> wrote:

> Folks,
>  
> In the most recent round of edits (I hope to publish tomorrow) I made a pass through the text to try to use the word "resource" or "WebFinger resource" rather than "WebFinger server" where it made sense.  ("Server" is still used, but hopefully only when speaking of the web server itself.)
>  
> But, as I did that, I noticed that in at least one place the word "resource" (referring to the parameter that gets passed in) seemed to make the text confusing.  I put quotes around "resource" when I'm referring to the parameter.
>  
> The question is this: should we rename the "resource" parameter to something else?
>  
> SWD used "principal" and the JRD uses the term "subject".  I think either of those would work as alternatives.
>  
> Or, shall we continue with "resource"?  I think it's worded so that it's not confusing now, but I'm probably a poor judge of that since I know is meant.
>  
> Paul
>

---

From: Evan Prodromou <[email-masked]>
Date: Fri, 08 Feb 2013 09:29:48 -0500

-1, it's good enough, no change.

-Evan

On 13-02-07 03:48 PM, Paul E. Jones wrote:
>
> Folks,
>
> In the most recent round of edits (I hope to publish tomorrow) I made 
> a pass through the text to try to use the word "resource" or 
> "WebFinger resource" rather than "WebFinger server" where it made 
> sense.  ("Server" is still used, but hopefully only when speaking of 
> the web server itself.)
>
> "resource" (referring to the parameter that gets passed in) seemed to 
> make the text confusing.  I put quotes around "resource" when I'm 
> referring to the parameter.
>
> SWD used "principal" and the JRD uses the term "subject".  I think 
> either of those would work as alternatives.
>
> Or, shall we continue with "resource"?  I think it's worded so that 
> it's not confusing now, but I'm probably a poor judge of that since I 
> know is meant.
>
> Paul
>
>
>

---

From: "Paul E. Jones" <[email-masked]>
Date: Fri, 8 Feb 2013 10:00:32 -0500

Ok, we'll leave the parameter name alone.

From: Evan Prodromou [mailto:[email-masked]] 
Sent: Friday, February 08, 2013 9:30 AM
To: Paul E. Jones
Cc: [email-masked]; [email-masked]
Subject: Re: [webfinger] Renaming the "resource" parameter

-Evan

Folks,

Paul