Subject: [webfinger] webfinger node.js module

From: Evan Prodromou <[email-masked]>
Date: Tue, 05 Feb 2013 15:57:32 -0500

The webfinger node.js module in npm now supports draft 09 of the spec.

     https://npmjs.org/package/webfinger

node.js users should be able to install it with

     npm install webfinger

I'm looking forward to testing it with other implementations.

-Evan

-- 
Evan Prodromou, e14n Inc.
1124 rue Marie-Anne Est #32, Montreal, Quebec, Canada H2J 2B7
E: [email-masked] P: +1-514-554-3826

---

From: Gonzalo Salgueiro <[email-masked]>
Date: Tue, 5 Feb 2013 16:19:41 -0500

Cool!  Thanks for doing this Evan.  It would be good to do some interop once we hit steady state on the draft (which it appears we are mercifully getting close to :-)

Cheers,

Gonzalo

On Feb 5, 2013, at 3:57 PM, Evan Prodromou <[email-masked]> wrote:

> _______________________________________________
> webfinger mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/webfinger
>

---

From: Evan Prodromou <[email-masked]>
Date: Tue, 05 Feb 2013 16:46:55 -0500

I see that the Ruby gem named 'webfinger' is also tracking the spec:

    https://github.com/nov/webfinger

The package named 'webfinger' in pypi (the Python repository) isn't:

    https://github.com/jcarbaugh/python-webfinger/

...and there's one for Perl that doesn't seem to be tracking, either:

    http://search.cpan.org/~tobyink/WWW-Finger-0.104/lib/WWW/Finger/Webfinger.pm

I'm guessing that the ones that do start tracking will either a) use RFC 
6415 and fall back to the relatively unimplemented new spec or b) vice 
versa.

There may be some that do only one or the other.

-Evan

---

From: James M Snell <[email-masked]>
Date: Tue, 5 Feb 2013 13:51:06 -0800

My webfinger-jrd rubygem provides an impl of the jrd format, not full
webfinger tho.

  https://rubygems.org/gems/webfinger-jrd

On Tue, Feb 5, 2013 at 1:46 PM, Evan Prodromou <[email-masked]> wrote:

> On Feb 5, 2013, at 3:57 PM, Evan Prodromou <[email-masked]> <[email-masked]> wrote:
>
>
> webfinger mailing [email-masked]://www.ietf.org/mailman/listinfo/webfinger
>
>
>
> --

---

From: Gonzalo Salgueiro <[email-masked]>
Date: Tue, 5 Feb 2013 16:58:43 -0500

Thanks for the update.  Inline...

> http://search.cpan.org/~tobyink/WWW-Finger-0.104/lib/WWW/Finger/Webfinger.pm

There are Perl packages that are tracking the current spec.

> I'm guessing that the ones that do start tracking will either a) use RFC 6415 and fall back to the relatively unimplemented new spec or b) vice versa.

> There may be some that do only one or the other.

Most I know do one or the other but if there is fallback I certainly hope it is your vice versa option.

--G

>> On Feb 5, 2013, at 3:57 PM, Evan Prodromou 
>> <[email-masked]>
>>  wrote:
>> 
>> 
>>> E: 
>>> [email-masked]
>>>  P: +1-514-554-3826

---

From: ☮ elf Pavlik ☮ <[email-masked]>
Date: Wed, 06 Feb 2013 08:32:33 +0000

> I'm looking forward to testing it with other implementations.
great! thanks for sharing it Evan :)