Subject: [webfinger] Properties in WebFinger

From: "Paul E. Jones" <[email-masked]>
Date: Mon, 4 Mar 2013 11:56:23 -0500

Folks,

One of the features in WebFinger is the ability to define “properties” related to either a subject or a link.

I would expect properties defined for a link to be defined as a part of the link relation definition.

Properties that relate to the subject would be defined in separate RFCs or could be defined by other SDOs or anyone else, as properties are always fully-qualified URIs.

As an example, consider the following example:

  "properties" :

  {

    "http://packetizer.com/ns/name" : "Paul E. Jones",

    "http://packetizer.com/ns/name#zh-CN" : "保罗‧琼斯"

  }

The “name” property is intended to convey the subject’s name with an optional language tag as a URI fragment.  This is not defined anywhere, except here: http://packetizer.com/ns/name

A question to the group is this: do we need to define a registry for property values defined for a subject?  The current WF spec does not define a registry.  Would we want to define one?  If so, should that go into the current draft?  (I appreciate that this has gone to Last Call, so I’ll apologize for not raising this before.)  If we did, what would the URIs look like?  Does the IETF or IANA have a URI defined for this sort of thing?

Paul

---

From: James M Snell <[email-masked]>
Date: Mon, 4 Mar 2013 09:06:22 -0800

I would suggest holding off and waiting to see if a registry is
necessary... maybe just see how adoption goes over the next few months then
decide.
On Mar 4, 2013 8:56 AM, "Paul E. Jones" <[email-masked]> wrote:

> Folks,****
>
> ** **
>
> One of the features in WebFinger is the ability to define “properties”
> related to either a subject or a link.****
>
> ** **
>
> I would expect properties defined for a link to be defined as a part of
> the link relation definition.****
>
> ** **
>
> Properties that relate to the subject would be defined in separate RFCs or
> could be defined by other SDOs or anyone else, as properties are always
> fully-qualified URIs.****
>
> ** **
>
> As an example, consider the following example:****
>
> ** **
>
>   "properties" :****
>
>   {****
>
>     "http://packetizer.com/ns/name" : "Paul E. Jones",****
>
>     "http://packetizer.com/ns/name#zh-CN" : "保罗‧琼斯"****
>
>   }****
>
> ** **
>
> The “name” property is intended to convey the subject’s name with an
> optional language tag as a URI fragment.  This is not defined anywhere,
> except here: http://packetizer.com/ns/name****
>
> ** **
>
> A question to the group is this: do we need to define a registry for
> property values defined for a subject?  The current WF spec does not define
> a registry.  Would we want to define one?  If so, should that go into the
> current draft?  (I appreciate that this has gone to Last Call, so I’ll
> apologize for not raising this before.)  If we did, what would the URIs
> look like?  Does the IETF or IANA have a URI defined for this sort of thing?
> ****
>
> ** **
>
> Paul****
>
> ** **
>
> _______________________________________________
> webfinger mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/webfinger
>
>

---

From: Melvin Carvalho <[email-masked]>
Date: Mon, 4 Mar 2013 18:10:13 +0100

> look like?  Does the IETF or IANA have a URI defined for this sort of thing?

This is very similar to the @property element in HTML5

Generally what you would do is 'follow your nose' from the property URL to
the description (via HTTP GET).

You could start a registry if you wanted, but it's been done a few times
already, e.g. schema.org, foaf, vcard, open graph protocol ... do we want
another one to maintain, and where would it be specified, who would look
after it etc.

Is the XRD group still active, maybe they have something to say about JRD
standardization?

> ****
>
> ** **
>
> Paul****
>
> ** **
>
> --
>
> ---
> You received this message because you are subscribed to the Google Groups
> "WebFinger" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to [email-masked].
> For more options, visit https://groups.google.com/groups/opt_out.
>
>
>

---

From: Melvin Carvalho <[email-masked]>
Date: Mon, 4 Mar 2013 18:12:36 +0100

>     "http://packetizer.com/ns/name#zh-CN" : "保罗‧琼斯"****

Very minor comment, would it not be better to put the properties under
HTTPS?

---

From: "Paul E. Jones" <[email-masked]>
Date: Mon, 4 Mar 2013 15:00:44 -0500

Melvin,

A Property UI is just a “name”, so it names no difference if it were a URN an HTTP URI or HTTPS URI.

Paul

From: [email-masked] [mailto:[email-masked]] On Behalf Of Melvin Carvalho
Sent: Monday, March 04, 2013 12:13 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [webfinger] Properties in WebFinger

Folks,

  "properties" :

  {

  }

Very minor comment, would it not be better to put the properties under HTTPS?

Paul

-- 
 
--- 
You received this message because you are subscribed to the Google Groups "WebFinger" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email-masked] <mailto:[email-masked]> .
For more options, visit https://groups.google.com/groups/opt_out.

---

From: Melvin Carvalho <[email-masked]>
Date: Mon, 4 Mar 2013 21:05:04 +0100

On 4 March 2013 21:00, Paul E. Jones <[email-masked]> wrote:

> Melvin,****

Sure, I just meant that since WF is https oriented, it might be an idea to
use https for these fields too.  In the linked data world most
schemas/vocabs/descriptions are http, but we are finding for some projects
(particularly security oriented ones such as payments) putting things under
https gives a bit more piece of mind and future proofing... :)

> ****
>
> ** **
>
> Paul****
>
> ** **
>
> *From:* [email-masked] [mailto:[email-masked]] *On
> Behalf Of *Melvin Carvalho
> *Sent:* Monday, March 04, 2013 12:13 PM
> *To:* [email-masked]
> *Cc:* [email-masked]
> *Subject:* Re: [webfinger] Properties in WebFinger****
>
> ** **
>
> ** **
>
> On 4 March 2013 17:56, Paul E. Jones <[email-masked]> wrote:****
>
> Folks,****
>
>  ****
>

---

From: Kingsley Idehen <[email-masked]>
Date: Mon, 04 Mar 2013 15:38:39 -0500

On 3/4/13 3:00 PM, Paul E. Jones wrote:
>
> Melvin,
>
> A Property UI is just a "name", so it names no difference if it were a 
> URN an HTTP URI or HTTPS URI.
>

You mean a property name is just a URI? And that a URI just names the 
property?

If the above is true, then there's a subtlety that's being overlooked if 
the URI in question resolves to content the describes its referent i.e., 
the content can take the form of an entity relationship graph 
representing human- and machine-comprehensible entity relationship 
semantics.

Simple example: a URI denoting a property that's inversefunctional in 
nature e.g., the semantics of an property that associates one of more 
Agent URIs with an Email Address (mailto: scheme URI).

Links:

1. http://bit.ly/Y6TIfs -- how entity relationship semantics enable 
identity reconciliation .

Kingsley
>
> Paul
>
> *From:[email-masked] [mailto:[email-masked]] 
> *On Behalf Of *Melvin Carvalho
> *Subject:* Re: [webfinger] Properties in WebFinger
>
> On 4 March 2013 17:56, Paul E. Jones <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
> Folks,
>
> One of the features in WebFinger is the ability to define "properties" 
> related to either a subject or a link.
>
> Properties that relate to the subject would be defined in separate 
> RFCs or could be defined by other SDOs or anyone else, as properties 
> are always fully-qualified URIs.
>
>     "http://packetizer.com/ns/name#zh-CN" : "?????"
>
>   }
>
>
>     The "name" property is intended to convey the subject's name with
>     an optional language tag as a URI fragment.  This is not defined
>     anywhere, except here: http://packetizer.com/ns/name
>
>     A question to the group is this: do we need to define a registry
>     for property values defined for a subject?  The current WF spec
>     does not define a registry.  Would we want to define one?  If so,
>     should that go into the current draft?  (I appreciate that this
>     has gone to Last Call, so I'll apologize for not raising this
>     before.)  If we did, what would the URIs look like?  Does the IETF
>     or IANA have a URI defined for this sort of thing?
>
>     Paul
>
>     -- 
>
>     ---
>     To unsubscribe from this group and stop receiving emails from it,
>     send an email to [email-masked]
>     <mailto:[email-masked]>.

-- 

Regards,

Kingsley Idehen	
Founder & CEO
OpenLink Software
Company Web: http://www.openlinksw.com
Personal Weblog: http://www.openlinksw.com/blog/~kidehen
Twitter/Identi.ca handle: @kidehen
Google+ Profile: https://plus.google.com/112399767740508618350/about
LinkedIn Profile: http://www.linkedin.com/in/kidehen

---

From: "Paul E. Jones" <[email-masked]>
Date: Mon, 4 Mar 2013 18:07:07 -0500

Kingsley,

A property consists of a name and value.  The name of the property is a URI.  The value is defined by whatever defines the property name.  Presently, there are no properties defined in the WF spec.  Only the syntax is defined.  An example of a property is:

   -----------------------------     -------------

                |                           |

          Property Name             Property Value

What I was asking is whether we want to define a registry for property names.  For example, perhaps urn:ietf:params:webfinger:<property_name> or something.

Paul

From: [email-masked] [mailto:[email-masked]] On Behalf Of Kingsley Idehen
Sent: Monday, March 04, 2013 3:39 PM
To: [email-masked]
Subject: Re: [webfinger] Properties in WebFinger

Melvin,

You mean a property name is just a URI? And that a URI just names the property? 

If the above is true, then there's a subtlety that's being overlooked if the URI in question resolves to content the describes its referent i.e., the content can take the form of an entity relationship graph representing human- and machine-comprehensible entity relationship semantics. 

Simple example: a URI denoting a property that's inversefunctional in nature e.g., the semantics of an property that associates one of more Agent URIs with an Email Address (mailto: scheme URI). 

Links:

1. http://bit.ly/Y6TIfs -- how entity relationship semantics enable identity reconciliation .

Kingsley 

Paul

 

Folks,

  "properties" :

  {

  }

 

Paul

-- 
 
--- 

-- 
 
Regards,
 
Kingsley Idehen             
Founder & CEO 
OpenLink Software

---

From: Nat Sakimura <[email-masked]>
Date: Tue, 12 Mar 2013 01:09:37 +0900

FYI, this looks very similar to Claims in OpenID Connect.
We use language-script tag to express it the same way you do.
http://openid.bitbucket.org/openid-connect-messages-1_0.html#StandardClaims

JWT defines a registry for public claim names.
http://tools.ietf.org/html/draft-ietf-oauth-json-web-token-06#section-9.1

Nat

2013/3/5 Paul E. Jones <[email-masked]>

-- 
Nat Sakimura (=nat)
Chairman, OpenID Foundation
http://nat.sakimura.org/
@_nat_en

---

From: "Paul E. Jones" <[email-masked]>
Date: Mon, 11 Mar 2013 13:15:21 -0400

Yes, that is very similar. A significant difference is that what is advertised via WebFinger is not necessarily something that one obtains through identity verification.  For example, if I visit a blog and see a posting by you or if I get an email from you, I might want to know some of this information about you and I'm clearly not in a position to do an identity verification.

Use of attributes in Connect might be preferred by users who don't mind sharing this information with certain RPs, but does not want to share this with the world.

Is there value in defining a URL for each of these attributes for use in WebFinger?

Paul

-------- Original Message --------
From: Nat Sakimura <[email-masked]>
Sent: Mon Mar 11 12:09:37 EDT 2013
To: "Paul E. Jones" <[email-masked]>
Cc: [email-masked], [email-masked]
Subject: Re: [webfinger] Properties in WebFinger

Nat

---

From: Dick Hardt <[email-masked]>
Date: Mon, 11 Mar 2013 10:25:33 -0700

> Use of attributes in Connect might be preferred by users who don't mind sharing this information with certain RPs, but does not want to share this with the world.

I agree these are different use cases.

> Is there value in defining a URL for each of these attributes for use in WebFinger?

There is if people are going to use the attributes! :)

Gonzala and I are going to pick up the link relation types doc and work on it. Would it make sense for these URIs for properties to be defined there as well?

> To unsubscribe from this group and stop receiving emails from it, send an email to [email-masked].

---

From: Nat Sakimura <[email-masked]>
Date: Tue, 12 Mar 2013 03:27:31 +0900

They are different use cases but what is being expressed amounts to be the
same.
The difference is whether the subject has been authenticated in certain way
or not.
The data schema should be more or less the same.

I think registering them in IANA Link Relation Type Registry would be good.

Nat

2013/3/12 Dick Hardt <[email-masked]>

> Yes, that is very similar. A significant difference is that what is
> advertised via WebFinger is not necessarily something that one obtains
> through identity verification. For example, if I visit a blog and see a
> posting by you or if I get an email from you, I might want to know some of
> this information about you and I'm clearly not in a position to do an
> identity verification.
>
> Use of attributes in Connect might be preferred by users who don't mind
> sharing this information with certain RPs, but does not want to share this
> with the world.
>
>
> Gonzala and I are going to pick up the link relation types doc and work on
> it. Would it make sense for these URIs for properties to be defined there
> as well?
>
>
> Paul
>
> ------------------------------
> *From:* Nat Sakimura <[email-masked]>
> *Sent:* Mon Mar 11 12:09:37 EDT 2013
> *To:* "Paul E. Jones" <[email-masked]>
> *Cc:* [email-masked], [email-masked]
>> Properties that relate to the subject would be defined in separate RFCs
>> or could be defined by other SDOs or anyone else, as properties are always