Subject: [webfinger] New WebFinger Draft posted

From: "Paul E. Jones" <[email-masked]>
Date: Fri, 9 Aug 2013 12:09:55 -0400

Folks,

As we're trying to bring the WebFinger spec to a close, we published a new
version -17 with some changes the WG might want to consider.

Draft is:
http://tools.ietf.org/html/draft-ietf-appsawg-webfinger-17

Those changes are:

- Section 2, added a new last paragraph to explain what URI syntax we use in
WebFinger
- Corrected error in section 3.2 ("Host:" line in example and quotes around
"3.2")
- We remove the words "absolute URI" since it's really redundant
- Added "query target" to 4.5 for clarity
- Introduced a new section 8 that describes "WebFinger" applications.  This
is a major new addition.
- Added a new section 10.3 and 10.4 to address registration of link relation
types and properties.  Link relations types already have a registry and we
refer to existing procedures.  WebFinger properties did not have a registry,
so we define one, primarily for the purpose of helping people avoid creating
redundant definitions.

If you have any questions or comments, please feel free to post to the list.

Paul

---

From: Melvin Carvalho <[email-masked]>
Date: Sat, 17 Aug 2013 20:12:11 +0200

> If you have any questions or comments, please feel free to post to the

[[

   The order of elements in the "links" array indicates an order of
   preference.  Thus, if there are two or more link relations having the
   same "rel" value, the first link relation would indicate the user's
   preferred link.

]]

Maybe remove this altogether, as I am unsure it can be guaranteed.

Case 1: Let's say I have a list of friends, how am I to determine as a
server the preferred friends?  How am I to determine as a client whether
the friends are ordered or not?

Case 2: Say I mash up data from two sources, how do I then order the
combined list?

>
> Paul
>
>
> _______________________________________________
> webfinger mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/webfinger
>

---

From: "Paul E. Jones" <[email-masked]>
Date: Sat, 17 Aug 2013 14:32:19 -0400

Melvin,

We have been asked about this before. If we leave it in, it meets the needs of some. I admit there might be cases where it's hard to control order, but if it matters, there is at least a way.

In my own implementation, I assign an integer value to each entry and sort on that.

I have no strong objection either way, but I do think it's good to have for those who care.

Paul

-------- Original Message --------
From: Melvin Carvalho <[email-masked]>
Sent: Sat Aug 17 14:12:11 EDT 2013
To: "Paul E. Jones" <[email-masked]>
Cc: webfinger <[email-masked]>
Subject: Re: [webfinger] New WebFinger Draft posted

[[

]]

---

From: Melvin Carvalho <[email-masked]>
Date: Sat, 17 Aug 2013 20:40:29 +0200

On 17 August 2013 20:32, Paul E. Jones <[email-masked]> wrote:

> Melvin,
>
> We have been asked about this before. If we leave it in, it meets the
> needs of some. I admit there might be cases where it's hard to control
> order, but if it matters, there is at least a way.
>

I understand the trade offs.  However, I can see that this is useful in
many cases, particularly this would work well for openid, but other use
cases, eg to have a friends list, for something like a federated social
web, would then be perhaps impractical with JRD (not the end of the world,
though)

> Paul
>
>
> ------------------------------
> *From:* Melvin Carvalho <[email-masked]>
> *Sent:* Sat Aug 17 14:12:11 EDT 2013
> *To:* "Paul E. Jones" <[email-masked]>
> *Cc:* webfinger <[email-masked]>
> *Subject:* Re: [webfinger] New WebFinger Draft posted
>
>
>
>

---

From: Mike Jones <[email-masked]>
Date: Sat, 17 Aug 2013 18:45:47 +0000

When used, the ordering can do good.  When not used, it does no harm.  Please leave it in.

                                                            Thanks,
                                                            -- Mike

From: [email-masked] [mailto:[email-masked]] On Behalf Of Melvin Carvalho
Sent: Saturday, August 17, 2013 11:40 AM
To: Paul E. Jones
Cc: webfinger
Subject: Re: [webfinger] New WebFinger Draft posted

On 17 August 2013 20:32, Paul E. Jones <[email-masked]<mailto:[email-masked]>> wrote:

Melvin,

I understand the trade offs.  However, I can see that this is useful in many cases, particularly this would work well for openid, but other use cases, eg to have a friends list, for something like a federated social web, would then be perhaps impractical with JRD (not the end of the world, though)

Paul

________________________________
From: Melvin Carvalho <[email-masked]<mailto:[email-masked]>>
Sent: Sat Aug 17 14:12:11 EDT 2013
To: "Paul E. Jones" <[email-masked]<mailto:[email-masked]>>
Cc: webfinger <[email-masked]<mailto:[email-masked]>>
Subject: Re: [webfinger] New WebFinger Draft posted

On 9 August 2013 18:09, Paul E. Jones <[email-masked]<mailto:[email-masked]>> wrote:
Folks,

Draft is:

Those changes are:

[[

   preferred link.
]]

Maybe remove this altogether, as I am unsure it can be guaranteed.
Case 1: Let's say I have a list of friends, how am I to determine as a server the preferred friends?  How am I to determine as a client whether the friends are ordered or not?
Case 2: Say I mash up data from two sources, how do I then order the combined list?

Paul

_______________________________________________
webfinger mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/webfinger

---

From: Melvin Carvalho <[email-masked]>
Date: Sat, 17 Aug 2013 20:49:05 +0200

>  When used, the ordering can do good.  When not used, it does no harm.

Mike, my question related to how the client can *know* when it's used and
when it's not used.  This seems unclear?

> ****
>
> ** **
>
>                                                             Thanks,****
>
>                                                             -- Mike****
>
> ** **
>
> *From:* [email-masked] [mailto:[email-masked]] *On
> Behalf Of *Melvin Carvalho
> *Sent:* Saturday, August 17, 2013 11:40 AM
> *To:* Paul E. Jones
> *Cc:* webfinger
>
> *Subject:* Re: [webfinger] New WebFinger Draft posted****
>
> ** **
>
> ** **
>
> ** **
>
> On 17 August 2013 20:32, Paul E. Jones <[email-masked]> wrote:****
>
> Melvin,****
>
> order, but if it matters, there is at least a way.****
>
> In my own implementation, I assign an integer value to each entry and sort
> on that.****
>
> I have no strong objection either way, but I do think it's good to have
> for those who care.****
>
> ** **
>
> though)****
>  ****
>  Paul****
> ** **
> *Subject:* Re: [webfinger] New WebFinger Draft posted****
>
> ** **
>
> ** **
>
> ** **
>
> On 9 August 2013 18:09, Paul E. Jones <[email-masked]> wrote:****
>
> Folks,
>
> If you have any questions or comments, please feel free to post to the
> list.****
>
>
> [[****
>
>    The order of elements in the "links" array indicates an order of****
>
>    preference.  Thus, if there are two or more link relations having the****
>
>    same "rel" value, the first link relation would indicate the user's****
>
>    preferred link.****
>
> ]]
>  ****
>
> Maybe remove this altogether, as I am unsure it can be guaranteed.****
>
> the friends are ordered or not?****
>
> combined list?****
> ** **
> https://www.ietf.org/mailman/listinfo/webfinger****
>
>  ** **
>
>  ** **
>

---

From: "Paul E. Jones" <[email-masked]>
Date: Sat, 17 Aug 2013 16:29:57 -0400

Why not have the client always offer items in the array in order? Any reason to randomly select items from the array?

Paul

---

From: Bob Wyman <[email-masked]>
Date: Sat, 17 Aug 2013 17:04:58 -0400

I would prefer if the wording didn't require that order of listing is
required to indicate a necessary order of preference. Thus, I suggest the
following wording:

The order of elements in the "links" array *MAY be read as indicating*
an order of preference.

The idea is to permit readers to infer order of preference, and to
allow writers to express that order, without requiring that a
preferred order be determined or expressed. Where there is no
preferred order, there will be no harm. Where there is a preferred
order, the right thing will happen.

bob wyman

On Sat, Aug 17, 2013 at 4:29 PM, Paul E. Jones <[email-masked]>wrote:

> Why not have the client always offer items in the array in order? Any
> reason to randomly select items from the array?
>
> Paul
>
>
> *Sent:* Sat Aug 17 14:49:05 EDT 2013
> *To:* Mike Jones <[email-masked]>
> *Cc:* "Paul E. Jones" <[email-masked]>, webfinger <
> [email-masked]>
>
>> In my own implementation, I assign an integer value to each entry and
>> sort on that.****
>>

---

From: Melvin Carvalho <[email-masked]>
Date: Sun, 18 Aug 2013 07:14:05 +0200

On 17 August 2013 23:04, Bob Wyman <[email-masked]> wrote:

> The order of elements in the "links" array *MAY be read as indicating* an order of preference.
>
> The idea is to permit readers to infer order of preference, and to allow writers to express that order, without requiring that a preferred order be determined or expressed. Where there is no preferred order, there will be no harm. Where there is a preferred order, the right thing will happen.
>
>
+1

---

From: "Paul E. Jones" <[email-masked]>
Date: Mon, 19 Aug 2013 12:16:26 -0400

Bob,

I'm OK with that change, if we're permitted to make this type of change now.

Paul

From: [email-masked] [mailto:[email-masked]] On Behalf Of Bob Wyman
Sent: Saturday, August 17, 2013 5:05 PM
To: Paul E. Jones
Cc: Melvin Carvalho; Mike Jones; webfinger
Subject: Re: [webfinger] New WebFinger Draft posted

The order of elements in the "links" array MAY be read as indicating an
order of preference.
The idea is to permit readers to infer order of preference, and to allow
writers to express that order, without requiring that a preferred order be
determined or expressed. Where there is no preferred order, there will be no
harm. Where there is a preferred order, the right thing will happen.
bob wyman

On Sat, Aug 17, 2013 at 4:29 PM, Paul E. Jones <[email-masked]>
wrote:

Why not have the client always offer items in the array in order? Any reason
to randomly select items from the array?

Paul

  _____  

 

When used, the ordering can do good.  When not used, it does no harm.
Please leave it in.

 

                                                            Thanks,

                                                            -- Mike

From: [email-masked] [mailto:[email-masked]] On
Behalf Of Melvin Carvalho
Sent: Saturday, August 17, 2013 11:40 AM
To: Paul E. Jones
Cc: webfinger

 

Melvin,

We have been asked about this before. If we leave it in, it meets the needs
of some. I admit there might be cases where it's hard to control order, but
if it matters, there is at least a way.

on that.

I have no strong objection either way, but I do think it's good to have for
those who care.

I understand the trade offs.  However, I can see that this is useful in many
cases, particularly this would work well for openid, but other use cases, eg
to have a friends list, for something like a federated social web, would
then be perhaps impractical with JRD (not the end of the world, though)

Paul

  _____  

 

Folks,

Draft is:

Those changes are:

[[

]]

Case 1: Let's say I have a list of friends, how am I to determine as a
server the preferred friends?  How am I to determine as a client whether the
friends are ordered or not?

Paul

---

From: Nick Jennings <[email-masked]>
Date: Mon, 19 Aug 2013 18:20:43 +0200

+1

On Mon, Aug 19, 2013 at 6:16 PM, Paul E. Jones <[email-masked]>wrote:

> Bob,****
>
> ** **
>
> I’m OK with that change, if we’re permitted to make this type of change
> now.****
>
> ** **
>
> Paul****
>
> ** **
>
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf Of *Bob
> Wyman
> *Sent:* Saturday, August 17, 2013 5:05 PM
> *To:* Paul E. Jones
> *Cc:* Melvin Carvalho; Mike Jones; webfinger
>
> following wording:****
> The order of elements in the "links" array *MAY be read as indicating* an order of preference.****
>
> The idea is to permit readers to infer order of preference, and to allow writers to express that order, without requiring that a preferred order be determined or expressed. Where there is no preferred order, there will be no harm. Where there is a preferred order, the right thing will happen.****
>
> bob wyman****
>
> ** **
>
> wrote:****
> reason to randomly select items from the array?****
>
> Paul****
>
> ** **
> *From:* Melvin Carvalho <[email-masked]>****
>
> [email-masked]>****
> On 17 August 2013 20:45, Mike Jones <[email-masked]> wrote:**
> **
>
> Please leave it in.****
> when it's not used.  This seems unclear?****
>
>  ****
>
>  ****
>
>                                                             Thanks,****
>
>                                                             -- Mike****
>
>  ****
>
> *Cc:* webfinger****

---

From: Melvin Carvalho <[email-masked]>
Date: Mon, 19 Aug 2013 18:40:56 +0200

On 19 August 2013 18:16, Paul E. Jones <[email-masked]> wrote:

> now.

I guess if it's too late it's not the end of the world.

I do think Bob's change is an improvement.  But I still dont quite
understand how the client is supposed to know if it's dealing with an
ordered list or an unordered list.

---

From: "Paul E. Jones" <[email-masked]>
Date: Mon, 19 Aug 2013 13:01:36 -0400

Melvin,

Items in a JSON array are ordered by definition, so adding this language
actually does not change the fact that the list is ordered.  What it does,
though, is remind people that if they have information they would like to
prioritize, they can take advantage of the fact that arrays are ordered.

So to answer your question, clients always know the links array is ordered
:)

If I have two avatars that I would like to make available, do I care which
one is selected?  If I do, then I should ensure the preferred avatar is
first.  If I do not, then it does not matter about order.  That said, it
should be understood that some clients are likely to select the first avatar
it encounters and some clients might not even look further in the array to
see if there are alternatives.  Other clients, though, might actually offer
all alternative avatars.

Paul

From: Melvin Carvalho [mailto:[email-masked]] 
Sent: Monday, August 19, 2013 12:41 PM
To: Paul E. Jones
Cc: Bob Wyman; Mike Jones; webfinger
Subject: Re: [webfinger] New WebFinger Draft posted

Bob,

 

Paul

Paul

  _____  

 

 

                                                            Thanks,

                                                            -- Mike

 

Melvin,

Paul

  _____  

 

Folks,

Draft is:

Those changes are:

[[

]]

Paul

---

From: Mike Jones <[email-masked]>
Date: Mon, 19 Aug 2013 16:51:01 +0000

I'm not OK making this change.  Expressing an order of preference is useful semantics and we shouldn't remove it.  No the handling of it isn't guaranteed (it's a *preference*, not a hard requirement), but it's still useful as-is.

We're resolving the last IESG comments now.  It seems pretty late to be asking for non-essential changes - especially when they degrade functionality.

                                                                -- Mike

From: Melvin Carvalho [mailto:[email-masked]]
Sent: Monday, August 19, 2013 9:41 AM
To: Paul E. Jones
Cc: Bob Wyman; Mike Jones; webfinger
Subject: Re: [webfinger] New WebFinger Draft posted

On 19 August 2013 18:16, Paul E. Jones <[email-masked]<mailto:[email-masked]>> wrote:
Bob,

I guess if it's too late it's not the end of the world.
I do think Bob's change is an improvement.  But I still dont quite understand how the client is supposed to know if it's dealing with an ordered list or an unordered list.

Paul

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Bob Wyman
Sent: Saturday, August 17, 2013 5:05 PM
To: Paul E. Jones
Cc: Melvin Carvalho; Mike Jones; webfinger

I would prefer if the wording didn't require that order of listing is required to indicate a necessary order of preference. Thus, I suggest the following wording:

The order of elements in the "links" array MAY be read as indicating an order of preference.

bob wyman

On Sat, Aug 17, 2013 at 4:29 PM, Paul E. Jones <[email-masked]<mailto:[email-masked]>> wrote:

Paul

________________________________
From: Melvin Carvalho <[email-masked]<mailto:[email-masked]>>
Sent: Sat Aug 17 14:49:05 EDT 2013
To: Mike Jones <[email-masked]<mailto:[email-masked]>>
Cc: "Paul E. Jones" <[email-masked]<mailto:[email-masked]>>, webfinger <[email-masked]<mailto:[email-masked]>>

On 17 August 2013 20:45, Mike Jones <[email-masked]<mailto:[email-masked]>> wrote:
When used, the ordering can do good.  When not used, it does no harm.  Please leave it in.

Mike, my question related to how the client can *know* when it's used and when it's not used.  This seems unclear?

                                                            Thanks,
                                                            -- Mike

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Melvin Carvalho
Sent: Saturday, August 17, 2013 11:40 AM
To: Paul E. Jones
Cc: webfinger

Melvin,

Paul

Draft is:

Those changes are:

[[

   preferred link.
]]

Paul

---

From: Melvin Carvalho <[email-masked]>
Date: Mon, 19 Aug 2013 19:28:37 +0200

On 19 August 2013 19:01, Paul E. Jones <[email-masked]> wrote:

> prioritize, they can take advantage of the fact that arrays are ordered.**
> **
>
> ** **
>
> :)****
> should be understood that some clients are likely to select the first
> avatar it encounters and some clients might not even look further in the
> array to see if there are alternatives.  Other clients, though, might
> actually offer all alternative avatars.
>

Thanks for the explanation, I think I get this.

So, as a client, lists are ordered by preference.

As a server should order lists according to the information it has.  If it
has that information, or the preference order is not important, then we're
good.

As a server if the order *is* important and we dont have preference
information, probably best to send nothing?

> ****
>
> ** **
>
> Paul****
>
> ** **
>
> *From:* Melvin Carvalho [mailto:[email-masked]]
> *Sent:* Monday, August 19, 2013 12:41 PM
> *To:* Paul E. Jones
> *Cc:* Bob Wyman; Mike Jones; webfinger
>
> On 19 August 2013 18:16, Paul E. Jones <[email-masked]> wrote:****
>
> Bob,****
>
>  ****
>
> I guess if it's too late it's not the end of the world.****
>
> ordered list or an unordered list.   ****
>
>  ****
>
>  ****
>
> Paul****
>
>  ****
>
> *Cc:* Melvin Carvalho; Mike Jones; webfinger****
>
>

---

From: "Paul E. Jones" <[email-masked]>
Date: Mon, 19 Aug 2013 15:22:14 -0400

Melvin,

If order is important, then why would the server not have that information?
It either is or is not important, and I don't see how one can say order is
important and then not consider order when data is collected.

I order everything as I enter information into my database, but if there are
items for which I have no preference I just use the same priority value and
don't worry about the order in which information is rendered.

Paul

From: Melvin Carvalho [mailto:[email-masked]] 
Sent: Monday, August 19, 2013 1:29 PM
To: Paul E. Jones
Cc: Bob Wyman; Mike Jones; webfinger
Subject: Re: [webfinger] New WebFinger Draft posted

Melvin,

 

Paul

 

Bob,

 

Paul

Paul

  _____  

 

 

                                                            Thanks,

                                                            -- Mike

 

Melvin,

Paul

  _____  

 

Folks,

Draft is:

Those changes are:

[[

]]

Paul

---

From: Melvin Carvalho <[email-masked]>
Date: Tue, 20 Aug 2013 00:54:15 +0200

On 19 August 2013 21:22, Paul E. Jones <[email-masked]> wrote:

> Melvin,****
>
> ** **
>
> If order is important, then why would the server not have that
> information?  It either is or is not important, and I don’t see how one can
> say order is important and then not consider order when data is collected.
> ****
>
> ** **
>
> I order everything as I enter information into my database, but if there
> are items for which I have no preference I just use the same priority value
> and don’t worry about the order in which information is rendered.
>

Very good point.  The term "important" seems to be a subjective evaluation.

Most data I have comes from some kind of relational or nosql style DB.

So as a server, when I'm getting data from a DB and serving it dynamically
for webfinger record, I'll need to
A) subjectively determine whether order is important
B) attempt to order the preferred items to the top

I dont naturally tend to keep lists ordered (except maybe by timestamp),
but I can start to, where I think it matters.  Seems a slight extra
implementation challenge, but something probably doable when it matters ...

> *Sent:* Monday, August 19, 2013 1:29 PM
>
> *To:* Paul E. Jones
> On 19 August 2013 19:01, Paul E. Jones <[email-masked]> wrote:****
>
> Melvin,****
>
>  ****
>
> actually offer all alternative avatars.****
>
> ** **
>
> So, as a client, lists are ordered by preference.****
>
> information, probably best to send nothing?  ****
>
>  ****
>
>  ****
>
> Paul****
>
>  ****
>
> *Cc:* Bob Wyman; Mike Jones; webfinger****
>
>

---

From: Bill Mills <[email-masked]>
Date: Mon, 19 Aug 2013 16:02:02 -0700

If clients MAY ignore ordering then order can't be very important.  Order becomes at most a requested preference.

-bill

--------------------------------
William J. Mills
"Paranoid" Yahoo!

________________________________
 From: Melvin Carvalho <[email-masked]>
To: Paul E. Jones <[email-masked]> 
Cc: Bob Wyman <[email-masked]>; Mike Jones <[email-masked]>; webfinger <[email-masked]> 
Sent: Monday, August 19, 2013 3:54 PM
Subject: Re: [webfinger] New WebFinger Draft posted

Melvin,
> 
>If order is important, then why would the server not have that information?  It either is or is not important, and I don’t see how one can say order is important and then not consider order when data is collected.
> 
>I order everything as I enter information into my database, but if there are items for which I have no preference I just use the same priority value and don’t worry about the order in which information is rendered.

So as a server, when I'm getting data from a DB and serving it dynamically for webfinger record, I'll need to 
A) subjectively determine whether order is important 
B) attempt to order the preferred items to the top

I dont naturally tend to keep lists ordered (except maybe by timestamp), but I can start to, where I think it matters.  Seems a slight extra implementation challenge, but something probably doable when it matters ...

>Paul
> 
>From:Melvin Carvalho [mailto:[email-masked]] 
>Items in a JSON array are ordered by definition, so adding this language actually does not change the fact that the list is ordered.  What it does, though, is remind people that if they have information they would like to prioritize, they can take advantage of the fact that arrays are ordered.
> 
>So to answer your question, clients always know the links array is ordered :)
> 
>If I have two avatars that I would like to make available, do I care which one is selected?  If I do, then I should ensure the preferred avatar is first.  If I do not, then it does not matter about order.  That said, it should be understood that some clients are likely to select the first avatar it encounters and some clients might not even look further in the array to see if there are alternatives.  Other clients, though, might actually offer all alternative avatars.
> 
>As a server should order lists according to the information it has.  If it has that information, or the preference order is not important, then we're good.  
>
>As a server if the order *is* important and we dont have preference information, probably best to send nothing?  
> 
> 
>>Paul
>> 
>>From:Melvin Carvalho [mailto:[email-masked]] 
>>I’m OK with that change, if we’re permitted to make this type of change now.
>> 
>>>From:[email-masked] [mailto:[email-masked]] On Behalf Of Bob Wyman
>>>On Sat, Aug 17, 2013 at 4:29 PM, Paul E. Jones <[email-masked]> wrote:
>>>From:Melvin Carvalho <[email-masked]>
>>>Sent:Sat Aug 17 14:49:05 EDT 2013
>>>>From:[email-masked] [mailto:[email-masked]] On Behalf Of Melvin Carvalho
>>>>>From:Melvin Carvalho <[email-masked]>

---

From: Gonzalo Salgueiro <[email-masked]>
Date: Wed, 21 Aug 2013 19:38:10 -0400

Folks - 

The last DISCUSS has finally been cleared!! A new version (-18) will be published in the next few days addressing the final minor edits that came from this final round of IESG review.  This is a final plea to please review the document (particularly the new Section 8 and sub-sections 10.3 and 10.4) to ensure that you agree with us that everything is in order and the document is in fact ready to go to the RFC Editor for publication.

As we get through this final hurdle, I'm reminded to thank all of you for your continued dedication throughout this long (and sometimes arduous) journey. 

Gonzalo