Subject: [xml2rfc] lists within lists

From: Robert Moskowitz <[email-masked]>
Date: Tue, 19 Jan 2021 17:15:40 -0500

I am trying for something like:

a)Public key operation

       2 Public Key signing verifications,

       1 Public Key signing,

b)Key generation

       1 Diffie-Hellman ephemeral keypair generation, and

       1 Diffie-Hellman shared secret generation.

And looking at rfc7991 I am suppose to be able to put <ul> within <li> like:

<ol type="a">
     <li>
         Public key operations
<ul spacing="normal" empty="true">
     <li>
         2 Public Key signing verifications,
     </li>
     <li>
         1 Public Key signing,
     </li>
</ul>
     </li>
</ol>
<ol type="a">
     <li>
         Key generation
<ul spacing="normal" empty="true">
     <li>
         1 Diffie-Hellman ephemeral keypair generation, and
     </li>
     <li>
         1 Diffie-Hellman shared secret generation.
     </li>
</ul>
     </li>
</ol>

But I get the error:

$ xml2rfc --v3 draft-ietf-hip-dex.xml
draft-ietf-hip-dex.xml(322): Error: Element li has extra content: ul, at 
/rfc/middle/section[1]/section[2]/section/ol[1]/li/ul
draft-ietf-hip-dex.xml(335): Error: Element li has extra content: ul, at 
/rfc/middle/section[1]/section[2]/section/ol[2]/li/ul

What am I doing wrong?

How do I get nested lists?

thanks

---

From: Robert Moskowitz <[email-masked]>
Date: Tue, 19 Jan 2021 18:19:07 -0500

I needed:

     <li>
         <t>Public key operations</t>
<ul spacing="normal" empty="true">

I asked basically the same question back in March.  :(

On 1/19/21 5:15 PM, Robert Moskowitz wrote:
> draft-ietf-hip-dex.xml(322): Error: Element li has extra content: ul, 
> at /rfc/middle/section[1]/section[2]/section/ol[1]/li/ul
> draft-ietf-hip-dex.xml(335): Error: Element li has extra content: ul, 
> at /rfc/middle/section[1]/section[2]/section/ol[2]/li/ul
>
> What am I doing wrong?
>
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc