Subject: [xml2rfc] Idnits false positive on RFC2606 FQDN

From: Roger Price <[email-masked]>
Date: Thu, 21 Jan 2021 17:33:44 +0100 (CET)

This is probably off-topic for this list.

My text refers to constants such as output.voltage.nominal and 
ups.delay.shutdown.  Idnits complains with messages such as

tmp/draft-rprice-ups-management-protocol-00.txt(814): Found possible FQDN
  'ups.delay.shutdown' in position 12; this doesn't match RFC 2606's suggested
  ".example" or ".example.(com|org|net)".

My constants are marked up as <tt>ups.delay.shutdown</tt>
How can I tell Idnit that my constants are not domain names?

Roger

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 21 Jan 2021 17:42:36 +0100

> How can I tell Idnit that my constants are not domain names?

Idnits uses heuristics, so these *will* create false positives.

A future sprint for idnits could provide a way to create “ignore” pragmas for these false positives.
This is complicated a bit by the fact that idnits works on the text version, so there would be no way to hide those pragmas from the casual viewer.
But maybe they can be hidden in the backmatter or some such.

However, idnits awaits a rewrite anyway, so that probably should be done first.

Until then, I’d say just keep note of the false positives.
(You might even have a “toBeRemovedinRFC” section that lists them, so readers know you are aware…)

Grüße, Carsten