Subject: [xml2rfc] Picking up old draft version

From: Robert Moskowitz <[email-masked]>
Date: Mon, 19 Apr 2021 12:48:37 -0400

I am using:

     <xi:include 
href="https://xml2rfc.tools.ietf.org/public/rfc/bibxml/reference.I-D.ietf-drip-reqs.xml"/>

And I am getting ver -06 where the current ver is -09.

I am just not seeing what has changed since the last I built a draft 
(has been since prior to IETF 110).

Thanks for help in cleaning out some dust webs over here....

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 19 Apr 2021 19:06:32 +0200

On 2021-04-19, at 18:48, Robert Moskowitz <[email-masked]> wrote:
> 
> I am using:
> 
>     <xi:include href="https://xml2rfc.tools.ietf.org/public/rfc/bibxml/reference.I-D.ietf-drip-reqs.xml"/>

That is currently not advisable.

> And I am getting ver -06 where the current ver is -09.

Try:

<xi:include href="https://datatracker.ietf.org/doc/bibxml3/draft-ietf-drip-reqs/xml"/>

Grüße, Carsten

---

From: Robert Moskowitz <[email-masked]>
Date: Mon, 19 Apr 2021 13:10:08 -0400

> That is currently not advisable.

I can't remember how far back I have been pulling from /public.  Got it 
from somewhere...

> <xi:include href="https://datatracker.ietf.org/doc/bibxml3/draft-ietf-drip-reqs/xml"/>

Yep.  that did the trick.

Thanks.

---

From: Brian Campbell <[email-masked]>
Date: Wed, 21 Apr 2021 16:01:26 -0600

Thanks for the info Carsten,

Can you say why that style of reference URL is not advisable? And how
someone would/should come to know that? I must admit I'm rather confused by
all this.

I was experiencing similar issues, which I mentioned last week
https://mailarchive.ietf.org/arch/msg/xml2rfc/pQSxAbQLIqGZ0ORJLPDDwHesILA/

We've been using the mmark tool, which produces reference links in the
style that you've said is not advisable (at least it does so by default in
the version at hand). Does that tooling need to be updated?

Also https://xml2rfc.tools.ietf.org/ seems to recommend exactly what you
say is not advisable. In the Internet-Draft section of Citation Libraries
it has:

"*Examples:*
http://xml2rfc.ietf.org/public/rfc/bibxml-ids/reference.I-D.example-name.xml
http://xml2rfc.ietf.org/public/rfc/bibxml-ids/reference.I-D.draft-example-name-99.xml

*Note:* Leave *draft-* off when referencing a generic draft name, and add
*draft-* when referencing a specific version of an internet-draft."

On Mon, Apr 19, 2021 at 11:06 AM Carsten Bormann <[email-masked]> wrote:

> >     <xi:include href="
> https://xml2rfc.tools.ietf.org/public/rfc/bibxml/reference.I-D.ietf-drip-reqs.xml
> "/>
>
> <xi:include href="
> https://datatracker.ietf.org/doc/bibxml3/draft-ietf-drip-reqs/xml"/>
>
> Grüße, Carsten
>
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc
>

-- 
_CONFIDENTIALITY NOTICE: This email may contain confidential and privileged 
material for the sole use of the intended recipient(s). Any review, use, 
distribution or disclosure by others is strictly prohibited.  If you have 
received this communication in error, please notify the sender immediately 
by e-mail and delete the message and any file attachments from your 
computer. Thank you._

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 22 Apr 2021 01:08:51 +0200

On 22. Apr 2021, at 00:01, Brian Campbell <[email-masked]> wrote:
> Can you say why that style of reference URL is not advisable? And how someone would/should come to know that? I must admit I'm rather confused by all this.

Hi Brian,

I would be very uncomfortable to speculate about the “why”, but many of us have made the observation this year that the resources provided by tools.ietf.org have become less timely and less reliable recently.  So this is the tentative premise I’m working from.

> I was experiencing similar issues, which I mentioned last week https://mailarchive.ietf.org/arch/msg/xml2rfc/pQSxAbQLIqGZ0ORJLPDDwHesILA/ 
> 
> We've been using the mmark tool, which produces reference links in the style that you've said is not advisable (at least it does so by default in the version at hand). Does that tooling need to be updated?

I did update kramdown-rfc (1.3.30 on 2021-02-13, [1]) to avoid some of the tools.ietf.org-based resources (there are others that are not so easy to replace right now).

> Also https://xml2rfc.tools.ietf.org/ seems to recommend exactly what you say is not advisable. In the Internet-Draft section of Citation Libraries it has:
> 
> "Examples:

Up to a few months ago, this indeed was the way to do this.
(Actually, xml2rfc.tools.ietf.org:

$ curl -I http://xml2rfc.ietf.org/public/rfc/bibxml-ids/reference.I-D.example-name.xml
HTTP/1.1 301 Moved Permanently
Location: https://xml2rfc.tools.ietf.org/public/rfc/bibxml-ids/reference.I-D.example-name.xml
[…]
)

> Note: Leave draft- off when referencing a generic draft name, and add draft- when referencing a specific version of an internet-draft."

(Which is, by the way, somewhat weird, because the anchors then don’t do that.)

Grüße, Carsten

[1]: https://mailarchive.ietf.org/arch/msg/rfc-markdown/obCjU0W0aGKcFn5G4pPnWHDxGYA