Subject: [xml2rfc] Double quotes added to text output when <br/> inside <td>

From: Glyn Normington <[email-masked]>
Date: Mon, 9 Aug 2021 11:53:32 +0100

When I use <br/> to add a linebreak inside a <td>, xml2rfc seems to add
double quotes round some items. For example, the following table:

<table align="center">
<name>Filter expression operator precedence</name>
<thead>
<tr>
<th align="center">Precedence</th>
<th align="center">Operator type</th>
<th align="center">Syntax</th>
</tr>
</thead>
<tbody>
<tr>
<td align="center">5</td>
<td align="center">Grouping</td>
<td align="center">
<tt>(...)</tt></td>
</tr>
<tr>
<td align="center">4</td>
<td align="center">Logical NOT</td>
<td align="center">
<tt>!</tt></td>
</tr>
<tr>
<td align="center">3</td>
<td align="center">Relations</td>
<td align="center">
<tt>==</tt><br/><tt>&lt;</tt></td>
</tr>
<tr>
<td align="center">2</td>
<td align="center">Logical AND</td>
<td align="center">
<tt>&amp;&amp;</tt></td>
</tr>
<tr>
<td align="center">1</td>
<td align="center">Logical OR</td>
<td align="center">
<tt>||</tt></td>
</tr>
</tbody>
</table>

is rendered in text output as:

                  +============+===============+========+
                  | Precedence | Operator type | Syntax |
                  +============+===============+========+
                  |     5      |    Grouping   | (...)  |
                  +------------+---------------+--------+
                  |     4      |  Logical NOT  |   !    |
                  +------------+---------------+--------+
                  |     3      |   Relations   |  "=="  |
                  |            |               |  "<"   |
                  +------------+---------------+--------+
                  |     2      |  Logical AND  |   &&   |
                  +------------+---------------+--------+
                  |     1      |   Logical OR  |   ||   |
                  +------------+---------------+--------+

                    Table 5: Filter expression operator
                                 precedence

Why are these extra quotes added and is there a way to avoid this behaviour?

Regards,
Glyn

---

From: Robert Sparks <[email-masked]>
Date: Mon, 9 Aug 2021 09:51:37 -0500

Hi Glyn -

see https://trac.ietf.org/trac/xml2rfc/ticket/600

The quoting behavior will be removed in an upcoming release.

RjS

On 8/9/21 5:53 AM, Glyn Normington wrote:
> When I use <br/> to add a linebreak inside a <td>, xml2rfc seems to 
> add double quotes round some items. For example, the following table:
>
> <table align="center">
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc