Subject: RE: draft-wang-diff-serv-usd-00.txt

From: mohan sharma <[email-masked]>
Date: Thu, 4 Dec 1997 12:13:27 +0530

In the proposed USD scheme, a user "buys" k-shares from an ISP for all his traffic requirements. The problem here is that a user is charged for ALL the traffic generated by him - both the best effort and those that need QoS. The application marking of packets as explained in the USD scheme is only to guide the routers along the path on dropping packets. And a user nevertheless is charged for his k-share utilization.

As widely agreed, the QoS traffic forms a small percentage of user traffic and a good majority of user traffic falls under best-effort. As such, it may be prudent to say that USD applies only for the QoS traffic and every user by default gets best-effort service. If that were the case, USD will have to be integrated into one of differentiated service models as scheme that provides a simpler accounting mechanism for the ISPs.

Thanks.

mohan sharma

email: [email-masked]

-----Original Message-----
From:	Zheng Wang [SMTP:[email-masked]]
Sent:	Thursday, November 27, 1997 1:20 AM
To:	Jean-Yves Le Boudec
Cc:	[email-masked]
Subject:	Re: draft-wang-diff-serv-usd-00.txt 

> with the USD scheme, you guarantee a fair share to user flows. Now on which
> principle do you base packet classification ? For example, is a packet from
> user A to user B classified in the flow of A or B ? How about multicast
> packets ?

A router checks the src address and dest addess.
If either src or dest matches a entry, the allocation of
the matched entry will be used. If both src and dest
match, it means both the sender and receiver are customers
of the ISP. In this case, the minimum of the two matched
entries should be used. For multicast, an ISP can also
allocate bandwidth to a particular mcast session so that
the session is also isolated from other traffic in the same
way as unicast. Thus, mcast does not require any additional
mechanisms except that the allocation needs to be done
when the mcast address is allocated.

Cheers
Zheng

---

From: Zheng Wang <[email-masked]>
Date: Thu, 04 Dec 1997 09:57:21 -0500

> In the proposed USD scheme, a user "buys" k-shares from an ISP for all his traffic requirements. The problem here is that a user is charged for ALL the traffic generated by him - both the best effo…

When you talk about charging, you have to look at the price. Getting
more does not automatically mean that you pay more.

In premium services, you pay for the privilege of a guaranteed bandwidth 
at any time.  In USD, you get a minimum bandwidth guarantee plus
proportional sharing of the rest of the bandwidth.

> As widely agreed, the QoS traffic forms a small percentage of user traffic and a good majority of user traffic falls under best-effort. As such, it may be prudent to say that USD applies only for t…
 
How much QoS traffic accounts for the total traffic is really a question
of cost. If you charge a lot, sure, there is going to be a very small
people who can afford. If you provide a reasonable service at a reasonable
cost, many people may choose to use it.

Cheers
Zheng