Subject: Re: Need for a COST object

From: [email-masked]
Date: Thu, 10 Oct 96 16:39:06 PDT

This is really an int-serv issue, not an RSVP protocol issue.

In discussions in the int-serv working group, there was a general
conclusion that we don't yet understand the economic/policy model
issues well enough to know how to include cost in our reservation
requests.

Bob Braden

  *> From [email-masked] Fri Sep 20 17:13:42 1996
  *> From: Mohan Sharma <[email-masked]>
  *> Subject: Need for a COST object 
  *> To: [email-masked]
  *> Date: Fri, 20 Sep 1996 16:25:05 -0700 (PDT)
  *> Cc: [email-masked]
  *> X-Mailer: ELM [version 2.4 PL24]
  *> Mime-Version: 1.0
  *> Content-Type  *> :   *> text/plain  *> ;   *> charset=US-ASCII  *> 
  *> Content-Transfer-Encoding: 7bit
  *> Content-Length: 1274
  *> Sender: [email-masked]
  *> Precedence: bulk
  *> X-Lines: 28
  *> 
  *> Hello:
  *> 
  *> In the present RSVP model, there is no option for a receiver to specify the
  *> "cost" threshold that is acceptable for him. The reservation for sure will
  *> cost him "some" but don't you think he should have a way to specify an
  *> upper bound on the cost that he could tolerate? 
  *> 
  *> May be, the Adspec can inform the receiver of the cost for receiving a 
  *> particular flow in the path. Receiver then will indicate his tolerable limits
  *> of "cost" for the flow he describes. This may have to be a guiding factor as the 
  *> RESV msg moves towards the sender. Reservation could be rejected for exceeding the
  *> specified cost.
  *> 
  *> This may be an important consideration since the paths could change and the
  *> costs could become unpredictable to quite an extent. It may be difficult to 
  *> compute the "cost" on the fly but there should be some means for the receiver
  *> to forbid "expensive" paths. If the "cheaper" path is down for some reasons, he
  *> may want to wait until it comes up instead of going through the "expensive" path.
  *> 
  *> 
  *> mohan
  *> 
  *> 	-----------------------------------------------------------------
  *> 	| Dr.Mohan Sharma	e-mail: [email-masked]			|
  *> 	| Routers Group							|
  *> 	| 3Com Corp.							|
  *> 	| Santa Clara, CA 95052.					|
  *> 	|_______________________________________________________________|
  *>

---

From: Fred Baker <[email-masked]>
Date: Fri, 11 Oct 1996 10:09:51 -0700

> In the present RSVP model, there is no option for a receiver to specify the
> "cost" threshold that is acceptable for him. 

This is not an example of policy?