Subject: Re: Unused bandwidth policy

From: [email-masked]
Date: Mon, 23 Dec 1996 13:05:08 -0500

In a message dated 96-12-22 07:17:34 EST, [email-masked]
(Masataka Ohta) writes:

>Lixia;
>
>> > I feel that irrespective of the type of service, it should be up to the 
>> > users to request the BW as either exclusive or sharable when not used. 
>> > This could be a RSVP policy info that will be used by the schedulers 
>> > along the path. The result is two-fold. It could increase the network
>> > utilization and I could be charged less for making my reservation
>> > non-exclusive.
>> 
>> Given a user can already choose between "exclusive" and "shared"
>reservation
>> by choosing different service types, I wonder why why you consider it
>> desirable to have another way for doing the same thing.
>
>Perhaps, some kind of people who are working on reservation-only
>networking just do not know that there is best effort traffic
>which can consume unused resources exclusively reserved by
>someone else.
>
>						Masataka Ohta

After thinking about this discussion somewhat more, I have the 
impression RSVP true believers wanted to reserve some
amount of bandwidth but allow others to use that bandwidth
when the application that reserved the bandwidth is not
using it.  Such a system makes sense if the statistics
of network traffic is more or less as it is today (but
then why is reservation needed?).  

RSVP true believers allude to video applications and
maybe voice.  The statistics of such traffic is quite
different from today's typical network traffic.  Once a voice
or video application reserves its bandwidth, that
bandwidth really is not available for sharing,

Such  maybe the issue to which Ohta alludes.
Allowing unused reserved bandwidth to actually
be used by other applications probably will not
work because, applications requiring reservation
will simply use all the bandwidth and any use
of apparently unused bandwidth will simply
introduce latency or unacceptable traffic losses
until the packetswitches determine that the
apparently free bandwidth is really being used
by the reserved flow.

ATM (in the model where cells are allocated end-
to-end and packet switch internal buses are
multiplexed cell busses) has a similar problem in that 
it works well for permanent or semi-permanent VCs
but arbitrating for free cells in a complex network of
ATM switches requires an omniscient or psychic
arbitrator.

To deal with video traffic in the internet, it
might be better to use permanent or semi-permanent
ATM VCs (or FR with sufficient committed 
bandwidth) with static host routes between
transmitter and receiver (or final distributor).
In this way, the circuit oriented traffic
gets something like a circuit, and the
statistical multiplexed traffic can benefit
share resources according to the usual
stochastic models.  Packet switching
systems genuinely depend on the
statistical nature of the traffic (unless
there is a tremendous overabundance
of bandwidth).  

The reserved bandwidth applications
break the stochastics and the calculations
associated with reservation control in
the packet switches consume bandwidth
which is already far too precious.

Joachim Martillo

---

From: Karl Auerbach <[email-masked]>
Date: Mon, 23 Dec 1996 12:46:41 -0800 (PST)

> bandwidth really is not available for sharing,

Here at Precept video traffic is by far the dominant part of our
network traffic.  We see that although video is fairly constant when
measured over a period of seconds, it does tend to have a lot of
variability when measured on a smaller scale.  Much depends on the codec,
the abount of variability between sucessive video frames (i.e. whether the
scene is high motion or talking heads), etc.

We usually find that video traffic has sufficient variability that there
is a reasonable amount of room left over during the short periods of
lesser video traffic to get a lot of useful normal TCP traffic through.

As part of my own RSVP testing, one of the problems I've had is to find
traffic mixes which allow me to demonstrate the impact of reservations --
the statistical multiplexing we are getting without reservations is
amazingly good.

		--karl--

---

From: Masataka Ohta <[email-masked]>
Date: Tue, 24 Dec 96 11:58:32 JST

Joachim;

> >which can consume unused resources exclusively reserved by

Perhaps, you are a typical telco guy to believe that all the bandwidth
(or more than that with statistical multiplexing) must be used up by
resource reserved traffic.

But, I'm not.

> Such  maybe the issue to which Ohta alludes.

No.

> apparently free bandwidth is really being used

That's a problem for the true believers of statistical multiplexing.

But, when some bandwidth is exclusively reserved for the aggregated
best effort traffic with no individual resource reservation, it's
not a problem for me.

> might be better to use permanent or semi-permanent

No.

							Masataka Ohta