Subject: RE: Qry on Traffic Policing

From: Jim Fleming <[email-masked]>
Date: Tue, 10 Jun 1997 17:58:25 -0500

On Tuesday, June 10, 1997 3:21 PM, Koskelainen Petri[SMTP:[email-masked]] wrote:
@ >
@ >  > Policing will mark a flow's nonconformant packes so that they may
@ >  > not be involved in meeting service committments.
@ >
@ > In IP, policing will cause nonconformant packets to be scheduled
@ > so they get "best effort" service (in the node where the policing
@ > occurs), but there is no mechanism, I believe, to carry the 'mark'
@ > around with the packet.  Dave Clark had a paper last year on this idea
@ > and some nice analysis and suggestions.  In ATM, such a marking bit
@ 
@ Yep, it'd nice to have some mechanism to mark those noncomformant packets.
@ For example, IPv6 version field is very much unnecessary
@ and one bit from there could be defined as remove bit, set by edge-router
@ especially for those packets which exceeds their RSVP contract.
@ (in fact, all misbehaving packets could be marked with R=1
@ and let succeeding routers to drop those if necessary)
@ 
@ Unfortunately, I guess it is too late to change IPv6 header anymore.
@ 

Yes, that is unfortunately the case.

If it is any comfort, in IPv8 the version field has
been totally utilized. By setting the high bit of that
field to a 1 (value = 8), the low 3 bits are then usable
and are used for part of the extended addressing
information.

The versions are then:

4 - 0100
6 - 0110
8 - 1XXX

--
Jim Fleming
Unir Corporation
http://www.Unir.Corp

---

From: Mark W Garrett <[email-masked]>
Date: Wed, 11 Jun 1997 11:17:02 -0400 (EDT)

> 8 - 1XXX

Sorry if this is a clueless question, but ...
What about IP version 9?  Will there *never* be a version 9?
(OK, what am I missing?...)

-Mark

-------------------------------------------------------------------------------
                        Bellcore   Rm. 1A-220B                  +1 201 829-4439
Mark W. Garrett         445 South St.                          [email-masked]
                        Morristown NJ 07960-6438  USA         Fax: 201 829-2504
                        WWW: ftp://ftp.bellcore.com/pub/mwg/homepage.html
-------------------------------------------------------------------------------

---

From: Jim Fleming <[email-masked]>
Date: Wed, 11 Jun 1997 12:28:51 -0500

On Wednesday, June 11, 1997 6:17 AM, Mark W Garrett[SMTP:[email-masked]] wrote:
@ 
@  > The versions are then:
@ 
@  > 4 - 0100
@  > 6 - 0110
@  > 8 - 1XXX
@ 
@ Sorry if this is a clueless question, but ...
@ What about IP version 9?  Will there *never* be a version 9?
@ (OK, what am I missing?...)
@ 
@ -Mark
@ 
@ 
@ -------------------------------------------------------------------------------
@                         Bellcore   Rm. 1A-220B                  +1 201 829-4439
@ Mark W. Garrett         445 South St.                          [email-masked]
@                         Morristown NJ 07960-6438  USA         Fax: 201 829-2504
@                         WWW: ftp://ftp.bellcore.com/pub/mwg/homepage.html
@ -------------------------------------------------------------------------------
@ 
@ 
@ 

There is another way to look at the bits....

0XXX - IP Version 0
1XXX - IP Version 1

Version 0 encompasses IPv4 and IPv6.
There is still room for IPv7, but I imagine
that is reserved, like everything else.

--
Jim Fleming
Unir Corporation
http://www.Unir.Corp