Subject: TOS and Tunnels ?

From: Dimitrios Stiliadis <[email-masked]>
Date: Wed, 12 Nov 1997 15:03:58 -0500

Part of the IPinIP tunnel standard is that the
TOS bits are copied to the encapsulating header
from the encapsulated packet. It is my 
understanding that ISPs will want to use tunnels
for traffic enginneering and as a result the 
TOS bits for differentiated services. 

My question is: What happens with tunnels ?
Should the TOS bits still be copied or not ?

What are people thinking ?

Thanks,

Dimitri

---

From: Paul Ferguson <[email-masked]>
Date: Wed, 12 Nov 1997 16:49:28 -0500

>Should the TOS bits still be copied or not ?

Certainly. Why wouldn't they be?

- paul

---

From: Dimitrios Stiliadis <[email-masked]>
Date: Wed, 12 Nov 1997 19:33:59 -0500 (EST)

> Certainly. Why wouldn't they be?

You may want a specific bandwidth/drop priority
for all the packets in the tunnel. In a sense
reserve a pipe from point A to point B. Whatever
are the TOS bits in the packets are not much
of interest to you. You are merely interested
provisioning bandwidth in the tunnel ...

I was just thinking that people might want
to do traffic engineering in this way ...

Dimitri