Subject: Re: Concerns about exported numbers

From: [email-masked] (Mark W Garrett)
Date: Fri, 19 Jan 1996 09:41:42 -0500

> >Jon Crowcroft:
 > >explicitly, for controlled load, we would like _all packets dropped_
 > >to be part of the specification.....or at least some fixed
 > >behaviour...

 > Fred:
 > I would suggest that we do this (this is what I do). I believe that this is
 > pretty much how the specification reads...

 > measure the traffic rate using a token bucket, and treat excess traffic as
 > if it had been classified as best effort traffic in the first place. If
 > that means that it would experience excessive delay and therefore be
 > dropped, or would be marked by RED, so be it.

Hmmm, not to beat this to death, but Jon seems to be saying
drop *all* packets on a connection which exceeds its traffic description,
and Fred seems to be saying drop (at worst) only the *excess*
traffic of such a connection.  Is the disagreement one of intention
or just semantics?

The latter is the right thing, I think, because then you
don't fall off a steep cliff as soon as you get slightly
overloaded or over jittered etc.

-Mark

-------------------------------------------------------------------------------
			Bellcore   Rm. 1A-220B			+1 201 829-4439
Mark W. Garrett		445 South St.			[email-masked]
			Morristown NJ 07960-6438  USA	     (FAX 201 829-2504)
                        WWW: ftp://thumper.bellcore.com/pub/mwg/homepage.html
-------------------------------------------------------------------------------

---

From: Jon Crowcroft <[email-masked]>
Date: Fri, 19 Jan 1996 16:56:47 +0000

>traffic of such a connection.  Is the disagreement one of intention

mea culpa- i meant drop all the packets that are in the proportion
over the traffic spec, not all the packets in a  flow that has broken
its contract....

the point was that we would like there to be no choice about the
action (delay versus drop) ...

 jon