Subject: 802.1 user priority mapping

From: Bryan Gleeson <[email-masked]>
Date: Tue, 16 Dec 1997 11:42:02 -0800 (PST)

I think the default mapping to IEEE 802 user_priority described
in draft-ietf-issll-is802-svc-mapping-01.txt should make provision 
for the concept of "drop priority" as distinct from "delay
priority" to take account of the ongoing diff-serv work. 

The diff-serv proposals use drop priority to tag packets that
fail policing or that are marked as such by applications. If
there is no congestion then you still want the marked packets
to be delivered in order, rather than bumped down to a 
lowest possible delay priority level which would then result
in out of order delivery. This problem is mentioned in the
above draft, however it is assumed there that such flows are 
abusing the network and don't deserve any better. For an
application like multilayered video, marking some packets
as more important than others is not network abuse, but 
a reasonable thing to do. 

At the diff-serv meeting it was emphasized that it was
very important to distinguish between the traffic type
(e.g degree of delay sensitivity) and its importance. 
One person's email could be more important than another's 
internet telephony. A split of the user_priority bits into 
1 bit of drop priority and 2 bits of delay priority would 
probably more closely reflect the diff-serv approaches than 
using 3 bits of delay priority. Other approaches which reserve 
a set of values for drop priority may also be possible. At 
this point I think the default mapping should not use up all 
the bits for delay priority levels, precluding further 
extensions when diff-serv is nailed down, or possible 
use by 802.1 of some form of drop priority semantics.

Bryan Gleeson
Cisco.

---

From: Scott W Brim <[email-masked]>
Date: Tue, 16 Dec 1997 15:28:10 -0500

Brian, while I agree, I think this should be taken up with the IEEE.  How
much discussion has drop priority been getting in their meetings?  We have
room for drop priorities (if we decide to use them) but I don't think we
get to change the semantics of the 802.1p bits.  

...Scott

---

From: Juha Heinanen <[email-masked]>
Date: Wed, 17 Dec 1997 09:00:21 +0200

the current semantics of 802.1p bits are not very useful, since the
whole 3 bit field is dedicated to strict delay priority.  cisco at least
is sending people to ieee meetings.  may be they can bring the issue up?

-- juha