Subject: [100attendees] Arrival Experience

From: Bob Hinden <[email-masked]>
Date: Sat, 11 Nov 2017 11:52:03 +0800

HI,

I arrived after midnight today.  I spend the rest of the night at the Transit hotel in the airport (before immigration).  While small and no windows, it was clean and comfortable.

I changed money and bought a SIM card at the currency exchange booth.

After breakfast, went through immigration and customs.  No lines at 11am, nor any problems.

Ordered an Uber, specified a pickup point (exit door #), car came and too me to the Fairmont, took about 25 minutes.  About $18 SD.

Overall, all very easy and problem free.

Now just waiting for my room to be ready.

Bob

---

From: Harish Pillay 9v1hp <[email-masked]>
Date: Sat, 11 Nov 2017 14:49:25 +0800

Bob -

> Now just waiting for my room to be ready.

Welcome back to Singapore. See you soon.

Harish