Subject: Re: [100attendees] Cash vs. credit cards

From: "Hrvoje (Harry) Dogan (hrdogan)" <[email-masked]>
Date: Thu, 9 Nov 2017 09:43:36 +0000

Szia, Balazs,

On 9/11/17, 16:35, "100attendees on behalf of Balázs Varga A" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

Hi,
Are cards widely accepted (e.g., taxi, shops, etc.) in Singapore?
ATM experience at the airport?
Thanks
Bala’zs

ATMs are literally everywhere. Most taxis take cards, perhaps with a small surcharge. Best to ask before taking it, and the driver will tell you. All other shops take cards. Mostly it’s just local food courts and hawker centres that accept cash only.

Cheers,

H.

---

From: Dmitry Kohmanyuk <[email-masked]>
Date: Thu, 9 Nov 2017 12:32:04 +0200

On 9 лист. 2017 р., at 11:43, Hrvoje (Harry) Dogan (hrdogan) <[email-masked]> wrote:
> 
> Szia, Balazs,
>  
>  
> On 9/11/17, 16:35, "100attendees on behalf of Balázs Varga A" <[email-masked] on behalf of [email-masked]> wrote:
>  
> Hi,

Uber also works (from airport, at least.)
Cash dispensers may be hard to spot Donny advice to take cash in airport (100$-200$ or so  should be more than needed) and just exchange unused on your way back.

Shops, supermarkets, sit-down restaurants and Starbucks all take cards. 

NETS is local payment system.

Recommended to buy Singapore metro card in airport if you plan to use metro. There are two kinds, one for residents and one for tourists.
Ask for assistance,  it's hard to figure out which is which you know already.

---

From: "Hrvoje (Harry) Dogan (hrdogan)" <[email-masked]>
Date: Thu, 9 Nov 2017 10:35:31 +0000

On 9/11/17, 18:32, "Dmitry Kohmanyuk" <[email-masked]<mailto:[email-masked]>> wrote:

Actually, the tourist version of the card just costs more and gives you some attraction discounts. Go to any 7-11 (or you can get it at the MRT (metro) station), and ask for an “ez-link” card. They’re not limited for residents, literally anyone can buy them. They come with some stored value, but you will most likely have to top up – top up machines take cash, and at MRT stops cards as well. You can use your ez-link balance to pay for purchases at 7-11 and taxis.

Cheers.

H.

---

From: Daniel Shaw <[email-masked]>
Date: Thu, 9 Nov 2017 15:28:24 +0400

On 09/11/2017, 14:35, Hrvoje Dogan (Harry hrdogan)	typed:
> 
> 
>  Go to any 7-11 (or you can get it at the MRT (metro) station), and ask for an “ez-link” card. They’re not limited for residents, literally anyone can buy them. They come with some stored value, but you will most likely have to top up – top up machines take cash, and at MRT stops cards as well. You can use your ez-link balance to pay for purchases at 7-11 and taxis.
>  

So very very similar system to those in Yokohama and Seoul then :)

I get to add a 3rd such card to my collection!

The Japanese one is the coolest though, because it was customisable with your name (or any word(s) you typed into the vending machine).

Cheers,
Daniel

---

From: Ole Jacobsen <[email-masked]>
Date: Thu, 09 Nov 2017 05:55:04 -0800 (PST)

The EZ-Link cards are great, but Singapore changed the technology some 
years back and I had to trade in my old card for a new one. This 
required a trip to the POST OFFICE where I waited patiently for their 
online link to the Metro system to come up (it never did). In the end 
they just gave up and provided me with the refund for the old card 
once I explained I was leaving the next morning :-) Unlike some 
countries in Asia (ahem), the concept of flexibility and bending the 
rules slightly is fully embraced :-)

Ole

On Thu, 9 Nov 2017, Hrvoje (Harry) Dogan (hrdogan) wrote:

> Recommended to buy Singapore metro card in airport if you plan to 
> use metro. There are two kinds, one for residents and one for 
> tourists. Ask for assistance, it's hard to figure out which is which 
> you know already.
> 
> 
> Actually, the tourist version of the card just costs more and gives 
> you some attraction discounts. Go to any 7-11 (or you can get it at 
> the MRT (metro) station), and ask for an “ez-link” card. They’re not 
> limited for residents, literally anyone can buy them. They come with 
> some stored value, but you will most likely have to top up – top up 
> machines take cash, and at MRT stops cards as well. You can use your 
> ez-link balance to pay for purchases at 7-11 and taxis.
> 
> 
> Cheers.
> 
> 
> H.
>