Subject: [100attendees] SIM cards/data access

From: Sean Leonard <[email-masked]>
Date: Sat, 4 Nov 2017 22:41:21 -0700

Hi attendees,

Where are folks doing for SIM cards & data access while in Singapore for this IETF?

I found this:
https://www.klook.com/activity/1460-sim-card-singapore

It is US$11 (SGD$15?) for 100GB of data/20 minutes of international calling, in 5 days.

Seems like a good deal. However, my experience with international SIM cards has been that when I replace the SIM in my iPhone, my regular number in iMessage gets deleted after a certain period of time (sometimes instantly), which is a huge hassle because then nobody can message me the usual way until after I return to the US. I am not sure if there is some workaround for that behavior, to keep the iMessages flowing. I suppose there is no way to keep the SMS messages flowing, short of leaving a phone plugged in, in the US, and having the phone forward the SMS messages elsewhere. Phone calls, of course, can be forwarded to other numbers fairly easily.

Thanks,

Sean

---

From: Ole Jacobsen <[email-masked]>
Date: Sat, 04 Nov 2017 23:02:22 -0700 (PDT)

Sean,

I was going to get the non-tourist card from M1:

https://www.m1.com.sg/personal/mobile/prepaidmobile/mcard

... and try to extend the number "forever" by paying S$2.40
every 180 days (if I read it correctly), but that's just
because I sort of collect permanent numbers around the world
:-)

Regarding iMessage, I am pretty sure you can add multiple
numbers without having the old one go away, but I admit
that I am not a regular user of iMessage.

Note that 2G no longer works in Singapore and also that
coverage is really excellent on all the carriers, not to
mention that WiFi is available in many places.

See you in Singapore!

Ole

Ole J. Jacobsen
Editor and Publisher
The Internet Protocol Journal
Office: +1 415-550-9433
Cell:   +1 415-370-4628
Docomo: +81 090 3337-9311
E-mail: [email-masked]
Skype: organdemo

On Sat, 4 Nov 2017, Sean Leonard wrote:

> _______________________________________________
> 100attendees mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/100attendees
>

---

From: Mike Bishop <[email-masked]>
Date: Sun, 5 Nov 2017 06:02:52 +0000

I was looking at https://topup.starhub.com/preorder/ - S$15 gives 15GB for the first five days, and the accompanying S$18 credit is enough for another 2GB over the subsequent seven days, which is more time than I'll be in Singapore.  That's worlds more data than I'm likely to use, so I primarily care about having enough time.  My US SIM will give me SMS regardless (and calling can be saved for Wi-Fi), and I have a dual-SIM phone, so I'm also only considering data rates.

-----Original Message-----
From: 100attendees [mailto:[email-masked]] On Behalf Of Sean Leonard
Sent: Saturday, November 4, 2017 10:41 PM
To: [email-masked]
Subject: [100attendees] SIM cards/data access

Hi attendees,

I found this:

Thanks,

Sean

---

From: Christer Holmberg <[email-masked]>
Date: Sun, 5 Nov 2017 06:22:26 +0000

http://www.visitsingapore.com/travel-guide-tips/tourist-information/connectivity-wifi-prepaid/

Sent from my iPhone

On 5 Nov 2017, at 8.03, Mike Bishop <[email-masked]<mailto:[email-masked]>> wrote:

-----Original Message-----
From: 100attendees [mailto:[email-masked]] On Behalf Of Sean Leonard
Sent: Saturday, November 4, 2017 10:41 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [100attendees] SIM cards/data access

Hi attendees,

I found this:

Thanks,

Sean
_______________________________________________
100attendees mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/100attendees

_______________________________________________
100attendees mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/100attendees

---

From: [email-masked]
Date: 5 Nov 2017 15:43:41 -0000

When I was in Singapore for ICANN a few years ago, I got a cheap SIM
from a kiosk in the mall attached to the conference centre which gave
me more data than I could use in a week along with a voice and SMS
bundle.  For people with lives outside the IETF (rare, I know) it also
had a cheap dialaround option for calls back to North America.

No idea about iphone problems, on my Android phone I have to long back
into my Google account when I switch SIMs but then everything works
fine.

R's,
John

PS: These days VoIP using mobile data usually works but I find that
the voice quality can be a lot worse than actual phone calls.

---

From: Michael StJohns <[email-masked]>
Date: Sun, 05 Nov 2017 16:32:04 +0000

I got tired a few years ago of always worrying about this and moved to
T-mobile.  The US branch at least has a plan that includes 3g international
data roaming and generally cheap”high speed” bump ups if you want them when
you’re on travel.  I mostly don’t use the bump ups  as my main out of the
hotel use is for maps and I can download google maps for the area when I’m
connected to WiFi.  Also includes WiFi calling which just works at an IETF.

It’s wonderful no longer getting the ATT text message indicating that a MB
of data would cost $15.36 each while I was in country.

Mike

On Sun, Nov 5, 2017 at 01:41 Sean Leonard <[email-masked]> wrote:

> Seems like a good deal. However, my experience with international SIM
> cards has been that when I replace the SIM in my iPhone, my regular number
> in iMessage gets deleted after a certain period of time (sometimes
> instantly), which is a huge hassle because then nobody can message me the
> usual way until after I return to the US. I am not sure if there is some
> workaround for that behavior, to keep the iMessages flowing. I suppose
> there is no way to keep the SMS messages flowing, short of leaving a phone
> plugged in, in the US, and having the phone forward the SMS messages
> elsewhere. Phone calls, of course, can be forwarded to other numbers fairly
> easily.
>
> Thanks,
>
> Sean

---

From: Carlos Marcelo Martinez Cagnazzo <[email-masked]>
Date: Sun, 05 Nov 2017 13:35:19 -0300

Sadly few carriers if any outside the US offer a similar plan.
I walked into a T Mobile store and offered them to pay the full amount of the contract up front but even so they could not sell it to me since I dont have credit history in the US.
So I still do be SIM dance, on a dual SIM Android phone.

via Newton Mail [https://cloudmagic.com/k/d/mailapp?ct=pi&cv=9.8.91&pv=11.0.3&source=email_footer_2]
On Sun, Nov 5, 2017 at 1:32 PM, Michael StJohns <[email-masked]> wrote:
I got tired a few years ago of always worrying about this and moved to T-mobile. The US branch at least has a plan that includes 3g international data roaming and generally cheap”high speed” bump ups if you want them when you’re on travel. I mostly don’t use the bump ups as my main out of the hotel use is for maps and I can download google maps for the area when I’m connected to WiFi. Also includes WiFi calling which just works at an IETF.
It’s wonderful no longer getting the ATT text message indicating that a MB of data would cost $15.36 each while I was in country.
Mike

On Sun, Nov 5, 2017 at 01:41 Sean Leonard < [email-masked] [[email-masked]] > wrote:
Hi attendees,

I found this:
https://www.klook.com/activity/1460-sim-card-singapore [https://www.klook.com/activity/1460-sim-card-singapore]

Thanks,

Sean
_______________________________________________
100attendees mailing list
[email-masked] [[email-masked]]
https://www.ietf.org/mailman/listinfo/100attendees [https://www.ietf.org/mailman/listinfo/100attendees]

---

From: Saleem Bhatti <[email-masked]>
Date: Sun, 5 Nov 2017 17:29:53 +0000

If you are a Three customer, then Singapore is a (recently added) "Feel At Home" destination, i.e. your current contract allowance gets used as if you were in your home country. I am assuming this applies to whichever home country in which you are a Three customer, but here is the info from the UK web-site:

  http://www.three.co.uk/feel-at-home/
  http://www.three.co.uk/support/roaming/singapore

(Not intended to be an advert for Three, of course, just FYI for those who use Three.)

Cheers,
--/Saleem

On 05 Nov 2017, at 16:35, Carlos Marcelo Martinez Cagnazzo <[email-masked]<mailto:[email-masked]>> wrote:

[https://tr.cloudmagic.com/h/v6/emailtag/tag/2.0/1509899719/96f2d3060286ecbab9150cfe7cb38c63/7/9b4df0e07a0b3e3cf0b9303795f0b642/38fe39ae86593a52d2c297e45931a9f7/1d6d5403e7e1e3f620d7e233ab439b9c/newton.gif]
Sadly few carriers if any outside the US offer a similar plan.

via Newton Mail<https://cloudmagic.com/k/d/mailapp?ct=pi&cv=9.8.91&pv=11.0.3&source=email_footer_2>

On Sun, Nov 5, 2017 at 1:32 PM, Michael StJohns <[email-masked]<mailto:[email-masked]>> wrote:
I got tired a few years ago of always worrying about this and moved to T-mobile. The US branch at least has a plan that includes 3g international data roaming and generally cheap”high speed” bump ups if you want them when you’re on travel. I mostly don’t use the bump ups as my main out of the hotel use is for maps and I can download google maps for the area when I’m connected to WiFi. Also includes WiFi calling which just works at an IETF.

Mike

On Sun, Nov 5, 2017 at 01:41 Sean Leonard <[email-masked]<mailto:[email-masked]>> wrote:
Hi attendees,

I found this:

Thanks,

Sean

---

From: [email-masked]
Date: 5 Nov 2017 17:32:00 -0000

In article <[email-masked]> you write:
>data roaming ...

Please let us know when they get around to providing service in the
U.S.  Where I live, AT&T, VZ, and Sprint work fine, T-Mo not at all.
I know where the towers are since I negotiated the tower contracts for
AT&T, Sprint, and Sprint predecessor Nextel, and T-Mo has never
bothered to show up.  Their maps say they have coverage, but they are
lying.  They could cover gaps by roaming on AT&T but they don't do
that, either.

On the other hand, I find that I can usually get foreign SIMs for far
less than the $45/mo that T-Mo costs which give me a local number and
free or cheap calls back to the U.S. along with a big blob of data.

R's,
John

---

From: Sean Leonard <[email-masked]>
Date: Sun, 5 Nov 2017 22:45:24 -0800

Thanks all.

For those who are going the route of getting a local Singaporean prepaid 
SIM card:

Looks like that https://topup.starhub.com/preorder/ is a great deal. 
 From the website, it appears that the $18 credit can be used for 2x 
7-day 1GB data plans @ $7 each = $14, with $4 to spare for SMS or other 
miscellaneous charges? And it gives you a local Singaporean number, for 
as long as it lasts (so to speak...well, specifically, 180 days, but the 
fine print says it can be extended with a top-up)?

That one seems better than the M1 tourist card (identical to Klook link 
I originally posted), in that the M1 tourist card seems to die in 5 days 
or 10 days, with no renewal possibility.

Sean

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Mon, 6 Nov 2017 07:35:39 +0000

A variation of the original question: what about an IPv6-capable mobile provider ?

-éric

On 06/11/17 07:45, "100attendees on behalf of Sean Leonard" <[email-masked] on behalf of [email-masked]> wrote:

    Thanks all.

    
    
    Sean

---

From: Randy Bush <[email-masked]>
Date: Mon, 06 Nov 2017 18:18:58 +0800

last eve, i walked out of customs, ignored the stand in front of me,
and walked to the starhub stand maybe 25m to the right.  the cheap sim
was to short, as i am here for two weeks (setup).  so i paid sg$50 for
20GB and more voice and data than i could possibly use.

i am sure you can do cheaper.  beware of the data; some plans quote
SG-only data

http://www.starhub.com/personal/mobile/travel-roam/visiting-singapore.html

randy

---

From: Ted Lemon <[email-masked]>
Date: Mon, 6 Nov 2017 12:12:47 +0100

> i am sure you can do cheaper.  beware of the data; some plans quote

Do you mean that you can only connect to IP addresses in Singapore with these SIMs?

---

From: Randy Bush <[email-masked]>
Date: Mon, 06 Nov 2017 19:32:11 +0800

> Do you mean that you can only connect to IP addresses in Singapore

they're X gig for connecting to SG addresses and Y gig for {countries}.
yes, it's kinky.

---

From: Mikael Abrahamsson <[email-masked]>
Date: Mon, 6 Nov 2017 12:41:10 +0100 (CET)

> they're X gig for connecting to SG addresses and Y gig for {countries}. 

When I read it, that's not my interpretation. They're limiting roaming. As 
in when you're in those countries.

http://www.starhub.com/personal/mobile/mobile-phones-plans/prepaid-cards/travel-sim.html?cardItem=1

So it's "local data" and "roaming data". So with the cheapest option, you 
don't get any roaming (which is ok). On what are you basing your 
conclusion that it limits whereto you can communicate when you're in SG?

"And now, there's no need for a local SIM card each time you’re in another 
country. Just surf at Singapore data rates in Malaysia, Indonesia, 
Thailand and other popular destinations with Happy Roam."

I think this is their point they're trying to make, not that you only can 
talk to SG IP addresses when you're in SG.

-- 
Mikael Abrahamsson    email: [email-masked]

---

From: Ted Lemon <[email-masked]>
Date: Mon, 6 Nov 2017 12:41:18 +0100

> they're X gig for connecting to SG addresses and Y gig for {countries}.

Wow.   Thanks for the heads-up!   I guess one could fork a linode for the week and VPN through it... :)

---

From: Randy Bush <[email-masked]>
Date: Mon, 06 Nov 2017 19:49:02 +0800

>> they're X gig for connecting to SG addresses and Y gig for
>> {countries}. yes, it's kinky.
> 
> When I read it, that's not my interpretation. They're limiting
> roaming. As in when you're in those countries.

we can conjecturbate all we want.  i only know ehat the tech at the desk
told me.

when you are here, please experiment and report the results.

randyc

---

From: "Hrvoje (Harry) Dogan (hrdogan)" <[email-masked]>
Date: Mon, 6 Nov 2017 12:00:24 +0000

Hi guys, Singapore resident here.

    
    
Techs at the desk are usually clueless ;) Mikael is right. That’s data access *from* Singapore, vs roaming from other countries. Singaporean mobile providers usually include free or discounted roaming for neighbouring countries even in their prepaid plans, and that’s what they’re describing. There is no way allowing connections to Singaporean-only IPs would ever work :)

Cheers,

Harry

---

From: [email-masked]
Date: 6 Nov 2017 15:57:40 -0000

>fine print says it can be extended with a top-up)?

There's no need to preorder -- you can get the same card over the counter
at their kiosks at the airport.

---

From: "John R. Levine" <[email-masked]>
Date: 6 Nov 2017 11:10:27 -0500

> we can conjecturbate all we want.  i only know ehat the tech at the desk

The tech (and anyone else) might want to look at Starhub's web site:

It says you get 15GB usable in Singapore for 10 days, and 5GB usable 
elsewhere (including Japan and the U.S.) for 30 days.  When your 10 days 
are up, you can add some much more expensive data topups:

http://www.starhub.com/personal/mobile/mobile-phones-plans/prepaid-cards/data-add-on-plans/prepaid-data-plan.html

Regards,
John Levine, [email-masked], Primary Perpetrator of "The Internet for Dummies",
Please consider the environment before reading this e-mail. https://jl.ly

---

From: Jim Fenton <[email-masked]>
Date: Mon, 6 Nov 2017 17:13:42 -0800

> Where are folks doing for SIM cards & data access while in Singapore for this IETF?

I'm on AT&T in the US, and they have an option called "International Day
Pass" that, for US$10/day, allows you to use your home data, text, and
voice plan. It doesn't cost anything if you don't use it, so it's a good
insurance plan if you forget to turn off data roaming and show up in
another country, or in the interim before getting an in-country SIM.

I was planning to just use Day Pass from Singapore, but the in-country
options look really cost effective.
> Seems like a good deal. However, my experience with international SIM cards has been that when I replace the SIM in my iPhone, my regular number in iMessage gets deleted after a certain period of t…

Have you tried adding the international number to your Apple account?
(just a guess)

-Jim

---

From: Bill Silverajan <[email-masked]>
Date: Tue, 7 Nov 2017 09:57:53 +0200

I've tried Singtel's SGD$30 "hi!tourist" SIM card that's valid for 10 
days. 
(https://www.singtel.com/personal/i/phones-plans/mobile/prepaid/hitouristsimcards). 
I've used all three operators (Singtel, M1 and Starhub) and I've been 
fairly happy with Singtel's LTE coverage.

When you get the SIM card, they also give you a free EZ-Link card with 
SGD$3 preloaded, that's used in buses and the MRT (metro) trains in 
Singapore. If you otherwise get an EZ-Link card from the MRT station 
control you'd have to pay a small deposit fee, I think.

A word of warning when buying prepaid SIM cards in Singapore: Many of 
the numbers are recycled, so I've encountered lots of incoming calls 
from unknown numbers (even from India and Bangladesh) as well as 
marketing ads. This is one reason why I generally use a spare phone, 
keep it on silent and just use the phone as a mobile hotspot for the 
duration of my stay.

Also you'd need some form of identification when you purchase a prepaid 
card (such as a passport).

Regards,
Bill

On 06/11/17 18:10, John R. Levine wrote:
> elsewhere (including Japan and the U.S.) for 30 days.  When your 10 
> days are up, you can add some much more expensive data topups:
>

---

From: Sean Leonard <[email-masked]>
Date: Fri, 10 Nov 2017 16:18:52 -0800

> On Nov 6, 2017, at 7:57 AM, [email-masked] wrote:
> 

Found out the hard way that the $15 SGD card is *not* available at the (Terminal 2 arrival) airport counter. They may be somewhere else, but StarHub only lists more expensive ones. Best to pre-order.

Sean

---

From: Harish Pillay 9v1hp <[email-masked]>
Date: Sat, 11 Nov 2017 08:22:04 +0800

> Found out the hard way that the $15 SGD card is *not* available at the (Terminal 2 arrival) airport counter. They may be somewhere else, but StarHub only lists more expensive ones. Best to pre-orde…

You should be able to get them around the Raffles City location. Go to
Peninsula Plaza [0] about 200 meters west of Raffles City. There are many
stores selling prepaid cards of all types.

Harish
[0] https://goo.gl/maps/RLDEWA4F9qt

---

From: Sean Leonard <[email-masked]>
Date: Fri, 10 Nov 2017 16:23:42 -0800

> On Nov 10, 2017, at 4:22 PM, Harish Pillay 9v1hp <[email-masked]> wrote:
> 

Thanks.

What’s the [best] offer, for ~10 days' usage?

---

From: Harish Pillay 9v1hp <[email-masked]>
Date: Sat, 11 Nov 2017 08:54:23 +0800

> What’s the [best] offer, for ~10 days' usage?

I can't suggest as I am local. Get what makes sense to you.

Harish

---

From: Ted Lemon <[email-masked]>
Date: Sat, 11 Nov 2017 09:32:39 +0800

> Found out the hard way that the $15 SGD card is *not* available at the (Terminal 2 arrival) airport counter. They may be somewhere else, but StarHub only lists more expensive ones. Best to pre-orde…

You can buy it at the currency exchange.

---

From: Sean Leonard <[email-masked]>
Date: Sat, 11 Nov 2017 10:05:04 +0800

Yes, I subsequently confirmed. UOB Currency Exchange on the arrival and departure levels (in terminal 2) has them, although they are not advertised.

> On Nov 11, 2017, at 9:32 AM, Ted Lemon <[email-masked]> wrote:
>

---

From: Chris Shen <[email-masked]>
Date: Sat, 11 Nov 2017 11:22:30 +0900

I got the prepaid $15 sim card of Singtel at the currency exchange port of
Terminal 4. There also are some other more expensive sim cards selling
there, Starhub or M1, I asked them if they provide other options for sim
cards, they say they only sell $30 and $50 kinds.

So find the currency exchange port to get $15, or if you can't, any 711 in
the city has this $15 sim card to sell.

On Sat, Nov 11, 2017 at 10:32 AM, Ted Lemon <[email-masked]> wrote:

> Found out the hard way that the $15 SGD card is *not* available at the
> (Terminal 2 arrival) airport counter. They may be somewhere else, but
> StarHub only lists more expensive ones. Best to pre-order.
>
>

-- 
Yiwen (Chris) Shen, Ph.D. Candidate

IoT Lab: *http://iotlab.skku.edu <http://iotlab.skku.edu/>*
Sungkyunkwan University, Suwon, South Korea
Mobile:+82-(0)10-6871-8103
Email: [email-masked]

---

From: [email-masked]
Date: 11 Nov 2017 07:12:05 -0000

>What’s the [best] offer, for ~10 days' usage?

Probably the Singtel Hi!Tourist $30 card, good for 10 days, 100GB of
data, unlimited local calls and SMS, 90 mins of int'l calls.

---

From: Daniel Shaw <[email-masked]>
Date: Sat, 11 Nov 2017 15:57:03 +0800

> Yes, I subsequently confirmed. UOB Currency Exchange on the arrival and departure levels (in terminal 2) has them, although they are not advertised.

UOB exchange in T1 however, doesn't have them.

They do have the more expensive $32 ones, with 15GB valid for 10 days as you may expect.

Although I know there are "better" deals to be had, the convenience of just getting everything done as I exited the 'plane won out and I took one of these. I got a Starhub.

However, when I subsequently checked into my hotel (Grand Pacific), the room comes with a "handy phone" - and android device that you can carry around with you, which includes unlimited data. And it works as a mobile hotspot. :-)

That does mean carrying an extra device, and one with untested battery life. But I'm ok with that.

I therefore have an activated and working SIM I'd be happy to part with for some mutually agreed on donation towards a power bank, but of course less that the original cost.

It has one day's usage today totalling about 100MB out of the 15GB. It worked fine all around the venue area at almost always 4G. The data bundle is valid for 10 days form today.

If anyone'd like to take it, I'll be around the venue tomorrow morning in the Sofia room. Reply off list and we can arrange to meet.

Regards,
Daniel

---

From: Mike Bishop <[email-masked]>
Date: Sat, 11 Nov 2017 21:15:05 +0000

There’s also a 7-11 on the level of the airport above Departures.  Go past the KFC and it’s way in the back.  I got the $15 StarHub SIM there – 15GB for five days, then $15 credit will buy ~3GB for the remaining days.

From: 100attendees [mailto:[email-masked]] On Behalf Of Chris Shen
Sent: Saturday, November 11, 2017 10:23 AM
To: Ted Lemon <[email-masked]>
Cc: [email-masked]; Sean Leonard <[email-masked]>; [email-masked]
Subject: Re: [100attendees] SIM cards/data access

I got the prepaid $15 sim card of Singtel at the currency exchange port of Terminal 4. There also are some other more expensive sim cards selling there, Starhub or M1, I asked them if they provide other options for sim cards, they say they only sell $30 and $50 kinds.

So find the currency exchange port to get $15, or if you can't, any 711 in the city has this $15 sim card to sell.

On Sat, Nov 11, 2017 at 10:32 AM, Ted Lemon <[email-masked]<mailto:[email-masked]>> wrote:
On Nov 11, 2017, at 8:18 AM, Sean Leonard <[email-masked]<mailto:[email-masked]>> wrote:
Found out the hard way that the $15 SGD card is *not* available at the (Terminal 2 arrival) airport counter. They may be somewhere else, but StarHub only lists more expensive ones. Best to pre-order.

IoT Lab: http://iotlab.skku.edu<http://iotlab.skku.edu/>
Sungkyunkwan University, Suwon, South Korea
Mobile:+82-(0)10-6871-8103
Email: [email-masked]<mailto:[email-masked]>

---

From: Ted Lemon <[email-masked]>
Date: Sun, 12 Nov 2017 09:39:39 +0800

> There’s also a 7-11 on the level of the airport above Departures.  Go past the KFC and it’s way in the back.  I got the $15 StarHub SIM there – 15GB for five days, then $15 credit will buy ~3GB for…

Setup was a lot more involved for these.   They seem to work just as well, and you get more data, but it took about ten minutes to set up at 7-11 when I did it with a friend; the singtel SIM just worked as soon as the lady behind the counter at the currency exchange place handed it to me.   So, I guess you get to pick which thing is more important.   :)

---

From: [email-masked]
Date: 12 Nov 2017 02:09:06 -0000

In article <[email-masked]> you write:
>-=-=-=-=-=-
>-=-=-=-=-=-
>There’s also a 7-11 on the level of the airport above Departures.  Go past the KFC and it’s way in the back.  I got the $15 StarHub SIM there – 15GB
>for five days, then $15 credit will buy ~3GB for the remaining days.

I got a $30 Singtel tourist SIM at the Singtel kiosk in the mall
attached to the conference centre.  It took about 5 mins once I got to
the head of the queue.  They needed my passport, apparently a legal
requirement here.

I get 100GB of data, 3000 local minutes, 5000 local SMS, 90
international minutes, good for 10 days.  Seems like a better deal
than the 15+15.  It also includes 2GB good for a month in Malaysia,
Indonesia, and Australia.

It should also be available at Singtel kiosks at the airport.

R's,
John

---

From: Bryan Call <[email-masked]>
Date: Sun, 12 Nov 2017 10:55:54 +0800

I went to the Sigtel store in the mall this morning and picked up a 7 day, 100GB of data, 500 local minutes, 100 local SMS, and 300 international minutes sim for $15.  They also have the 10 day sim for $30.

Map:
https://goo.gl/maps/CpQDRtaQ2EH2

-Bryan

> On Nov 12, 2017, at 10:09 AM, [email-masked] wrote:
>