Subject: [100attendees] Love buffer bloat -- cannot get enough of it

From: "Lubashev, Igor" <[email-masked]>
Date: Sat, 11 Nov 2017 06:52:21 +0000

Now that we figured that Singapore customs are not as bad, a technical question for a change.

Does anyone know how to make Cisco 2900 assign really big buffers per port?  We would love the router to build up huge buffers for ports whose link speeds are lower than the rate of incoming data.

  *   Igor

---

From: joel jaeggli <[email-masked]>
Date: Sat, 11 Nov 2017 16:32:31 +0800

On 11/11/17 14:52, Lubashev, Igor wrote:
> Does anyone know how to make Cisco 2900 assign *really* big buffers per
> port?  We would love the router to build up huge buffers for ports whose
> link speeds are lower than the rate of incoming data.

29xx maps to a multitude of devices but something like the following on
ios xe

1.    enable

2.    conf t

3.    policy-map bloat-policy

4.    class class-map-bloat

5.    bandwidth {bandwidth-kbps | percent percent

6.    queue-limit number-of-packets

7.    end

packets-per-queue range is 1 to 2,000,000 on an asr, that should be
enough for some clowning.

5ms on 100G port is stll around half a gig so your milage may vary.

>  
> 
>   * Igor
> 
> 
> _______________________________________________
> 100attendees mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/100attendees
>

---

From: "Lubashev, Igor" <[email-masked]>
Date: Sat, 11 Nov 2017 08:49:31 +0000

Thanks, Joel!  We'll give it a spin.

> 5ms on 100G port is stll around half a gig so your milage may vary.

Indeed.  That's why we are trying it on a 100M port. :)

-----Original Message-----
From: joel jaeggli [mailto:[email-masked]] 
Sent: Saturday, November 11, 2017 4:33 PM
To: Lubashev, Igor <[email-masked]>; [email-masked]
Subject: Re: [100attendees] Love buffer bloat -- cannot get enough of it

On 11/11/17 14:52, Lubashev, Igor wrote:
> Does anyone know how to make Cisco 2900 assign *really* big buffers 
> per port?  We would love the router to build up huge buffers for ports 
> whose link speeds are lower than the rate of incoming data.

29xx maps to a multitude of devices but something like the following on ios xe

1.    enable

2.    conf t

4.    class class-map-bloat

7.    end

packets-per-queue range is 1 to 2,000,000 on an asr, that should be enough for some clowning.