Subject: Re: [6lowpan] goals draft issues

From: Samita Chakrabarti <[email-masked]>
Date: Thu, 6 Oct 2005 15:56:58 -0700 (PDT)

> From: "Kushalnagar, Nandakishore" <[email-masked]>
> To: <[email-masked]>

Issue:

The security considerations are still "TBD". Gabriel Montenegro proposed
mining the security considerations section of the format document for
possible input.

NK:

I am soliciting for some feedback here as to what this section is
supposed to have? 

Chairs/others?
--------------------------------

Hi Nandu,

In the first meeting of LowPan wg (BOF?), folks brought up the
security consideration issues. It was mentioned that 802.15.4
link-layer security should be enough.  The following paper
depicts some of the problem scenarios with 802.15.4 security:

http://www.cs.berkeley.edu/~nks/papers/15.4-wise04.pdf

I was told by a security expert that 802.15.4 security is not
good enough. The above paper recomends a few modifications - does
anyone know if IEEE 802.15.4 workgroup is looking into improving
the link-layer security? 

I don't think IPsec security is a feasible solution on this kind
of small devices where 6lowpan would eventually run. It'd be 
interesting to get people's viewpoint on this.

Since we are routing at the link-layer, it would be better if we
have tighter link-level security and then application level security
using crypto.   Perhaps the protocols running on top of LowPan
can run some security protocols  that are appropriate for this kind
of network.

Comments?

-Samita

_______________________________________________
6lowpan mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/6lowpan

---

From: Soohong Daniel Park <[email-masked]>
Date: Sat, 08 Oct 2005 16:23:37 +0900

> can run some security protocols  that are appropriate for this kind

Current draft said; (in both problem statements and goals)

4.6  Security

Although IEEE 802.15.4 provides AES link layer security, a complete
end-to-end security is needed.

8.  Security threats at different layers must be clearly understood
and documented.  Bootstrapping of devices into a secure network
could also be considered given the location, limited display,
high density and ad hoc deployment of devices.

So, I prefer not to address more specific something in Security Considerations. Just refering them into Security Considerations would be fine for me. If rechartering requires more details on security issue, it could be a separated document (at least *6lowpan security threat analysis*).

Regards,

Daniel (Soohong Daniel Park)
Mobile Platform Laboratory, SAMSUNG Electronics.

---

From: Soohong Daniel Park <[email-masked]>
Date: Tue, 11 Oct 2005 11:17:57 +0900

Hi Samita again...:-)

> can run some security protocols  that are appropriate for this kind

Your comment seems very interesting for me to raise the awareness of 6lowpan security. Yes, 802.15.4 security is not good enough in my understanding. Also, IPSec is not appropriate to 6lowpan small device. So, I think *6lowpan security threat analysis* should be documended prior to moving specific solutions on. Obviously, 6lowpan requires security protocols. 

Regards,

---

From: gabriel montenegro <[email-masked]>
Date: Tue, 11 Oct 2005 23:48:15 -0700 (PDT)

802.15.4b is improving somewhat the link security. I *believe*, for example, that they
have deprecated (or recommended against) CBC-CTR (one of the weaknesses identified in 
the paper) and recommend CCM* (also recommended by ZigBee according to their public
tutorials at their open house events), supposedly a much improved mode. Not sure about
other
security related changes, but I'm sure there are plenty of 15.4b-savvy folks on this
alias.
Hopefully, they can respond. It might even be a good idea to have a quick update by one
of those folks at the meeting.

-gabriel

ps - another thing 15.4b is doing is increasing the speed for the sub-1GHz PHYs to bring
them
up to 250 Kbps.