Subject: [6lowpan] Comments on draft-ietf-6lowpan-format-01 Header Compression

From: David Green <[email-masked]>
Date: Sun, 06 Nov 2005 17:36:47 -0700

draft-ietf-6lowpan-format-01.txt section 8:

"Given the very limited packet sizes, it is highly desirable
to
integrate layer 2 with layer 3
compression, something typically
not
done."

Actually link-layer assist is quite commonly done - see:

RFC 3242 - RObust Header Compression (ROHC): A Link-Layer
Assisted Profile for IP/UDP/RTP

Also, I have a draft written on point-to-multipoint header
compression that you may find useful for this section.

-David Green

_______________________________________________
6lowpan mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/6lowpan

---

From: gabriel montenegro <[email-masked]>
Date: Mon, 7 Nov 2005 01:17:11 -0800 (PST)

I wrote that based on a conversation a while back with Carsten (before he was chair) 
in which he said this was not typically done. 

Carsten, care to elaborate?

As for the effect on the draft, we can just delete this text if there's any objection.
It was just meant as background info and has no normative weight whatsoever.

-gabriel

--- David Green <[email-masked]> wrote:

---------------------------------
draft-ietf-6lowpan-format-01.txt section 8: 
 
"Given the very limited packet sizes, it is highly desirableto
      integrate layer 2 with layer 3compression, something typically
      notdone."

RFC 3242 - RObust Header Compression (ROHC): A Link-LayerAssisted Profile for IP/UDP/RTP
 
Also, I have a draft written on point-to-multipoint headercompression that you may find
useful for this section. 
 
-David Green