Subject: [6lowpan] RE: IPv6 (and IPv4) over IEEE 802.15.3 ?

From: Daniel Park <[email-masked]>
Date: Mon, 26 Feb 2007 09:38:27 +0900

(ccing 6lowpan list)

Markku,

No space for this discussion in IETF yet. If you have any
tangible and applicable use cases in conjunction with IP
over 802.15.3, it should be chartered to develop the solutions.

Several years back, IP over 802.15.1 (BT) occurred in
IETF, but failed to be formed a new WG. From the IP 
perspective, 6lowpan (IPv6 over 802.15.4) has its applicable 
area as ZigBee and this kinds of IP connectivity. 16ng 
(IP over 802.16) has also its applicable area such as 
WiMAX and WiBro IP networks. 

Is there any specific reason for IETF to develop IP over
802.15.3 solutions ? Otherwise, I'd recommend you to
work on that via Individual Track regardless of any specific
WGs at this stage. Also, 6lowpan would be better 
place for further discussion than IPv6 since they have
WPAN expertises...

My 0.02 cents.

Daniel 

-----Original Message-----
From: Markku Savela [mailto:[email-masked]] 
Sent: Thursday, February 22, 2007 7:58 PM
To: [email-masked]
Subject: IPv6 (and IPv4) over IEEE 802.15.3 ?

Hi,

Slightly off topic, but I'm trying to find something that would guide how to
map IPv6 (and also IPv4) over IEEE 802.15.3 link layer.

I only found 6lowpan for 802.15.4. Where is the same for 802.15.3?

--
Markku Savela

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

_______________________________________________
6lowpan mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/6lowpan

---

From: Markku Savela <[email-masked]>
Date: Tue, 27 Feb 2007 11:27:22 +0200

[this is somewhat offtopic for 6lowpan]

> From: Daniel Park <[email-masked]>
> 

I just have to make IP happen over a wireless link device (which is
still a protype or does not event exist) that claims to be
802.15.3. The API's provided are almost straight from the IEEE
standard in format

MA-UNITDATA.request (
                    SourceAddress,
                    DestinationAddress,
                    RoutingInformation,
                    Data,
                    Priority,
                    ServiceClass
                    )

Note, the obnoxious "Priority" and "ServiceClass" *after* the variable
length data, seemed ridiculous layout (and may cause need to copy data in
linux driver to expand sk_buff for them for each packet... yechh!)

Of course, this is internal, not on the wire format. For the wire I
would need to know how to put the additional require "EtherType" into
payload. I seem to have two choices

 1) 802.15.3b way, use 8 first octets of the payload for LLC/SNAP

 2) ECMA-368 (Annex A.1 MUX service), use 2 first octets of the
    payload for EtherType.

To me, ECMA way seems much more compact, but of course, if someone
else is doing link layer for this 15.3, would prefer to use the same
payload format. That's why I was asking around for opinions...