Subject: RE: [6lowpan] WG rechartering

From: "Schumacher Christian Peter Pii" <[email-masked]>
Date: Thu, 8 Feb 2007 09:12:48 +0100

I believe the two terms are related to a certain degree.
The difference could be that bootstrapping is for initial network setup whereas commissioning is network management for the entire lifecycle of a device.

-----Original Message-----
From: Geoff Mulligan [mailto:[email-masked]] 
Sent: 7. februar 2007 18:30
To: Ki-Hyung Kim
Cc: 6lowpan
Subject: Re: [6lowpan] WG rechartering

Are commissioning and bootstrapping the same?  How do we define
bootstrapping?

	geoff

On Wed, 2007-02-07 at 11:28 +0900, Ki-Hyung Kim wrote:
> Bootstrapping is one of the important issues. I think commissioning
> might be more appropriate term which can include bootstrapping as a
> core protocol.
> 
> 
>  
> On 2/7/07, Daniel Park <[email-masked]> wrote: 
>         Bootstrapping is one of important issues around 6lowpan,
>         hence I agree with Samita's suggestion as well. 
>         
>         Regarding 6lowpan mobility, MANEMO looks like a relevant
>         place within IETF as of today, but INT AD's decision does
>         not allow us to have a BOF in Prague at this stage.
>         
>         Anyhow, I am suggesting 6lowpan mobility for further study 
>         as one of rechartering items. As Samita pointed out, its
>         problem statements are already available and we are in the
>         progress of ellaborating on that.
>         
>         Daniel (Soohong Daniel Park)
>         Mobile Convergence Laboratory, SAMSUNG Electronics. 
>         
>         ----- Original Message -----
>         From: "Samita Chakrabarti" <[email-masked]>
>         To: "Geoff Mulligan" <[email-masked]>
>         Cc: "6lowpan" <[email-masked]>
>         Sent: Wednesday, February 07, 2007 3:53 AM
>         Subject: Re: [6lowpan] WG rechartering
>         
>         
>         > Hi Geoff, 
>         >
>         > The list looks good.
>         >
>         > Last time we also discussed a need for a document on
>         boot-strapping.
>         > Is it still on the agenda?  Personally I prefer
>         bootstrapping should be a
>         > separate document; we also have to figure out the
>         requirements for 
>         > bootstrapping in this space.
>         >
>         > The second point is on mobility analysis - recently with
>         MANEMO (Network
>         > mobility for MANET) discussion, some interesting points came
>         out regarding
>         > 6lowpan mobility. Daniel Park, Jim Bound brought this up
>         and 
>         > we are working on updating
>         > my expired draft on 6lowpan mobility requirements.  So, may
>         be we can keep
>         > mobility item in the radar if not on the charter list for
>         now.
>         >
>         > Thanks,
>         > -Samita 
>         >
>         >
>         > On 2/6/07, Geoff Mulligan <[email-masked]> wrote:
>         >> Folks,
>         >>  We have reached a milestone.  We have submitted the
>         Problem Statement 
>         >> document and the Format Document to our AD for
>         publication.  We have
>         >> completed the original charter of the WG.
>         >>
>         >> Mark will review the documents and then submit them for
>         IETF LC (2 
>         >> weeks) and then IESG review and discussion, which will
>         hopefully happen
>         >> on the IESG telechat on March 8th.
>         >>
>         >> So now it is very important that we finalize our thoughts
>         about
>         >> rechartering the Working Group for new work, should we want
>         to take on
>         >> new work.
>         >>
>         >> Some of the items that people have indicated interest in
>         working on:
>         >>  Neighbor Discovery and Secure Neighbor Discovery (proposed
>         standard) 
>         >>  Stateful header compression (informational)
>         >>  6lowpan applications (informational)
>         >>  mesh routing (proposed standard)
>         >>  Security analysis (informational)
>         >>
>         >> If there are other ideas as to work the WG should be
>         looking at, please 
>         >> send them to the list.  If you think that we are finished,
>         please send
>         >> that to the list also.
>         >>
>         >> We plan to have a call with our AD next Monday the 12th and
>         I would like
>         >> to hear from the group before then. 
>         >>
>         >>        geoff
>         >>
>         >>
>         >>
>         >>
>         >>
>         >>
>         >> _______________________________________________
>         >> 6lowpan mailing list
>         >> [email-masked]
>         >> https://www1.ietf.org/mailman/listinfo/6lowpan
>         >>
>         >
>         > _______________________________________________
>         > 6lowpan mailing list 
>         > [email-masked]
>         > https://www1.ietf.org/mailman/listinfo/6lowpan
>         >
>         >
>         
>         _______________________________________________ 
>         6lowpan mailing list
>         [email-masked]
>         https://www1.ietf.org/mailman/listinfo/6lowpan
> 
> 
> 
> -- 
> Ki-Hyung Kim (김기형, 金起亨)
> Associate Professor
> Division of Information and Computer Eng., Ajou University, Suwon,
> Korea 442-749
> Tel: +82-31-219-2433, Cel: +82-17-760-2551,  Fax: +82-31-219-2433
> http://www.6lowpan.org 

_______________________________________________
6lowpan mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/6lowpan

_______________________________________________
6lowpan mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/6lowpan

---

From: Daniel Park <[email-masked]>
Date: Fri, 09 Feb 2007 08:35:35 +0900

It depends on how to define each term in 6lowpan area.
Obviously, we should elaborate and clarify on each terms
if necessary...

-----Original Message-----
From: Geoff Mulligan [mailto:[email-masked]] 
Sent: 7. februar 2007 18:30
To: Ki-Hyung Kim
Cc: 6lowpan
Subject: Re: [6lowpan] WG rechartering

geoff

---

From: "Yong-Woon KIM" <[email-masked]>
Date: Tue, 27 Feb 2007 17:05:03 +0900

Sure, it does.

Schumacher's clarification seems good.
But there is another viewpoint.
"who should care for the network management?"

From sales and marketing points of view, here are two questions:
what kinds of products should we develop?
whom we should bring the products to for sales?

The network management can be clarified into two viewpoints:
operator-side and installer-side. 
NMS is an operator-side management tool and
commissioning system is installer-side.
That is, most sensor networks aren't installed by operators themselves but
installation professionals such as SI(system integration) and 
NI(network integration) companies. 

So, the comissioning system has to focus on how to install sensor
devices and sensor networks and how to manage them locally at installation sites.
In order to support these points, 
it needs to support checkup and setup for physical component configuration 
(a device component cannot be detected), electrical ground, hardware profile,
various configuration files, functional profiles, topology management,
device management, etc.

Consequently here are my summary:
- comissioning seems proper as a business term, not a technology term.
- bootstrapping seems a technology term and might be better for 6lowpan because
  it can help 6lowpn focus on technology issues including initial setup and
  installer-side network management.
- network management should be clarified from operator's and installer's points of view.
- two prospective products: NMS and commisioning system.
- commissing system should include bootstrapping.
- bootstrapping-itself product seems a non-sense in the context of my opinion.

--
Qkim

>>         >> to hear from the group before then. 

--------------------------------------------------------------------------------

---

From: Geoff Mulligan <[email-masked]>
Date: Tue, 27 Feb 2007 17:40:05 -0700

This is a very interesting idea.

I think there are some folks that might consider commission a technical
issue also.

	geoff