Subject: [6lowpan] Comment... internet-drafts/draft-ietf-6lowpan-format-11.txt

From: Markku Savela <[email-masked]>
Date: Thu, 15 Mar 2007 16:06:39 +0200

Just a short question, out of curiosity I was looking for how it does
the multicast mapping, and got into chapter 9 "Multicast Address
Mapping".

16 bit mapping is explained, but there not a word about 64 bit
mapping! Should there be some text from some IEEE standard, written in
*IETF* style (I've sometimes difficulties parsing the IEEE style of
protocol text :-)

_______________________________________________
6lowpan mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/6lowpan

---

From: gabriel montenegro <[email-masked]>
Date: Thu, 15 Mar 2007 10:21:23 -0700 (PDT)

Re: mcast, we don't specify 64-bit mcast cuz we only use 16-bit for that. This is one of the reasons we need to support both

simultaneously, so 16-bit mcast or bcast addresses can be used regardless of what your unicast addresses use (16 or 64-bit).
Having one way of doing things (i.e., mapping mcast addresses to L2 addresses) is better than having two, as per an often
repeated IETF principle. The current choice favors less bits on the air, rather than more fine-grained mapping.