Subject: Re: [6lowpan] Looking for feedback on HC1g - stateless header compression for routable prefix

From: gabriel montenegro <[email-masked]>
Date: Mon, 16 Jul 2007 20:00:36 -0700 (PDT)

We actually discussed this a while back with Erik Nordmark in some detail. The issue is that an IPv6 link
can have several prefixes, and they are not guaranteed to be advertised in any particular order by the router
or routers on that link. So one could not use a bit pattern easily to refer to:

    * "the" global prefix (cuz there may be more than one)
    * "the first global prefix" (cuz node A's first might be node B's second)

At the end we did not see a clear and easy way of doing so, so we limited the header compression scheme
to only the link-local addresses (cuz the "prefix" in that case in unequivocally known). It also did not seem 
like overall, complicating the basic scheme with additional header compression for global prefixes was
very meaningful as most traffic would probably be link-local anyways. 

In case it is not clear, an assumption above (as in all the format document) was that we wanted to have
support for IPv6, not for some watered-down or somewhat tweaked (even if only slightly) version of IPv6.
It was also pretty clear that without this we wouldn't have been able to have a working group.

That was several years ago, so our assumptions may need to change, and it would be good to hear 

that based on folks' experience, of course.

-gabriel

----- Original Message ----
From: David Culler <[email-masked]>
To: [email-masked]
Sent: Monday, July 16, 2007 4:38:26 PM
Subject: [6lowpan] Looking for feedback on HC1g - stateless header compression for routable prefix

Folks,
  We'd like to draw your attention to I-D  

    http://www.ietf.org/internet-drafts/draft-hui-6lowpan-hc1g-00.txt 

that was posted two weeks ago.  It generalizes HC1 to provide the same level of header compression for a PAN-wide global prefix.  HC1 only compresses addresses that use the link local prefix.  A global prefix is always used in communication with endpoints external to the PAN.  It may be used as well within the PAN.  In the context of mesh-under, HC1g applies to originator / final.  

Thanks,

     David Culler and Jonathan Hui

_______________________________________________
6lowpan mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/6lowpan

_______________________________________________
6lowpan mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/6lowpan

---

From: Jonathan Hui <[email-masked]>
Date: Mon, 16 Jul 2007 20:55:25 -0700

>     * "the first global prefix" (cuz node A's first might be node B's 

Yes, the global compressible prefix must be clearly identified if nodes 
are assigned more than one prefix. Our thoughts are that this can be 
done using either stateless autoconfiguration mechanisms (i.e. IPv6 ND), 
by extending RAs and using a reserved bit to indicate its compressible 
status; through stateful autoconfiguration (i.e. DHCPv6) through IA 
Address options; or through some yet-to-be-defined 6LoWPAN configuration 
protocol. If there is a configuration error and more than one global 
prefix is marked as compressible, then the node must not compress the 
prefix. This is not stated in the current draft and probably should be.

> to only the link-local addresses (cuz the "prefix" in that case in 
> unequivocally known). It also did not seem

Link-local communication covers an important subset of applications. But 
we do see benefits in allowing nodes to communicate directly with other 
IP devices outside the LoWPAN network. By utilizing IP end-to-end, 
LoWPAN nodes can readily communicate with any other non-LoWPAN node, and 
it can do so without a stateful translation gateway in between.

> It was also pretty clear that without this we wouldn't have been able to 

We completely agree that we would like to support full IPv6. LOWPAN_HC1g 
supports just that, allowing nodes to communicate with any arbitrary prefix.

--
Jonathan Hui
[email-masked]

---

From: "David Culler" <[email-masked]>
Date: Mon, 16 Jul 2007 23:30:02 -0700

Gabriel,
  Thanks for weighing in.  To expand a little on Jonathan's comments...  The
potential to have multiple global ipv6 would not seem to suggest that NONE
of them should be compressible.  hc1g allows ONE of them to be, but doesn't
prevent the use of the others.  Doesn't it seem a shame to lose the
advantages of 6LoWPAN just because you assign IPv6 addresses to the nodes in
addition to the default link local address.  The philosophy of 6LoWPAN seems
to be to provide a way to improve the common case while still supporting the
general case correctly.  We cannot compress all the UDP ports, just a
selected region.  I think that you would agree that two of the most
important reasons for putting IPV6 on the 802.15.4 network in the first
place is the ability to name a node with a globally meaningful IP address
and the ability to route packets to and from nodes on the 802.15.4 network.
HC1g preserves the the HC1 compression in these two cases.