Subject: [6lowpan] Questions about RFC 4944

From: Guido Moritz <[email-masked]>
Date: Thu, 29 Jan 2009 15:41:27 +0100

Hello,

I just finished going through RFC4944 and I have three questions left, I
cannot understand. Maybe you can help me with that and provide me with
a better understanding.

1. Section 8
The type field is 8 bit. Why is it so big?
The length field is units of 8: I understand it as multiples of 8-bit.
Why means value 1 16-bit and value 2 64-bit addresses? It should be
8-bit and 16-bit with the values 1 and 1?!

2. Section 9
What is the reason, that mulitcast address mapping only has to be
supported in mesh-enabled networks? What is the concept behind that.

Thank you for your answers.

Kind Regards

Guido Moritz

-------------------------
Dipl. Ing. Guido Moritz
Universitaet Rostock, Fakultaet f. Informatik und Elektrotechnik
Institut f. Angewandte Mikroelektronik und Datentechnik
University of Rostock, Department of CS and EE
Institute of Applied Microelectronics and Computer Engineering
Richard-Wagner Str. 31, 18119 Rostock-Warnemuende
Phone:  +49 (0)381 498 - 7269
http://www.imd.uni-rostock.de
http://www.aal-rostock.de

_______________________________________________
6lowpan mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/6lowpan

---

From: "Julien Abeille (jabeille)" <[email-masked]>
Date: Thu, 29 Jan 2009 15:57:51 +0100

Hi Guido,

Type and length fields in section 8 are defined in Neighbor Discovery. The amount of ND options may not be that huge even in future extensions, but compressing thiese fields is not in the charter for now.

The length is in units of 8 bytes. For example, over Ethernet, length would be 1 (type+length+6bytes Ethernet address->8bytes)
With a 16-bit address, you will need 4 bytes (type + length + 2 bytes address), plus 4 bytes of padding to reach a multiple of 8, hence total is 8, length field is 1
With a 64-bit address, you will need 10 bytes (type + length + 8 bytes address), plus 6 bytes of padding, total is 16, length field is 2.

Best,
Julien

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Guido Moritz
Sent: jeudi 29 janvier 2009 15:41
To: [email-masked]
Subject: [6lowpan] Questions about RFC 4944

Hello,

I just finished going through RFC4944 and I have three questions left, I cannot understand. Maybe you can help me with that and provide me with a better understanding.

1. Section 8
The type field is 8 bit. Why is it so big?
The length field is units of 8: I understand it as multiples of 8-bit.
Why means value 1 16-bit and value 2 64-bit addresses? It should be 8-bit and 16-bit with the values 1 and 1?!

2. Section 9
What is the reason, that mulitcast address mapping only has to be supported in mesh-enabled networks? What is the concept behind that.

Kind Regards

Guido Moritz

Universitaet Rostock, Fakultaet f. Informatik und Elektrotechnik Institut f. Angewandte Mikroelektronik und Datentechnik University of Rostock, Department of CS and EE Institute of Applied Microelectronics and Computer Engineering Richard-Wagner Str. 31, 18119 Rostock-Warnemuende