Subject: [6lowpan] Fwd: New Version Notification for draft-ietf-6lowpan-hc-06

From: Jonathan Hui <[email-masked]>
Date: Mon, 5 Oct 2009 08:02:22 -0700

Hi everyone,

Below is a summary of changes in this draft.  Please send comments.   
Thanks.

- Fixed typo in description of number of bits used for IPHC encoding.  
(addresses ticket #45)
- Specify M=0 only for non-multicast addresses and M=1 only for  
multicast addresses.
- Move 128-bit multicast encoding to DAC=0 (stateless mode).
- Reserve ESC dispatch value of 01 000000. (addresses ticket #31)
- Text to discuss relationship to RFC 4944 (addresses ticket #55)
- Many minor editorial changes.

--
Jonathan Hui

Begin forwarded message:

> From: IETF I-D Submission Tool <[email-masked]>
> Date: October 5, 2009 7:56:05 AM PDT
> To: [email-masked]
> Cc: [email-masked]
> Subject: New Version Notification for draft-ietf-6lowpan-hc-06
>
>
> A new version of I-D, draft-ietf-6lowpan-hc-06.txt has been  
> successfuly submitted by Jonathan Hui and posted to the IETF  
> repository.
>
> Filename:	 draft-ietf-6lowpan-hc
> Revision:	 06
> Title:		 Compression Format for IPv6 Datagrams in 6LoWPAN Networks
> Creation_date:	 2009-10-05
> WG ID:		 6lowpan
> Number_of_pages: 20
>
> Abstract:
> This document specifies an IPv6 header compression format for IPv6
> packet delivery in 6LoWPAN networks.  The compression format relies
> on shared context to allow compression of arbitrary prefixes.  How
> the information is maintained in that shared context is out of scope.
> This document specifies compression of multicast addresses and a
> framework for compressing next headers.  This framework specifies UDP
> compression.
>
>
>
> The IETF Secretariat.
>
>

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 5 Oct 2009 17:15:25 +0200

On Oct 5, 2009, at 17:02, Jonathan Hui wrote:

> Please send comments.

Let me expand that:

I haven't done a detailed review, but from the first look it appears  
to me this might now be ready for working-group last call.
Those of you reviewing this -- if you find any show-stoppers or don't  
agree this is ready for WGLC, please tell the list until Friday, which  
might be a good day to issue the WGLC otherwise*).

Gruesse, Carsten

*) (Of course, if you find show-stoppers afterwards, or have any other  
comments, they would go into the WGLC comments.)

---

From: JP Vasseur <[email-masked]>
Date: Mon, 5 Oct 2009 18:36:19 +0200

Looks ready to me.

Carsten, could you clarify how you want to handle RFC4944 ? Do you  
want to have this one updating RFC4944 ?

Thanks.

JP.

On Oct 5, 2009, at 5:15 PM, Carsten Bormann wrote:

> Those of you reviewing this -- if you find any show-stoppers or  
> don't agree this is ready for WGLC, please tell the list until  
> Friday, which might be a good day to issue the WGLC otherwise*).
>
> Gruesse, Carsten
>
> *) (Of course, if you find show-stoppers afterwards, or have any  
> other comments, they would go into the WGLC comments.)
>
> _______________________________________________
> 6lowpan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6lowpan

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 5 Oct 2009 18:45:12 +0200

On Oct 5, 2009, at 18:36, JP Vasseur wrote:

> Do you want to have this one updating RFC4944 ?

Indeed, this is what section 2 says, q.v.

(Remember that we have a special WGLC on that specific issue open  
until October 19, 2009, 23:59 UTC, see http://www.ietf.org/mail-archive/web/6lowpan/current/msg01967.html 
  for details.  So far, nobody has objected.)

Gruesse, Carsten