Subject: [6lowpan] An idea about reducing communciation within and out of PAN network

From: Anni Wei <[email-masked]>
Date: Thu, 05 Nov 2009 20:33:47 +0800

Hi,all,

      I just graduated from school months ago and as a new comer of 6lLOWPAN,i learn a lot from the expers in 6LOWPAN.
      Recently,I have an idea about reducing communciation within and out of PAN network.
   A new individual draft is going to be submitted before meeting but missed the deadline to submission.
   I think maybe some suggestion from you about my idea before submitting would be best.
      
      It is a solution about header compression for communication between nodes in and out of 6lowpan .  
   Based on the binding table, the communication between nodes in and out of 6lowpan 
   can totally be converted into communication between 6LoWPAN nodes and the loWPAN edge router.
   At the same time, as 16 bit short addresses can be used, the header can be further compressed.

      This work would be useful in case PAN nodes communicate to outside of PAN in my personal oponion. 
   A slide which explains the basic concept of my idea  was attached and any comments and feedback are appreciated..

With Best Regards 
Anni Wei
   Phone: +86-10-82836297
   Email: [email-masked]

---

From: Jonathan Hui <[email-masked]>
Date: Thu, 5 Nov 2009 11:36:50 -0800

Hi Anni,

The format defined in draft-ietf-6lowpan-hc-06 does support efficient  
compression of arbitrary IPv6 addresses.  Nodes maintain a context  
table.  While the specific contents of the table is not defined in  
this draft, a common use case is to populate it with IPv6 prefixes and  
use IPHC to effectively replace IPv6 prefixes with an index into the  
context table.  The format also allows the IPv6 address bits that are  
carried inline to serve as an additional index.

What particular problem is your proposal trying to address that IPHC  
does not?  I couldn't quite understand from the slides.

--
Jonathan Hui

On Nov 5, 2009, at 4:33 AM, Anni Wei wrote:

> Hi,all,
>
>       I just graduated from school months ago and as a new comer of  
> 6lLOWPAN,i learn a lot from the expers in 6LOWPAN.
>    A slide which explains the basic concept of my idea  was attached  
> and any comments and feedback are appreciated..
>
> With Best Regards
> Anni Wei
>    Phone: +86-10-82836297
> <6lowpan-hcC.ppt>
> _______________________________________________
> 6lowpan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6lowpan