Subject: [6lowpan] DaD in network with multiple LBR

From: "Reddy, Joseph" <[email-masked]>
Date: Tue, 22 Feb 2011 19:50:15 -0600

We have a question on doing DaD when a node is configuring mulitiple global addresses using the same interface identifier. 

In this case, the network has two routers with external network connectivity ( via differnet ISP's, consequently they have differnet prefixes that need to be propagated into the 6lowpan network ). 

A node in the network has configured an address using one of the prefix and succesfully performed DaD. Now, if it wishes to configure another address using the same interface identifier ( which is now known to be unique within the 6lowpan ), does it need to perform the multihop DaD process again ? We think it does not need to, but would like to hear other opinions. 

-Thanks, Joseph

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 23 Feb 2011 16:51:13 +0100

Hi Joseph:

I think there's  a long history before 6LoWPAN existed of not assuming
that DAD for a given address is a guarantee for any address built on
that same IID.

So I'd go for either assume that you do not need to DAD any address
based on your burn-in address (see 6LoWPAN ND 15 section 3.1, second
bullet), or DAD them all, which is the normal behavior in this Internet.

Cheers,

Pascal
http://www.xtranormal.com/watch/7011357/

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Reddy, Joseph
> Sent: Wednesday, February 23, 2011 2:50 AM
> To: [email-masked]
> Subject: [6lowpan] DaD in network with multiple LBR
> 
> 
> 
> 
> We have a question on doing DaD when a node is configuring mulitiple
global
> addresses using the same interface identifier.
> 
> In this case, the network has two routers with external network
connectivity
> ( via differnet ISP's, consequently they have differnet prefixes that
need to
> be propagated into the 6lowpan network ).
> 
> A node in the network has configured an address using one of the
prefix and
> succesfully performed DaD. Now, if it wishes to configure another
address
> using the same interface identifier ( which is now known to be unique
within
> the 6lowpan ), does it need to perform the multihop DaD process again
? We
> think it does not need to, but would like to hear other opinions.
> 
> -Thanks, Joseph
> 
> 
> 
> 
> 
> 
> _______________________________________________
> 6lowpan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6lowpan