Subject: [6lowpan] draft-bormann-6lowpan-roadmap-00

From: Carsten Bormann <[email-masked]>
Date: Mon, 7 Mar 2011 20:29:49 +0100

6LoWPANners,

the 6LoWPAN WG has been chartered to produce an "implementers guide", collecting clarifying information about the standards relevant for this WG.  So far there has been little need for this, as we have put the necessary clarifying information into the specs themselves. However, with these maturing, maybe it is time to start work on the implementers guide.

I have submitted a first version of a document that might be fleshed out over time to become that implementers guide.
I expect this to grow, but probably not to the size of its role model, RFC 4815.

Please find it at:
http://tools.ietf.org/html/draft-bormann-6lowpan-roadmap-00

Enjoy!

Gruesse, Carsten

Begin forwarded message:

> From: IETF I-D Submission Tool <[email-masked]>
> Date: March 7, 2011 20:16:52 +0100
> To: [email-masked]
> Subject: New Version Notification for draft-bormann-6lowpan-roadmap-00 
> 
> 
> A new version of I-D, draft-bormann-6lowpan-roadmap-00.txt has been successfully submitted by Carsten Bormann and posted to the IETF repository.
> 
> Filename:	 draft-bormann-6lowpan-roadmap
> Revision:	 00
> Title:		 6LoWPAN Roadmap and Implementation Guide
> Creation_date:	 2011-03-07
> WG ID:		 Independent Submission
> Number_of_pages: 12
> 
> Abstract:
> 6LoWPAN is defined in RFC 4944 in conjunction with a number of
> specifications that are currently nearing completion.  The entirety
> of these specifications may be hard to understand, pose specific
> implementation problems, or be simply inconsistent.
> 
> The present guide aims to provide a roadmap to these documents as
> well as provide specific advice how to use these specifications in
> combination.  In certain cases, it may provide clarifications or even
> corrections to the specifications referenced.
> 
> This guide is intended as a continued work-in-progress, i.e. a long-
> lived Internet-Draft, to be updated whenever new information becomes
> available and new consensus on how to handle issues is formed.
> Similar to the ROHC implementation guide, RFC 4815, it might be
> published as an RFC at some future time later in the acceptance curve
> of the specifications.
> 
> This document does not describe a new protocol or attempts to set a
> new standard of any kind -- it mostly describes good practice in
> using the existing specifications, but it may also document emerging
> consensus where a correction needs to be made.
> 
> The current version -00 of this document is just an initial draft
> that is intended to spark the collection of relevant information.

---

From: Geoff Mulligan <[email-masked]>
Date: Mon, 07 Mar 2011 12:42:34 -0700

Carsten,
  This is great.  Thanks for starting this.  I think this document will
be critical as we move forward.  Do you think we need a section on ND?

I hope the folks from Zigbee, Jennic, Tridium, Atmel and Ember who are
currently building specs and products based on 6lowpan will provide some
of this much needed information.

wow, thanks for starting this!

	geoff

On Mon, 2011-03-07 at 20:29 +0100, Carsten Bormann wrote:
> _______________________________________________
> 6lowpan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6lowpan

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 7 Mar 2011 20:47:32 +0100

> be critical as we move forward.  Do you think we need a section on ND?

Thanks.  I'm pretty sure we will add ND experience at some point, but  
for now I'd rather get nd-15 finished...

> of this much needed information.

Let's try to collect some tidbits in the hallways in Prague so we can  
have a more useful -01 soon.

(If you have something now, I'd be glad to add it before the -0x  
deadline, too.)

Gruesse, Carsten

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 7 Mar 2011 14:46:30 -0800 (PST)

Hi Carsten,
  Now we have LWIP which will on similar issues. In view of that I am not sure 
if this is still needed.

Regards,

Behcet

> 
> 6LoWPANners,
> 
> the 6LoWPAN WG has been chartered to produce an  "implementers guide", 
>collecting clarifying information about the standards  relevant for this WG.  So 
>far there has been little need for this, as we  have put the necessary 
>clarifying information into the specs themselves.  However, with these maturing, 
>maybe it is time to start work on the implementers  guide.
> 
> > A  new version of I-D, draft-bormann-6lowpan-roadmap-00.txt has been 
>successfully  submitted by Carsten Bormann and posted to the IETF repository.
> >

---

From: Z Z <[email-masked]>
Date: Mon, 7 Mar 2011 23:16:03 -0800 (PST)

I think that LWIP will deal with more generic LW IP topics.  I was thinking Mr. Bormann's draft will be much more 6lowpan specific.  I don't think the draft from LWIP will detail 6lowpan ND or 6lowpan LBR specific topics.

--- On Mon, 3/7/11, Behcet Sarikaya <[email-masked]> wrote:

> From: Behcet Sarikaya <[email-masked]>
> Subject: Re: [6lowpan] draft-bormann-6lowpan-roadmap-00
> To: "Carsten Bormann" <[email-masked]>, "6lowpan WG" <[email-masked]>
> Date: Monday, March 7, 2011, 2:46 PM
> Hi Carsten,
> > I have submitted a first version of a document that
> might be  fleshed out over 
> >time to become that implementers guide.
> > I expect this to  grow, but probably not to the
> size of its role model, RFC 
> >4815.
> > 
> > Please  find it  at:
> > > A  new version of I-D,
> draft-bormann-6lowpan-roadmap-00.txt has been 
> > >  Creation_date: 
>    2011-03-07

---

From: Behcet Sarikaya <[email-masked]>
Date: Tue, 8 Mar 2011 08:56:58 -0800 (PST)

Is this Robert?

> 
> I think that LWIP will deal with more generic LW IP topics.  I was thinking  
>Mr. Bormann's draft will be much more 6lowpan specific.  I don't think the  
>draft from LWIP will detail 6lowpan ND or 6lowpan LBR specific  topics.
> 

I think we need to assess the usefulness of such a draft on top of the lwip 
work. That was my comment.

Otherwise I am OK.

Regards,

Behcet

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 8 Mar 2011 20:02:14 +0100

Citing from a random draft LWIG charter (datatracker doesn't seem to have a final one yet):

> The purpose of the LWIG working group is to collect experiences from
> existing small IP stacks with regards to protocol implementation
> techniques and other details that have been useful in deployments. The
> group shall focus only on techniques that have been used in actual
> implementations and do not impact interoperability with other devices.
> The techniques shall also not affect conformance to the relevant
> specifications. The output of this work is a document that describes
> implementation techniques for reducing complexity, memory footprint, or
> power usage. The main focus is in the IPv4, IPv6, UDP, TCP, ICMPv4/v6,
> MLD/IGMP, ND, DHCPv4/v6, IPsec, 6LOWPAN, and RPL protocols.

So the LWIG output is intended to be descriptive, about implementation techniques, not affecting interoperability.

The 6LoWPAN implementers guide I started to write explains how to properly use the 6LoWPAN protocols, in a way that is intended to be more prescriptive than descriptive, very much impacting (i.e., improving) interoperability, and potentially ultimately leading to revised versions of the specifications.  Again, cf. RFC 4815 for an example for where this can lead.

While it is possible there will be some overlap in the fringe areas between the two, with a little bit of forethought that can be controlled.
And, yes, I'd expect LWIG to be a working group that we want to closely collaborate with, both with respect to this guide and with respect to the other 6LoWPAN documents.

Gruesse, Carsten

---

From: Zhen Cao <[email-masked]>
Date: Wed, 9 Mar 2011 22:06:39 +0800

On Wed, Mar 9, 2011 at 3:02 AM, Carsten Bormann <[email-masked]> wrote:
> The 6LoWPAN implementers guide I started to write explains how to properly use the 6LoWPAN protocols, in a way that is intended > to be more prescriptive than descriptive, very much impacting (i.e., improving) interoperability, and potentially ultimately leading to >revised versions of the specifications.  Again, cf. RFC 4815 for an example for where this can lead.

The descriptive part of this document would be covered by/merged to
the output of the LWIG.  And the roadmap document, if exactly as
implied by the name, is okay for 6lowpan.  But I do expect you can
output the guideline part (e.g., MTU section) to the LWIG document,
and we surely will collaborate with each other on the topic.

-- 
Best regards,
Zhen

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 9 Mar 2011 16:49:24 +0100

On Mar 9, 2011, at 15:06, Zhen Cao wrote:

> But I do expect you can

Well, that (if we decide to do it the way I wrote in the draft) actually is not just guidance, but a change to RFC 4944, which is why this isn't just a local implementation issue.

> and we surely will collaborate with each other on the topic.

Certainly!

Gruesse, Carsten