Subject: [6lowpan] IPv6 over DECT Ultra Low Energy

From: Peter Mariager <[email-masked]>
Date: Wed, 27 Apr 2011 01:14:35 -0700

Gentlemen,

I am very pleased to see 6LoWPAN being considered and developed for other wireless standards.

I would like to propose the development of a 6LoWPAN adaptation layer for DECT Ultra Low Energy (ULE), as DECT can also be a very strong platform for the "internet of things" due to the number of networks being deployed annually.

DECT ULE is in many ways similar to BTLE (short packet size, network topology etc), but also has some unique properties compared to other wireless short-range standards which I believe makes it worthwhile to develop a 6LoWPAN adaptation layer.

DECT ULE MAC/PHY is currently being specified by ETSI so there will shortly be an interoperable radio interface.

Yesterday, I submitted an I-D version 0 for IPv6 transmission over DECT ULE.
This is still very much work in progress but I would like to have a frame for the specification work or at least make sure it is aligned with any initiatives to make a common 6LoWPAN adaptation layer (as discussed in this WG).

Comments are much appreciated.
Best Regards,
Peter Mariager

---

From: Alexandru Petrescu <[email-masked]>
Date: Wed, 27 Apr 2011 18:10:29 +0200

Do we have an idea whether IP (not IPv6, just IP) already works somehow
over DECT?

For example, ss there a product DECT telephone using TCP/IP, and display
some data on LCD?

Alex

Le 27/04/2011 10:14, Peter Mariager a écrit :
> I would like to propose the development of a 6LoWPAN adaptation layer
>  for DECT Ultra Low Energy (ULE), as DECT can also be a very strong
> platform for the “internet of things” due to the number of networks
> being deployed annually.
>
> DECT ULE is in many ways similar to BTLE (short packet size, network
>  topology etc), but also has some unique properties compared to other
>  wireless short-range standards which I believe makes it worthwhile
> to develop a 6LoWPAN adaptation layer.
>
> DECT ULE MAC/PHY is currently being specified by ETSI so there will
> shortly be an interoperable radio interface.
>
> This is still very much work in progress but I would like to have a
> frame for the specification work or at least make sure it is aligned
>  with any initiatives to make a common 6LoWPAN adaptation layer (as
> discussed in this WG).
>
> Best Regards, Peter Mariager
>
>
>
> _______________________________________________ 6lowpan mailing list
> [email-masked] https://www.ietf.org/mailman/listinfo/6lowpan

---

From: Peter Mariager <[email-masked]>
Date: Wed, 27 Apr 2011 23:59:49 -0700

Hi Alex

Let me try to answer...

There is a well defined reliable data transport (DPRS) specification for packet traffic. This could potentially be used to transport e.g. 802.3 or IP frames to a "Portable Part" (PP - the "handset" / end node in DECT terms).

Besides, in the newest DECT CAT-iq specification v3.0 (TS 102 527-4) it has also been specified how to terminate the full TCP/IP stack in the gateway (DECT Fixed Part - the base station) and relay a subset of HTTP over to the portable part (intended for e.g. software upgrade over the air).
The problem here is that the DECT base station then has to be (mildly) application aware.

The above mechanism are also only defined for "classic" DECT and without any power limitations in mind.

I would like to enable true IP stack termination in the Portable Part and specifically tailored to fit the low resource channel of DECT ULE.

When such an adaptation layer has been defined it could easily be applied to "classic" DECT / CAT-iq as well.

Best Regards, 
Peter Mariager

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Alexandru Petrescu
Sent: 27. april 2011 18:10
To: [email-masked]
Subject: Re: [6lowpan] IPv6 over DECT Ultra Low Energy

Alex

Le 27/04/2011 10:14, Peter Mariager a écrit :
> platform for the "internet of things" due to the number of networks
> being deployed annually.
>

_______________________________________________
6lowpan mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/6lowpan

---

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 28 Apr 2011 09:00:21 -0700 (PDT)

Hi all,
  6lowpan on links other than IEEE 802.15.4 is different and can not be 
considered as left-over work in 6lowpan WG, IMHO. 

  As such, it would probably be better to look for other ways such as a BoF. 
6lowpan over Bluetooth seems to fall into this category as well :-).

My 2 cents.

Behcet

> Hi Alex
> 
> Let me try to answer...
> 
> There is a well defined reliable  data transport (DPRS) specification for 
>packet traffic. This could potentially  be used to transport e.g. 802.3 or IP 
>frames to a "Portable Part" (PP - the  "handset" / end node in DECT terms).
> 
> Besides, in the newest DECT CAT-iq  specification v3.0 (TS 102 527-4) it has 
>also been specified how to terminate  the full TCP/IP stack in the gateway (DECT 
>Fixed Part - the base station) and  relay a subset of HTTP over to the portable 
>part (intended for e.g. software  upgrade over the air).
> I  would like to enable true IP stack termination in the Portable Part and  
>specifically tailored to fit the low resource channel of DECT ULE.
>

---

From: <[email-masked]>
Date: Thu, 28 Apr 2011 16:16:43 +0000

Behcet,

>considered as left-over work in 6lowpan WG, IMHO.

Why? Do you have good reasoning why BT-LE for example should not be work
undertaken by the 6lowpan WG?
6lowpan is not air-interface specific,.
Your comments are anyway redundant since the WG decided at IETF80 to take
on the work of specifying IPv6 over BT-LE.

-Raj

>> The above mechanism are also only  defined for "classic" DECT and
>>without any 
>>power limitations in mind.
>> 
>> When  such an adaptation layer has been defined it could easily be
>>applied to  
>>"classic" DECT / CAT-iq as well.
>> 
>> Best Regards, 
>> Peter  Mariager
>> 
>> 
>> From: [email-masked] [mailto:[email-masked]] On
>>Behalf  Of 
>>Alexandru Petrescu