Subject: Re: [6lowpan] WG adoption of Transmission of IPv6 Packets over Bluetooth Low Energy

From: Samita Chakrabarti <[email-masked]>
Date: Fri, 1 Apr 2011 05:10:10 -0400

+1.

-Samita

On Mar 31, 2011, at 19:47, Carsten Bormann wrote:

> It appears I was a bit quick dismissing BT-LE as a working group item during Tuesday's 6LoWPAN meeting.  The WG is alive and well, so we can very well request the addition of milestones.  As the support in the room for working on the adaptation of 6LoWPAN for BT-LE was quite good, I'm now issuing a call for WG adoption.
> 
> This is a call for working group adoption of 
> draft-patil-6lowpan-v6over-btle-01.txt
> 
> Working group adoption does not mean we agree with every detail of the 
> draft, but that we want to use it as the basis of further working 
> group work.
> 
> Please reply to the list until
> 
>       Friday, April 8, 23:59 UTC
> 
> with your position whether this document should be adopted or not.
> 
> Gruesse, Carsten

_______________________________________________
6lowpan mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/6lowpan

---

From: Yoshihiro Ohba <[email-masked]>
Date: Fri, 01 Apr 2011 18:20:07 +0900

I support the BT-LE work.

Yoshihiro Ohba

(2011/04/01 2:53), Carsten Bormann wrote:
>> Re: [6lowpan] WG adoption of 6lowpan Implementers guide
> 
> That's what you get when you edit one message out of another.
> It's been a long week...
> Of course, this is about the BT-LE draft, not about the implementers guide.
> Please make sure you reply with the subject of this message, in particular if it is just a "+1"...
> 
> Sorry for the confusion,
> Carsten
> 
>> draft, but that we want to use it as the basis of further working group
>> work.
>>

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 01 Apr 2011 12:03:16 +0200

http://www.ietf.org/id/draft-patil-6lowpan-v6over-btle-01.txt

I think there is not much to be specified here.

IPv6 runs ok over bluetooth interface, rfcs.

It seems to me IMHO bt-le is just a new phy, but same mac, hence ip
would not be affected.

But of course, a document stating we do things over bt-le as usually as
over bt, would not hurt.

Is the WG re-opened?

Alex

Le 31/03/2011 19:47, Carsten Bormann a écrit :
> It appears I was a bit quick dismissing BT-LE as a working group item
> during Tuesday's 6LoWPAN meeting.  The WG is alive and well, so we
> can very well request the addition of milestones.  As the support in
> the room for working on the adaptation of 6LoWPAN for BT-LE was quite
> good, I'm now issuing a call for WG adoption.
>
> Working group adoption does not mean we agree with every detail of
> the draft, but that we want to use it as the basis of further working
> group work.
>
> _______________________________________________ 6lowpan mailing list
> [email-masked] https://www.ietf.org/mailman/listinfo/6lowpan

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 1 Apr 2011 12:12:50 +0200

> It seems to me IMHO bt-le is just a new phy, but same mac, hence ip

From the presentation, I had a different impression.

> But of course, a document stating we do things over bt-le as usually as

Actually, it is required, as RFC4944 and its updates only define 6LoWPAN for IEEE 802.15.4.
If two people took these documents and tried to apply them to BT-LE, they wouldn't necessarily arrive at interoperable specifications.

> Is the WG re-opened?

No, it is alive and well until such a time when it is actually being closed.
All that was said is that the Prague meeting will be the last physical meeting of the WG.
We want to close our unfinished business, and a number of documents are based on discussions that went on at least since Beijing, so if they fit our charter and we have energy to work on them, there is no problem doing that.

Gruesse, Carsten

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 01 Apr 2011 12:33:19 +0200

Le 01/04/2011 12:12, Carsten Bormann a écrit :
>> But of course, a document stating we do things over bt-le as
>> usually as over bt, would not hurt.
>
> Actually, it is required, as RFC4944 and its updates only define
> 6LoWPAN for IEEE 802.15.4. If two people took these documents and
> tried to apply them to BT-LE, they wouldn't necessarily arrive at
> interoperable specifications.

To me IMHO bluetooth is to 802.15.4 what wifi is to 802.11 - a marketing
name.  It seems sufficient to specify ipv6 over 802.15.4  and that would
cover all variants of bluetooth.  There is no ipv6-over-802.11n, nor
ipv6-over-wifilowpower, for example.

I may be wrong though about bluetooth being mostly 802.15.4 rfc4944 and
rfc2460.

>> Is the WG re-opened?
>
> No, it is alive and well until such a time when it is actually being
> closed. All that was said is that the Prague meeting will be the last
> physical meeting of the WG. We want to close our unfinished business,
> and a number of documents are based on discussions that went on at
> least since Beijing, so if they fit our charter and we have energy to
> work on them, there is no problem doing that.

sounds like doing new work without physical meetings... ok...

Alex

---

From: "Carles Gomez Montenegro" <[email-masked]>
Date: Fri, 1 Apr 2011 11:44:42 +0200 (CEST)

Hi Alex,

> I may be wrong though about bluetooth being mostly 802.15.4 rfc4944 and

Are you maybe referring to 802.15.1 instead of 802.15.4? (Btw, only some
of the first Bluetooth versions were ratified as parts of 802.15.1)

All the best,

Carles

---

From: <[email-masked]>
Date: Fri, 1 Apr 2011 10:48:38 +0000

Hi,
There are major differences between 802.15.4 and bt-le in the link and phy layers, topology etc. In fact, there are major differences between Bt and Bt-le as well. 802.15.4 can not be considered as a generalization of  Bluetooth modifications.
Johanna
--- alkuperäinen viesti ---
Lähettäjä: "ext Alexandru Petrescu" <[email-masked]>
Aihe: Re: [6lowpan] WG adoption of draft-patil-6lowpan-v6over-btle-01.txt
Päivämäärä: 1. huhtikuuta 2011
Aika: 12:33:43

Alex

---

From: <[email-masked]>
Date: Fri, 1 Apr 2011 11:16:31 +0000

Inline:

>I think there is not much to be specified here.

Disagree.

>IPv6 runs ok over bluetooth interface, rfcs.

BT-LE is != Classic BT
This is what was clearly stated and explained in the presentation.

>It seems to me IMHO bt-le is just a new phy, but same mac, hence ip

Not true again. When you go into the details of the Phy/Mac for BT-LE you
will see that it is a completely new air interface. The use cases for
BT-LE are completely different from classic BT.
Obviously we cannot discuss the Phy/Mac details in-depth at an IETF
meeting given the 10 mins of time.

And what we are specifying here is how to run IPv6 using 6lowpan
techniques over an air-interface that is low-power.

-Raj

---

From: <[email-masked]>
Date: Fri, 1 Apr 2011 11:16:59 +0000

There is a world of difference between 802.15.4 and BT-LE.

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 01 Apr 2011 13:41:19 +0200

> There is a world of difference between 802.15.4 and BT-LE.

yes, but I mean from the standpoint of IP.

Is the MAC address format different between bt and bt-le? (including
format of multicast addresses)

Is the bt-le mac still doing reassembly (as bt does) thus accept the
same minimal mtu as bt, i.e.1280bytes?

Is bt-le still a multicast-capable link layer, like bt is?

Alex

>
> On 4/1/11 5:33 AM, "ext Alexandru
> Petrescu"<[email-masked]> wrote:
>
>>>> It seems to me IMHO bt-le is just a new phy, but same mac,
>>>> hence ip would not be affected.
>>>
>>> 6LoWPAN for IEEE 802.15.4. If two people took these documents
>>> and tried to apply them to BT-LE, they wouldn't necessarily
>>> arrive at interoperable specifications.
>>
>> To me IMHO bluetooth is to 802.15.4 what wifi is to 802.11 - a
>> marketing name.  It seems sufficient to specify ipv6 over 802.15.4
>> and that would cover all variants of bluetooth.  There is no
>> ipv6-over-802.11n, nor ipv6-over-wifilowpower, for example.
>>
>> I may be wrong though about bluetooth being mostly 802.15.4 rfc4944
>> and rfc2460.
>>
>>>> Is the WG re-opened?
>>>
>>> No, it is alive and well until such a time when it is actually
>>> being closed. All that was said is that the Prague meeting will
>>> be the last physical meeting of the WG. We want to close our
>>> unfinished business, and a number of documents are based on
>>> discussions that went on at least since Beijing, so if they fit
>>> our charter and we have energy to work on them, there is no
>>> problem doing that.
>>
>> _______________________________________________ 6lowpan mailing
>> list [email-masked]

---

From: Robert Cragie <[email-masked]>
Date: Fri, 01 Apr 2011 13:15:37 +0100

Alex,

RFC4944 and 6lowpan-hc form an adaptation layer between IPv6 and, 
currently, 802.15.4. To be clear:

BT BR/EDR is not 802.15.4
BT LE is not 802.15.4
BT BR/EDR is not BT LE (MAC or PHY)

So each MAC/PHY needs its own considerations when it comes to an 
adaptation layer. My feeling is that many concepts could be abstracted 
and maybe written in a common document but ultimately, there will be 
three different adaptation layers.

Also "bluetooth is to 802.15.4 what wifi is to 802.11" - completely 
wrong comparison. Bluetooth has nothing to do with 802.15.4.

Robert

---

From: Zach Shelby <[email-masked]>
Date: Fri, 1 Apr 2011 15:19:11 +0300

+1 (co-author hat off)

This is sufficiently different from 802.15.4 and without specification hard to make interoperable between vendors. Furthermore, I believe having a specification for 6lowpan over (something other than 802.15.4) will be a great thing for the whole community.

Zach 

-- 
Zach Shelby, Chief Nerd, Sensinode Ltd.
http://zachshelby.org  - My blog "On the Internet of Things"
http://6lowpan.net - My book "6LoWPAN: The Wireless Embedded Internet"
Mobile: +358 40 7796297

---

From: <[email-masked]>
Date: Fri, 1 Apr 2011 12:40:01 +0000

+1 (if I-D editor view counts)

On 3/31/11 12:53 PM, "ext Carsten Bormann" <[email-masked]> wrote:

>>during Tuesday's 6LoWPAN meeting.  The WG is alive and well, so we can
>>very well request the addition of milestones.  As the support in the
>>room for working on the adaptation of 6LoWPAN for BT-LE was quite good,
>>I'm now issuing a call for WG adoption.
>>

---

From: Behcet Sarikaya <[email-masked]>
Date: Fri, 1 Apr 2011 07:20:11 -0700 (PDT)

+1

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 1 Apr 2011 16:27:32 +0200

I support this work. Thanks Raj and all : )

Pascal
http://www.xtranormal.com/watch/7011357/

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Carsten Bormann
> Sent: Thursday, March 31, 2011 7:54 PM
> To: 6lowpan WG
> Subject: Re: [6lowpan] WG adoption of Transmission of IPv6 Packets
> overBluetooth Low Energy
> 
> Please make sure you reply with the subject of this message, in
particular if it
> is just a "+1"...
> > It appears I was a bit quick dismissing BT-LE as a working group
item during
> Tuesday's 6LoWPAN meeting.  The WG is alive and well, so we can very
well
> request the addition of milestones.  As the support in the room for
working
> on the adaptation of 6LoWPAN for BT-LE was quite good, I'm now issuing
a
> call for WG adoption.
the

---

From: Oliver Hahm <[email-masked]>
Date: Fri, 01 Apr 2011 19:40:39 +0200

Hi,

> and maybe written in a common document 

in my opinion that's an interesting point. Why not writing a more generic document specifying IPv6 over low-power wireless? This could cover more common considerations about the requirements to the link layer for new 6lowpan implementations.

For instance we've implemented 6lowpan [1] for our micro kernel based operating system which currently supports MSP430 as well as an ARM7. But as our transceiver (TI CC110x) is neither capable of 802.15.4 nor bt-le at the physical layer we cannot be RFC compliant.

Therefore, a more generic specification for IPv6 over low-power wireless foo would be really interesting for us - and probably a lot of other people as CC1020 and CC110x are very popular transceivers for WSN.

Regards
Oleg

[1] For clarification: we have implemented RFC4944, current ND and HC as well as the 802.15.4 frame format based on CSMA for sub-GHz band.

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 01 Apr 2011 23:26:14 +0200

Le 01/04/2011 14:15, Robert Cragie a écrit :
> currently, 802.15.4.

A-ha.

> To be clear:
>
> BT BR/EDR is not 802.15.4, BT LE is not 802.15.4, BT BR/EDR is not BT
> LE (MAC or PHY)

Ok; you may see some technical differences, you may direct me to the
technical differences.

> adaptation layer.

Ok, yes, when it comes to an adaptation layer; the adaptation layer is
called "lowpan" in rfc4944.  Yes, "lowpan" adaptation layer would need
to be well adapted on each different MAC, one being BT-LE.

But I am talking pure IPv6 straight over bluetooth, without "lowpan".
That IPv6 over bluetooth works ok without lowpan, with "bnep".

The meeting presentation slides say "BNEP can be optionally used between
compressed IPv6 and BT-LE L2CAP".

I agree.  Moreover, bnep can also be used ok to run IPv6 over bluetooth
without lowpan, without compressed IPv6.  Is "lowpan" some better than
"bnep"?  Why would one prefer "lowpan" instead of "bnep"?  Thanks for an
indication.

> My feeling is that many concepts could be abstracted and maybe
> written in a common document but ultimately, there will be three
> different adaptation layers.

Ah... more adaptation layers...

> wrong comparison. Bluetooth has nothing to do with 802.15.4.

Yes they do: they're both PAN.

Alex

>> Is the MAC address format different between bt and bt-le?
>> (including format of multicast addresses)
>>
>> Is the bt-le mac still doing reassembly (as bt does) thus accept
>> the same minimal mtu as bt, i.e.1280bytes?
>>
>>>>>> But of course, a document stating we do things over bt-le
>>>>>> as usually as over bt, would not hurt.
>>>>>
>>>>> Actually, it is required, as RFC4944 and its updates only
>>>>> define 6LoWPAN for IEEE 802.15.4. If two people took these
>>>>> documents and tried to apply them to BT-LE, they wouldn't
>>>>> necessarily arrive at interoperable specifications.
>>>>
>>>> marketing name. It seems sufficient to specify ipv6 over
>>>> 802.15.4 and that would cover all variants of bluetooth. There
>>>>  is no ipv6-over-802.11n, nor ipv6-over-wifilowpower, for
>>>> example.
>>>>
>>>> I may be wrong though about bluetooth being mostly 802.15.4
>>>> rfc4944 and rfc2460.
>>>>
>>>>>> Is the WG re-opened?
>>>>>
>>>>> No, it is alive and well until such a time when it is
>>>>> actually being closed. All that was said is that the Prague
>>>>> meeting will be the last physical meeting of the WG. We want
>>>>>  to close our unfinished business, and a number of documents
>>>>>  are based on discussions that went on at least since
>>>>> Beijing, so if they fit our charter and we have energy to
>>>> _______________________________________________ 6lowpan
>>>> mailing list [email-masked]

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 01 Apr 2011 23:31:23 +0200

Le 01/04/2011 11:44, Carles Gomez Montenegro a écrit :
> Are you maybe referring to 802.15.1 instead of 802.15.4? (Btw, only
> some of the first Bluetooth versions were ratified as parts of
> 802.15.1)

Right, it may be so, that I may refer to a 802.15 variant (.1 maybe) as
bluetooth.  Also I meant rfc2464 (IPv6 ethernet) instead of rfc2460 (IPv6).

Alex

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 01 Apr 2011 23:33:59 +0200

Le 01/04/2011 14:19, Zach Shelby a écrit :
> +1 (co-author hat off)
>
> This is sufficiently different from 802.15.4 and without
> specification hard to make interoperable between vendors.
> Furthermore, I believe having a specification for 6lowpan over
> (something other than 802.15.4) will be a great thing for the whole
> community.

Zach, considering that supposedly BT-LE would be backwards compatible
with BT, i.e. bnep would still work - why would one be tempted by lowpan
in first place?

Alex

>>> item during Tuesday's 6LoWPAN meeting.  The WG is alive and
>>> well, so we can very well request the addition of milestones.  As
>>> the support in the room for working on the adaptation of 6LoWPAN
>>> for BT-LE was quite good, I'm now issuing a call for WG
>>> adoption.
>>>
>>> Working group adoption does not mean we agree with every detail
>>> of the draft, but that we want to use it as the basis of further
>>> working group work.
>>>

---

From: "Carles Gomez Montenegro" <[email-masked]>
Date: Sat, 2 Apr 2011 01:56:30 +0200 (CEST)

>>> ipv6-over-802.11n, nor ipv6-over-wifilowpower, for example.
[...]
> bluetooth.

[...]

Well, the point is that, as other folks have already explained:

- Bluetooth and 802.15.4 are *not* variants of the same thing.
- Bluetooth Low Energy and 802.15.4 are *not* variants of the same thing.

The "802.15" prefix in the spec. code (which only applies to some of the
first Bluetooth versions, and e.g. *not* to BLE) may lead you to
confusion. The analogy with 802.11 variants (as in your example) cannot be
done here.

Carles

---

From: Alexandru Petrescu <[email-masked]>
Date: Sat, 02 Apr 2011 12:53:33 +0200

Le 02/04/2011 01:56, Carles Gomez Montenegro a écrit :
>>> Are you maybe referring to 802.15.1 instead of 802.15.4? (Btw,
>>> only some of the first Bluetooth versions were ratified as parts
>>> of 802.15.1)
>>
>> Right, it may be so, that I may refer to a 802.15 variant (.1
>> maybe) as bluetooth.
>
> [...]
>
> - Bluetooth and 802.15.4 are *not* variants of the same thing. -
> Bluetooth Low Energy and 802.15.4 are *not* variants of the same
> thing.
>
> The "802.15" prefix in the spec. code (which only applies to some of
> the first Bluetooth versions, and e.g. *not* to BLE) may lead you to
> confusion.

Yes.  I am personally confused about 802.15 being  or not Bluetooth and,
by extension, BT-LE.

It may be that BT-LE is going to be backwards compatible with Bluetooth,
just speculating.  Otherwise why would they keep the bluetooth name in 
BT-LE.

Alex

> The analogy with 802.11 variants (as in your example) cannot be done
> here.
>
> Carles
>

---

From: "Carles Gomez Montenegro" <[email-masked]>
Date: Sat, 2 Apr 2011 13:22:42 +0200 (CEST)

> just speculating.  Otherwise why would they keep the bluetooth name in

A BT-LE device cannot talk with a non-BT-LE (say "classic" Bluetooth)
device. There are many differences in the protocol stacks, as for example
in the PHY and Link layers.

However, a dual-mode device (i.e. a device that supports both "classic"
Bluetooth and BT-LE) can benefit from the fact that many elements already
present in classic Bluetooth can be reused in a BT-LE implementation.

BT-LE was designed from the basis of "classic" Bluetooth for optimized
operation in control and monitoring applications, which typically involve
devices that exhibit constraints (in energy supply, processing power,
memory, etc.).

For more details about all this, you may refer to the Bluetooth specs.
They are publicly available.

Carles

---

From: Alexandru Petrescu <[email-masked]>
Date: Sat, 02 Apr 2011 14:36:44 +0200

Le 02/04/2011 13:22, Carles Gomez Montenegro a écrit :
>> It may be that BT-LE is going to be backwards compatible with
>> Bluetooth, just speculating.  Otherwise why would they keep the
>> bluetooth name in BT-LE.
>>
>> Alex
>
> A BT-LE device cannot talk with a non-BT-LE (say "classic"
> Bluetooth) device.

Yes, I agree it may be so.  This is one aspect backwards (in)compatibility.

But also, if BT-LE devices will support IPv6 as BT devices do, IPv6
solves the above incompatibility issue.

> There are many differences in the protocol stacks, as for example in
> the PHY and Link layers.
>
> However, a dual-mode device (i.e. a device that supports both
> "classic" Bluetooth and BT-LE) can benefit from the fact that many
> elements already present in classic Bluetooth can be reused in a
> BT-LE implementation.

Yes, I agree.  And there exist dual mode such devices supporting BT/ANT+
as well.  These dual-mode devices are excellent candidates to be
Routers.

> BT-LE was designed from the basis of "classic" Bluetooth for
> optimized operation in control and monitoring applications, which
> typically involve devices that exhibit constraints (in energy supply,
> processing power, memory, etc.).
>
> For more details about all this, you may refer to the Bluetooth
> specs. They are publicly available.

Yes, it's here:

https://www.bluetooth.org/Technical/Specifications/adopted.htm

I am looking mainly at "Core Version 4.0", Part A, "Logical Link Control
and Adaptation Protocol Specification", L2CAP, as requested by section
4.5 "Basic Rate and Low Energy Combined Core Configuration".

Alex

---

From: "Benjamin A. Rolfe" <[email-masked]>
Date: Sat, 02 Apr 2011 08:05:52 -0700

To further clarify:
802.15.1 is the IEEE standard base standard for Bluetooth.  If you had 
said 802.15.1 is to Bluetooth SIG as 802.11 is to WiFi Alliance you 
would be more correct.

802.15.4 was developed for  very different applications and physical 
environments than Bluetooth.   They are completely different standards. 
802.14.1 and 802.15.4 are significantly different MACs, and 802.15.4 
includes multiple PHY technologies.

The latest revision (802.15.4-2011) includes the 3 PHY amendments 
approved since 2006, bringing the total of distinct PHYs to 6, with 
multiple banding options within some PHY specifications, all under a 
single, common MAC.  There are at least 5 current task groups working on 
or finishing up further amendments. It has become the most popular 
downloaded standard in the 802 family and has been applied to a large 
variety of very different applications.

Of course Bluetooth (802.15.1) has deployed in billions of devices and 
continues to be included in nearly all consumer devices.  It is 
optimized for short physical range, small networks (piconets), low 
energy consumption, and high density of simultaneously operating 
piconets.  Most implementations limit TX power and optimize for a range 
of a couple meters or less.

Hope that clarification helps.

> On 4/1/11 5:33 AM, "ext Alexandru Petrescu"<[email-masked]>
> wrote:
>

---

From: Alexandru Petrescu <[email-masked]>
Date: Sat, 02 Apr 2011 17:40:55 +0200

Thanks for clarification,

Le 02/04/2011 17:05, Benjamin A. Rolfe a écrit :
> To further clarify: 802.15.1 is the IEEE standard base standard for
> Bluetooth. If you had said 802.15.1 is to Bluetooth SIG as 802.11 is
>  to WiFi Alliance you would be more correct.

Ok, 802.15.1 is to Bluetooth SIG as 802.11 is to WiFi Alliance.

> 802.14[5?].1 and 802.15.4 are significantly different MACs, and
> 802.15.4 includes multiple PHY technologies.

Ok.

IMHO BT-LE and 802.15.4 compete in the same application and
physical environment.

>  single, common MAC.

Ok, I wonder what that MAC is.

> There are at least 5 current task groups working on or finishing up
> further amendments. It has become the most popular downloaded
> standard in the 802 family and has been applied to a large variety of
> very different applications.

Aha, 802.15.4-2011 is a popular download; but I cant find, sorry; by
vote count here, it seems BT-LE is popular as well and I _can_ find the
BT-LE specs.

> Of course Bluetooth (802.15.1) has deployed in billions of devices
> and continues to be included in nearly all consumer devices. It is
> piconets. Most implementations limit TX power and optimize for a
> range of a couple meters or less.

Do you mean that BT is more adapted in more constrained
environments than 802.15.4?

For the range in meters, I read at the 6LoWPAN WG meeting slides that
BT-LE does 50-100meter.

Do you know whether 802.15.4-2011 doc refers to the use of the lowpan
adaptation layer (section 5 of rfc4944)?  Or does it simply say IPv6
(like RFC2460 or so)? I can't find the 802.15.4-2011 document.

Thanks,

Alex

>>>>  being closed. All that was said is that the Prague meeting
>>>> will be the last physical meeting of the WG. We want to close
>>>> our unfinished business, and a number of documents are based on
>>>>  discussions that went on at least since Beijing, so if they
>>>> fit our charter and we have energy to work on them, there is no
>>>>  problem doing that.

---

From: "Dijk, Esko" <[email-masked]>
Date: Mon, 4 Apr 2011 18:08:28 +0200

Dear all,

I'm in favor also of adopting this document. More clarification is what I'm looking for ;)

best regards
Esko Dijk

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Geoff Mulligan
Sent: Wednesday 30 March 2011 14:37
To: 6lowpan
Subject: [6lowpan] WG adoption of 6lowpan Implementers guide

As we discussed during yesterday's meeting, 6LoWPAN WG has a
non-milestone charter item for an "implementers guide" as a running
document that captures clarifications and small fixes to our
specifications.

Carsten has submitted an initial proposal for such a document,
draft-bormann-6lowpan-roadmap-00.txt.  This document provides a skeleton
and does not have many clarifications yet, it could serve as a basis for
future work on that implementers guide.

This is a call for working group adoption of
draft-bormann-6lowpan-roadmap-00.txt.

        geoff

The information contained in this message may be confidential and legally protected under applicable law. The message is intended solely for the addressee(s). If you are not the intended recipient, you are hereby notified that any use, forwarding, dissemination, or reproduction of this message is strictly prohibited and may be unlawful. If you are not the intended recipient, please contact the sender by return e-mail and destroy all copies of the original message.

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 4 Apr 2011 20:36:27 +0200

On Apr 2, 2011, at 17:40, Alexandru Petrescu wrote:

> adaptation layer (section 5 of rfc4944)?  

The current version of the standard, IEEE 802.15.4-2006 does not address layer 3 issues.
(Clearly, it couldn't reference RFC 4944, which was published in 2007.)

It's the other way around: RFC 4944 references IEEE 802.15.4, and one corrigenda that has been proposed is for 4944 to reference IEEE 802.15.4-2006 and not IEEE 802.15.4-2003.

> I can't find the 802.15.4-2011 document.

That isn't cooked yet.

To get the current versions of the standard:

http://standards.ieee.org/about/get/802/802.15.html

This page also has a link titled: "IEEE Shop: Buy 802 Draft Standards"

There you can buy a copy of the draft a revision of which might become 802.15.4-2011 later.
(Search for 802.15.4; the shop does not make good use of Web links.)
One year later, this standard will also become available from the above link.

Gruesse, Carsten

---

From: "Benjamin A. Rolfe" <[email-masked]>
Date: Mon, 04 Apr 2011 12:40:19 -0700

Some clarification (I hope):
P802.15.4-2006 alone is not the current standard: There are three 
approved amendments and so the current standard is P802.15.4-2006 plus 
the three amendments approved (P802.15.4a-2007, P802.15.4c-2009 and 
P802.15.4d-2009).  You need all 4 documents to know what is in the 
current standard.

The latest revision, which is in the final stages balloting, is a 
"roll-up" that rolls all the approved amendments and the prior revision 
together into one draft.  The standard is re-organized to be easier to 
use and facilitate future revisions more easily (there are 5 TGs working 
on more amendments to 15.4).

The revision is almost "cooked" but as Carsten says not yet served up.  
The latest draft will be recirculated in a few days.  It is expected to 
be forwarded for publication by end of April.

Hope that helps.

-B

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 4 Apr 2011 21:50:52 +0200

On Apr 4, 2011, at 21:40, Benjamin A. Rolfe wrote:

> P802.15.4-2006 alone is not the current standard: There are three approved amendments and so the current standard is P802.15.4-2006 plus the three amendments approved (P802.15.4a-2007, P802.15.4c-2009 and P802.15.4d-2009).  You need all 4 documents to know what is in the current standard.

So one interesting question would be -- does 6LoWPAN (RFC 4944 - HC1/2 + HC + ND) work with all these?

Gruesse, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 4 Apr 2011 22:05:25 +0200

> Therefore, a more generic specification for IPv6 over low-power wireless foo would be really interesting for us - and probably a lot of other people as CC1020 and CC110x are very popular transceive…

I think that is an interesting idea.  How much of such a specification could be generic and how much would need to be specific to each of the radios?  Can you describe the decisions you had to take in applying 6LoWPAN to these radios?

And, even better, can you write a draft?

Gruesse, Carsten

---

From: "Benjamin A. Rolfe" <[email-masked]>
Date: Mon, 04 Apr 2011 13:13:32 -0700

Yes, a very interesting question!
The three approved amendments define new PHY layers. All of the 
currently defined PHYs share a maximum PSDU size of 127.
There are some added MAC features to support new PHY features but the 
basic MAC has not changed.
Perhaps a more specific question is, what features of the PHYs and MAC 
does 6LoWPAN depend on to work?
-B

---

From: <[email-masked]>
Date: Tue, 5 Apr 2011 06:11:28 +0000

Hi,

When thinking about the solution for IPv6 over foo, the following issues are most important:

1. Link layer support for SAR
If SAR functionality is supported in the link layer and maximum MTU is large enough, separate adaptation layer is not needed in 6LoWpan. If SAR is not supported, then 6LoWpan adaptation layer is needed above PHY/Link layers.

2. Topology
Typically mesh or star topology. In a star topology not all 6LoWpan functionalities are required (e.g mesh headers).

3. Memory, power consumption and price
Different sensor technologies may have different optimization criteria. For some technologies e.g. low memory and power consumption as well as price can be a very critical factor. Thus adding new stack to the sensor might be undesirable - or at least low memory and power consumption are considered more important than advanced functionalities.

In principle, we could design a generic solution by classifying low power radios based on the above features. However, we are not aware of new radio technologies that may emerge. Since we don't know their possible limitations in the MAC/PHY layer it would be rather bold to claim that we have a solution for "low power IPv6 over foo". In my opinion it would be best to first pick some other radio that is not based on 802.15.4 (like Bluetooth Low Energy), specify the solution in the WG and if we still agree that requirements can be generalized at least for certain types of radios change the name of the draft or create another draft.

Johanna

>Behalf Of ext Benjamin A. Rolfe
>Sent: 04 April, 2011 23:14
>Cc: [email-masked]
>Subject: Re: [6lowpan] WG adoption of draft-patil-6lowpan-v6over-btle-
>01.txt
>

---

From: "Colin O'Flynn" <[email-masked]>
Date: Tue, 5 Apr 2011 07:46:51 +0200

Hello,

> Perhaps a more specific question is, what features of the PHYs > and MAC 

Basically, zero. RFC4944 + 6lowpan-hc assumes/uses the following:

* You have a 16-bit short address
* You have a 64-bit long address (EUI)
* You have a 16-bit PAN-ID (this isn't used in -hc anymore, but RFC4944
* You have a 127 byte payload
* You have a 'broadcast' mode

It only uses data transmissions: there is no scanning, beaconing, etc etc.
All that 'extra stuff' is left up to another layer if you want to use it.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Benjamin A. Rolfe
Sent: April 4, 2011 10:14 PM
Cc: [email-masked]
Subject: Re: [6lowpan] WG adoption of draft-patil-6lowpan-v6over-btle-01.txt

>> P802.15.4-2006 alone is not the current standard: There are three
approved amendments and so the current standard is P802.15.4-2006 plus the
three amendments approved (P802.15.4a-2007, P802.15.4c-2009 and
P802.15.4d-2009).  You need all 4 documents to know what is in the current
standard.

---

From: "Colin O'Flynn" <[email-masked]>
Date: Tue, 5 Apr 2011 07:48:23 +0200

Appologies - I'm typing on a netbook keyboard and somehow hit the 'send'
shortcut by accident.

The line:

Should read (I wasn't done typing):
* You have a 16-bit PAN-ID (this isn't used in -hc anymore, but RFC4944
still references it in broadcast frames)

Regards,

  -Colin O'Flynn

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Colin O'Flynn
Sent: April 5, 2011 7:47 AM
To: 'Benjamin A. Rolfe'
Cc: [email-masked]
Subject: Re: [6lowpan] WG adoption of draft-patil-6lowpan-v6over-btle-01.txt

Hello,

---

From: Zach Shelby <[email-masked]>
Date: Tue, 5 Apr 2011 10:10:08 +0300

I support accepting the roadmap as our WG implementer's guide document.

Zach

---

From: C Chauvenet <[email-masked]>
Date: Wed, 6 Apr 2011 01:45:02 -0700

Hi All, 

I definitely push the idea of a "generic IPv6 over low power foo" specification (if achievable).
IPv6 may be used over various low power media, and if a generic adaptation layer can be designed, this may avoid to write a specification fo each low power media (exiting and to appear) that use IPv6.
By the way, low power media cannot be restricted to wireless media. We also have to consider wired media (like low power PLC currentlty specified in IEEE P1901.2) as they shared many requirements with well known LoWPAN technologies.

Cédric.

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de Carsten Bormann
Envoyé : lundi 4 avril 2011 22:05
À : Oliver Hahm
Cc : [email-masked]
Objet : Re: [6lowpan] WG adoption of draft-patil-6lowpan-v6over-btle-01.txt

Gruesse, Carsten

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 6 Apr 2011 11:23:16 +0200

Agreed. 

Also, I've seen interest in IPv6 over DECT, with the advantage of an unlicensed band (mostly 1880 - 1900 MHz in Europe) that's dedicated to the technology.

Pascal

> Behalf Of C Chauvenet
> Sent: Wednesday, April 06, 2011 10:45 AM
> To: Carsten Bormann; Oliver Hahm
> Cc: [email-masked]
> IPv6 may be used over various low power media, and if a generic adaptation
> layer can be designed, this may avoid to write a specification fo each low
> power media (exiting and to appear) that use IPv6.
> By the way, low power media cannot be restricted to wireless media. We
> also have to consider wired media (like low power PLC currentlty specified in
> IEEE P1901.2) as they shared many requirements with well known LoWPAN
> technologies.
> 
> Cédric.
> 
> De : [email-masked] [mailto:[email-masked]] De la
> part de Carsten Bormann Envoyé : lundi 4 avril 2011 22:05 À : Oliver Hahm Cc :
> [email-masked] Objet : Re: [6lowpan] WG adoption of draft-patil-6lowpan-
> v6over-btle-01.txt
> 
> > Therefore, a more generic specification for IPv6 over low-power wireless
> foo would be really interesting for us - and probably a lot of other people as
> CC1020 and CC110x are very popular transceivers for WSN.
> 
> I think that is an interesting idea.  How much of such a specification could be
> generic and how much would need to be specific to each of the radios?  Can
> you describe the decisions you had to take in applying 6LoWPAN to these
> radios?
>

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 6 Apr 2011 12:04:33 +0200

> I definitely push the idea of a "generic IPv6 over low power foo" specification (if achievable).

That is my point -- if there is a way to do this in a reusable, mostly generic fashion, this would be great.
I'm assuming there generally always will need to be some shim -- e.g., if the PHY/MAC spec already has a multiplexing point, how to hook into that, and possibly some other radio parameters that need to be set the same on both sides for interoperability.
That's why I was looking for some input from people who have done work on the constrained networks we are talking about.
Please write a (short) draft, or (alternatively) give me a few paragraphs that could for example go into the 6LoWPAN roadmap document until there is critical mass for a separate spec.

Gruesse, Carsten

---

From: Oliver Hahm <[email-masked]>
Date: Wed, 6 Apr 2011 15:20:20 +0200

Hi,

Am Mon, Apr 04, 2011 at 10:05:25PM +0200 schrieb Carsten Bormann:
> > foo would be really interesting for us - and probably a lot of other
> > people as CC1020 and CC110x are very popular transceivers for WSN.
> 
> I think that is an interesting idea.  How much of such a specification could
> be generic and how much would need to be specific to each of the radios?
> Can you describe the decisions you had to take in applying 6LoWPAN to these
> radios?

for our current implementation we tried to change as little as possible in
comparison to RFC 4944.  Therefore, we also adapted the 802.15.4 frame format,
though this was not the optimum choice as we had to deal with a much smaller
packet size. (cc1100 supports natively only 64 byte packets.)

Besides, we have a different addressing scheme at the link layer and have no
PAN ids or anything comparable.

In addition, we could not use 802.15.4 at the physical layer due to hardware
limitations (neither DSSS nor PSSS are supported by the transceiver) and use a
different media access. However, this obviously does not affect 6LoWPAN
itself.
 
> And, even better, can you write a draft?

Okay, I'll try to do this and then we can see how generic such a specification
could be.

Regards
Oleg

---

From: C Chauvenet <[email-masked]>
Date: Wed, 6 Apr 2011 08:34:57 -0700

Hi Carsten, 

Working on Low Power, low data rate PLC, we find that the IEEE 802.15.4 specification targeted the same application and gather the same requirements (Small computation capabilities, Low Power, low data rate etc..).
So we adapted the IEEE 802.15.4 frame format over PLC.
(This is also because a low power and low data rate standard for narrow band PLC such as ongoing specification in P1901.2 don't exist yet at this time)

As a result, It does not hurt the 6loWPAN spec at all, and can be used as is.
Our PHY layer is proprietary (until the standard comes out) but use the 802.15.4 standard frame format.
All layers above are compliant with the classical 802.15.4/6LoWPAN/IPv6 stack.

I would enjoy to hear what other people use, and evaluate the diversity around IPv6 adaptation layers.

Best,
Cédric.

-----Message d'origine-----
De : Carsten Bormann [mailto:[email-masked]] 
Envoyé : mercredi 6 avril 2011 12:05
À : C Chauvenet
Cc : Oliver Hahm; [email-masked]
Objet : Re: [6lowpan] WG adoption of draft-patil-6lowpan-v6over-btle-01.txt

Gruesse, Carsten

---

From: Luis Carlos Maqueda Ara <[email-masked]>
Date: Wed, 6 Apr 2011 20:54:32 +0000

+1

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 11 Apr 2011 22:56:13 +0200

Clearly, we have consensus to adopt this document as a working group document.

Authors:
please resubmit the draft, with no change other than names, titles and dates, as:
draft-ietf-6lowpan-btle-00.txt

From there, this will be developed as a working group document, i.e., we will have some discussion of each (substantive) change we want to make on the mailing list and apply them as we reach (rough) consensus.  (This is best done through tickets, as we have been doing for ND for a while now.)

We also seem to have a lot of interest in creating other "6LoWPAN on X" type documents.
The idea to do much of this in a generic way is interesting, and it wouldn't hurt to have some input on how to do this in the form of individual Internet-Draft submissions.
This doesn't mean there should not be such submissions for specific technologies: If you know what needs to be done for a specific MAC/PHY where 6LoWPAN provides significant added value, please do submit an Internet-Draft.

Gruesse, Carsten

---

From: Peter Mariager <[email-masked]>
Date: Tue, 26 Apr 2011 00:46:12 -0700

Hi Pascal et al.

Yes, this is indeed correct. I have just submitted a draft for IPv6 adaptation layer over DECT Ultra Low Energy.
Comments much appreciated.
Best Regards,
Peter Mariager

From: Pascal Thubert (pthubert) [mailto:[email-masked]]
Sent: 6. april 2011 11:23
To: C Chauvenet; Carsten Bormann; Oliver Hahm
Cc: [email-masked]
Subject: RE: [6lowpan] WG adoption of draft-patil-6lowpan-v6over-btle-01.txt

Agreed.

Pascal