Subject: [6lowpan] which addresses can be registered?

From: Richard Kelsey <[email-masked]>
Date: Thu, 14 Apr 2011 08:34:21 -0400

As far as I can tell from the 6LoWPAN ND draft, the only
addresses that cannot be registered are multicast addresses.
Is this correct?  For example, can a link-local address be
registered?  Can any prefix be used when registering with
any 6LBR?
                                 -Richard Kelsey

---

From: Erik Nordmark <[email-masked]>
Date: Thu, 14 Apr 2011 16:29:40 -0700

> registered?  Can any prefix be used when registering with

The draft doesn't forbid registering a link-local address, but it also 
doesn't require it.

For multicast there is MLD, which is used to tell routers which 
multicast addresses the hosts want to receive. If there are applications 
which use multicast then it would make sense to use MLD.

    Erik