Subject: [6lowpan] Fwd: Re: which addresses can be registered?

From: Erik Nordmark <[email-masked]>
Date: Thu, 14 Apr 2011 16:31:32 -0700

On 4/14/11 5:34 AM, Richard Kelsey wrote:
> As far as I can tell from the 6LoWPAN ND draft, the only
> addresses that cannot be registered are multicast addresses.
> Is this correct?  For example, can a link-local address be
> registered?  Can any prefix be used when registering with
> any 6LBR?

The draft doesn't forbid registering a link-local address, but it also
doesn't require it.

For multicast there is MLD, which is used to tell routers which
multicast addresses the hosts want to receive. If there are applications
which use multicast then it would make sense to use MLD.

    Erik

---

From: Richard Kelsey <[email-masked]>
Date: Thu, 14 Apr 2011 19:56:23 -0400

> Date: Thu, 14 Apr 2011 16:31:32 -0700
> From: Erik Nordmark <[email-masked]>
> 

Thank you.  The question arose with respect to link-local
addresses derived from IEEE 802.15.4 16-bit short addresses,
which require some form of DAD.

Just to be clear, if there are two 6LBRs which advertise
different prefixes and a host configures addresses for
both prefixes, then both addresses need to be registered
with both 6LBRs?
                                  -Richard Kelsey

---

From: Erik Nordmark <[email-masked]>
Date: Thu, 14 Apr 2011 17:05:58 -0700

> which require some form of DAD.

To me it makes sense to register those.
But one could also have link-locals based on EUI-64 and only have the 
globals use the short addresses.
But as I said, the spec provides some flexibility here.

> both prefixes, then both addresses need to be registered

Both addresses need to be registered for sure. IPv6 checks for duplicate 
addresses and not duplicate interface IDs (there was a debate and a 
change/clarification in this area in the early days of IPv6.)

Ideally the 6LBRs are coordinated so that they both advertise both 
prefixes. That seems to be natural if we want one 6LBR to take over 
should the other one fail. But I assume that even if they don't 
advertise the same prefixes, it makes sense to register with both.

    Erik