Subject: [6lowpan] Question about the neighbor discovery

From: Damien Roth <[email-masked]>
Date: Thu, 11 Aug 2011 16:16:05 +0200

Hello,

I'm a 2nd year PhD student and I'm trying to understand how 6LoWPAN works and there is some points I still don't understand.

During the neighbor discovery process, a host sends a Neighbor Solicitation message with an ARO and a Source Link-Layer Address option. Why is the SLLA option mandatory, since the EUI-64 is already contained in the Address Registration option ?

This leads to my second question : in the figure 5 (detailed message address examples), why does the host use its short MAC address in the SLLAO rather than its 64 bits MAC address ?

Regards,

-- 
Damien ROTH - PhD student
Strasbourg University, France

---

From: Erik Nordmark <[email-masked]>
Date: Thu, 11 Aug 2011 09:33:33 -0700

On 8/11/11 7:16 AM, Damien Roth wrote:
> Hello,
>
> I'm a 2nd year PhD student and I'm trying to understand how 6LoWPAN
> works and there is some points I still don't understand.
>
> During the neighbor discovery process, a host sends a Neighbor
> Solicitation message with an ARO and a Source Link-Layer Address
> option. Why is the SLLA option mandatory, since the EUI-64 is already
> contained in the Address Registration option ?

The EUI-64 is an identifier, which uniquely identifies the host whether 
or not the host is using a 64 bit or 16 bit link-layer address.
The SLLA contains the address to which the host wants the router to send 
packets i.e., a locator.

> This leads to my second question : in the figure 5 (detailed message
> address examples), why does the host use its short MAC address in the
> SLLAO rather than its 64 bits MAC address ?

So that the packets the router forward to the host will be delivered 
with the short addresses in the link-layer header.

    Erik