Subject: [6lowpan] How to ask a presentation time slot in coming IETF conf in Taipei?

From: "Chao Zhou (czhou)" <[email-masked]>
Date: Tue, 27 Sep 2011 22:54:27 -0500

Hi, there

We're planning to give a presentation in 6lowpan area in next IETF
conference but couldn't find our schedule or time slot. How to apply for
it? Can anyone give some suggestion?

Thanks.

-Chao

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 28 Sep 2011 13:17:40 +0200

> We’re planning to give a presentation in 6lowpan area in next IETF conference but couldn’t find our schedule or time slot. How to apply for it? Can anyone give some suggestion?

Hi Chao,

the 6LoWPAN WG is not meeting in Taipei.
There also is, in general, no plan to take on new work within this particular WG.

This, of course, does not mean that there won't be additional work in this space — quite to the contrary.  Just not likely in the existing organizational context of this WG.

As you know, the right way to bring an idea to the IETF is to write an Internet-Draft.
(Even if there were a 6LoWPAN slot in Taipei, the chairs would generally require an Internet-Draft for a meeting slot.)  Once we have that, we may be able to find a meeting of a different WG that might provide a way to discuss the work.  Or we might be able to progress it outside of face-to-face meetings, as we are doing with the Bluetooth-Low-Energy (BT-LE) work right now.

So, in any case, my recommendation is to write a draft, and if that creates interest within the purview of the 6LoWPAN WG, we will find a way forward.

Grüße, Carsten

---

From: Robert Moskowitz <[email-masked]>
Date: Wed, 28 Sep 2011 10:30:38 -0400

> As you know, the right way to bring an idea to the IETF is to write an Internet-Draft.

On a related note, a PAR for adding Key Management to 802.15 is 
advancing and we expect its approval at the November 802 meeting (the 
week before IETF).  The work for 15.4 will rely on the Information 
Element and Multipurpose frame of 15.4e.  However, 6lowpan COULD 
allocate a frameID (? or whatever the RFC calls the data header field) 
for KMP and we could have a simple method mirroring the 4e model but for 
6lowpan pre-4e.

I was asked about this in Quebec, and I DO plan on writing an ID for 
this.  I could have a rough cut for November, but it will be tracking 
the 802.15 work (which btw most likely will be 802.15.8 as it will apply 
to 15.6 and 15.7 as well) so it will take a bit to finish.

What value would MAC KMP serve IETF?  Keying for the MAC to secure 
Neighbor discovery.  Security for roll.  Its value for core may be 
minimal:  for core over single hop only or one KMP for all levels (MAC, 
IP, Session (DTLS)).

So this will be available for 6lowpan discussions, but probably you will 
end up waiting until Paris for a full presentation.

Or come to Jacksonville in January to work it out in 802.15!

BTW, I need an editor.  I have an interested, experienced 802.15 editor 
that needs funding.  So either someone to help with the funding of an 
experienced editor or someone to step forward to take on the editing.  I 
do NOT see this (802.15.8) to be a major document.

> _______________________________________________
> 6lowpan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6lowpan
>

-- 
Robert Moskowitz
Senior Technical Advisor
Security & Standards
Verizon Business Systems
C:248-219-2059
F:248-968-2824
E:[email-masked]

There's no limit to what can be accomplished if it doesn't matter who 
gets the credit

---

From: "Chao Zhou (czhou)" <[email-masked]>
Date: Wed, 28 Sep 2011 13:25:20 -0500

Hi Carsten,

Thank you for your info. We do have a draft which is "draft-wang-6lowpan-scheduling-requirements-00". We're hoping to bring interest in this area through the presentation in the coming conference. We're planning to submit the second version soon. In this case, is that possible to make a slot?

Thanks.
-Chao

-----Original Message-----
From: Carsten Bormann [mailto:[email-masked]] 
Sent: Wednesday, September 28, 2011 7:18 PM
To: Chao Zhou (czhou)
Cc: [email-masked]
Subject: Re: [6lowpan] How to ask a presentation time slot in coming IETF conf in Taipei?

> We're planning to give a presentation in 6lowpan area in next IETF conference but couldn't find our schedule or time slot. How to apply for it? Can anyone give some suggestion?

Hi Chao,

This, of course, does not mean that there won't be additional work in this space - quite to the contrary.  Just not likely in the existing organizational context of this WG.

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 28 Sep 2011 21:34:02 +0200

> Thank you for your info. We do have a draft which is "draft-wang-6lowpan-scheduling-requirements-00". We're hoping to bring interest in this area through the presentation in the coming conference.…

Chao,

thanks for the pointer.
Leafing through this draft, I have two questions:

1) What is the ultimate disposition you envision for this document?
What kind of standards activity will be influenced by this set of requirements?
Or, more specifically, what is the IETF activity you envision that would have this document as its requirements set?

2) What would be the objective of a face-to-face discussion at this point?
(We don't schedule meeting slots to present things, but to achieve something.)
Given that I'm not aware of an existing IETF activity where this document would fit, a natural first step would be to first gather interest in setting up a new activity and then start work on the pertinent requirements document.

A random observation about the I-D: 
I'm not sure about the purpose of the references.

Gruesse, Carsten

---

From: "Chao Zhou (czhou)" <[email-masked]>
Date: Wed, 28 Sep 2011 23:06:45 -0500

Hi Carsten,

What we're trying to explore is the deployment possibility of 6lowpan in
industrial control/monitoring environment. There are specific
requirements in the industrial control field, like, determinism,
real-time, reliability, etc. This is the first document we submit and
hope to bring out people's interest and get a general idea of people's
perspective. We're planning to submit more follow-on drafts for some
detailed discussion. Hope this explains.

Thanks.
-Chao

-----Original Message-----
From: Carsten Bormann [mailto:[email-masked]] 
Sent: Thursday, September 29, 2011 3:34 AM
To: Chao Zhou (czhou)
Cc: [email-masked]
Subject: Re: [6lowpan] How to ask a presentation time slot in coming
IETF conf in Taipei?

On Sep 28, 2011, at 20:25, Chao Zhou (czhou) wrote:

> Thank you for your info. We do have a draft which is
"draft-wang-6lowpan-scheduling-requirements-00". We're hoping to bring
interest in this area through the presentation in the coming conference.
We're planning to submit the second version soon. In this case, is that
possible to make a slot?

Chao,

thanks for the pointer.

1) What is the ultimate disposition you envision for this document?
What kind of standards activity will be influenced by this set of
requirements?
Or, more specifically, what is the IETF activity you envision that would
have this document as its requirements set?

2) What would be the objective of a face-to-face discussion at this
point?
(We don't schedule meeting slots to present things, but to achieve
something.)
Given that I'm not aware of an existing IETF activity where this
document would fit, a natural first step would be to first gather
interest in setting up a new activity and then start work on the
pertinent requirements document.

Gruesse, Carsten