Subject: [6lowpan] GHC draft, version -03

From: Carsten Bormann <[email-masked]>
Date: Mon, 3 Oct 2011 23:18:19 +0200

LoWPANners,
ROLLers,

I have updated the 6LoWPAN generic header compression (GHC) draft along what I perceive to be the results of discussions so far:

	http://tools.ietf.org/html/draft-bormann-6lowpan-ghc-03

I have moved nibblecode and context references to an appendix, with the intention of removing them unless we do agree one or both of them should stay in.  I have also moved the extensive examples to an appendix to reduce the bulk of the main body.  Apart from removing nibblecode and context references, I haven't actually changed anything on the wire, so if you have code, that should still be interoperable.

I would love to receive comments in time to allow me an update before the Taipei cutoff (Nov 1), so we can discuss a -04 version there in the hallways (and possibly in or around the ROLL meeting).  Ceterum censeo: please keep the packet dumps (pcaps) coming…

(Please reply to the 6lowpan mailing list only, unless there is a ROLL-specific issue.)

Gruesse, Carsten

---

From: Mukul Goyal <[email-masked]>
Date: Mon, 3 Oct 2011 16:35:34 -0500 (CDT)

Hi Carsten

I think the context reference (for common IPv6 prefix) is very useful and should be a part of the main set of rules. On the other hand, I am not sure how useful the back reference facility is going to be.

Thanks
Mukul

----- Original Message -----
From: "Carsten Bormann" <[email-masked]>
To: "6lowpan" <[email-masked]>
Cc: [email-masked]
Sent: Monday, October 3, 2011 4:18:19 PM
Subject: [Roll] GHC draft, version -03

LoWPANners,
ROLLers,

Gruesse, Carsten

_______________________________________________
Roll mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/roll

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 4 Oct 2011 00:30:11 +0200

> I think the context reference (for common IPv6 prefix) is very useful and should be a part of the main set of rules. On the other hand, I am not sure how useful the back reference facility is going…

Hmm, interesting.  All the examples in the draft (except for the one in figure 6, which does not compress that well) make use of back references.  They are a major contributor to the compression factors achieved.  On the other hand, I have no examples that make use of context references yet, because the pcaps I have lack information about the context in use.  Do you have examples?

Gruesse, Carsten