Subject: [6lowpan] ND-18 Multiple Prefix

From: Tom <[email-masked]>
Date: Fri, 3 Feb 2012 23:02:51 +0530

Hello Everyone,

Kindly clarify does ND-18 support multiple prefix (and multiple
address/node derived from these prefixes).
I raise this doubt because the assumption section,  bullet 4 says -> a
6lowpan is configured with one or more prefixes,
and the final bullet says -> since the 6lowpan shares one single prefix
through out the network.

Further, if 6LBR is advertising multiple prefix and host configures
multiple global addresses based on these prefix how will they be useful.
Will not the 6LR/6LBR reject registration through ARO from different source
address but same EUI-64 (same node auto configuring with different
prefixes).

Regards,
Thomas Chacko

---

From: Erik Nordmark <[email-masked]>
Date: Fri, 03 Feb 2012 09:42:32 -0800

> address/node derived from these prefixes).

Yes it does.

> and the final bullet says -> since the 6lowpan shares one single prefix

That inconsistency was pointed out in the IESG review. The final bullet 
is supposed to point out that the prefix or prefixes are shared across 
all the links in the 6lowpan network.

> multiple global addresses based on these prefix how will they be useful.

They will be useful the same way multiple IPv6 prefixes are useful in 
general. For example, a site could have a ULA prefix plus a global 
prefix. Or a site might have multiple prefixes due to multihoming either 
permanently or while moving from one ISP to another. There are issues 
with multi-prefix multihoming for IPv4 and IPv6, but none of those are 
specific to 6lowpan networks.

> Will not the 6LR/6LBR reject registration through ARO from different
> source address but same EUI-64 (same node auto configuring with
> different prefixes).

Shouldn't be. There is nothing in the document that says that the same 
EUI-64 can't be used to register multiple addresses. I don't know if it 
makes sense to state this explicitly in the document.

Regards,
    Erik

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 3 Feb 2012 18:43:53 +0100

On Feb 3, 2012, at 18:32, Tom wrote:

> Hello Everyone,
> 
> Kindly clarify does ND-18 support multiple prefix (and multiple address/node derived from these prefixes). 
> I raise this doubt because the assumption section,  bullet 4 says -> a 6lowpan is configured with one or more prefixes,
> and the final bullet says -> since the 6lowpan shares one single prefix through out the network.

Yes, this editorial problem was noted by Adrian Farrel in the IESG review as well.

Fix:
s/shares one single prefix/shares its prefix(es)/

(The point of the sentence was that prefixes are lowpan-wide and thus you don't have a separate prefix for each link, not that there is only one prefix.  Bad wording.)

The expectation is that the number of these prefixes is going to be low.
Due to renumbering, we can't really rule out a situation where there is more than one prefix.

> Further, if 6LBR is advertising multiple prefix and host configures multiple global addresses based on these prefix how will they be useful.

Mostly in a renumbering situation, I think.

> Will not the 6LR/6LBR reject registration through ARO from different source address but same EUI-64 (same node auto configuring with different prefixes).

No, it would reject multiple nodes registering the same address, but there is no problem with one node registering multiple addresses.  Beside multiple prefixes, you may want to have one address based on a EUI-64 and another one based on a 16-bit MAC address (see RFC 4944) or you might even want an additional temporary address as a privacy address.  The EUI-64 is there in the ARO so the 6LBR can find out wether multiple nodes are trying to register the same address -- this is most likely to happen for 16-bit-based addresses, of course.

Grüße, Carsten