Subject: [6lowpan] Question about RA packets

From: Damien Roth <[email-masked]>
Date: Fri, 9 Mar 2012 15:51:25 +0100

Hello,

I have a question about the Router Advertisement (RA) packets described in draft-ietf-6lowpan-nd-18.

As I figure out, the RA packets are built like this : 
RA header + SLLAO + ABRO + ( PIO + 6CO ) * number_of_prefixes

With one prefix, the sum of the header / options length is equal to 104 bytes.
Here is the detail :

RA          : 16 bytes
SLLAO	: 16 bytes
ABRO 	: 24 bytes
PIO	        : 32 bytes
6CO 	: 16 bytes
               --------------
                  104 bytes

However, in 802.15.4 the maximum length of the payload is 102 bytes (127 bytes - 25 bytes for the MAC header). Which means that every RA packet have to be fragmented before being sent to the MAC layer.

Is my reasoning correct ?

Regards,

-- 
Damien ROTH - PhD student
Strasbourg University, France

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 9 Mar 2012 16:27:19 +0100

> Is my reasoning correct ?

I didn't check the numbers, but they sound about right.

Can you give me a sample packet (preferably in pcap form)?
I would like to check how much draft-bormann-6lowpan-ghc-03.txt improves the situation.

Grüße, Carsten