Subject: [6lowpan] draft-bormann-ghc

From: Michael Richardson <[email-masked]>
Date: Tue, 12 Jun 2012 15:28:10 -0400

I would like to propose that draft-bormann-6lowpan-ghc-04 be adopted as
a WG item.  I think that 6lowpan should adopt it, but I'm willing to
discuss alternatives.

Some analysis in 2011 showed that even a modest application of GHC
to ROLL RPL control messages resulted in sufficient compression to
make ROLL RPL packets regularly fit into a single 802.15.4 payload.

-- 
Michael Richardson <[email-masked]>, Sandelman Software Works 
speaking for myself

---

From: Zach Shelby <[email-masked]>
Date: Tue, 12 Jun 2012 22:36:33 +0300

+1 - I also would find this useful! And at least as a starting point this is a solid I-D.

On Jun 12, 2012, at 10:28 PM, Michael Richardson wrote:

> _______________________________________________
> 6lowpan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6lowpan

-- 
Zach Shelby, Chief Nerd, Sensinode Ltd.
http://www.sensinode.com
http://zachshelby.org  - My blog "On the Internet of Things"
http://6lowpan.net - My book "6LoWPAN: The Wireless Embedded Internet"
Mobile: +358 40 7796297

---

From: Behcet Sarikaya <[email-masked]>
Date: Tue, 12 Jun 2012 17:05:26 -0500

> +1 - I also would find this useful! And at least as a starting point this is a solid I-D.

I also support this but add that
Secure Neighbor Discovery draft,
http://tools.ietf.org/html/draft-sarikaya-6lowpan-cgand-03 should also
be adopted to complete 6lowpan ND yet to become RFC :-).

Behcet

---

From: Abdussalam Baryun <[email-masked]>
Date: Wed, 13 Jun 2012 13:46:46 +0100

+1

AB

---

From: Daniel Gavelle <[email-masked]>
Date: Wed, 13 Jun 2012 15:17:04 +0200

+1

__________________________________________________

Daniel Gavelle, Software Team Leader
Low Power RF Solutions (formerly Jennic Ltd.)
NXP Semiconductors Furnival Street,
Sheffield,
S1 4QT, UK
Tel: +44 114 281 2655
Fax: +44 114 281 2951
Comp Reg No: 3191371 - Registered In England
http://www.nxp.com http://www.jennic.com
__________________________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf Of Abdussalam Baryun
Sent: 13 June 2012 13:47
To: Michael Richardson
Cc: [email-masked]; [email-masked]
Subject: Re: [Roll] [6lowpan] draft-bormann-ghc

+1

AB
On Tue, Jun 12, 2012 at 8:28 PM, Michael Richardson <[email-masked]<mailto:[email-masked]>> wrote:

--
Michael Richardson <[email-masked]<mailto:[email-masked]>>, Sandelman Software Works
speaking for myself

_______________________________________________
6lowpan mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6lowpan

---

From: M Pouillot <[email-masked]>
Date: Wed, 13 Jun 2012 15:30:33 +0000

+1

De : [email-masked] [mailto:[email-masked]] De la part de Daniel Gavelle
Envoyé : mercredi 13 juin 2012 15:17
À : Michael Richardson
Cc : [email-masked]; [email-masked]
Objet : Re: [6lowpan] [Roll] draft-bormann-ghc

+1

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]<mailto:[mailto:[email-masked]]> On Behalf Of Abdussalam Baryun
Sent: 13 June 2012 13:47
To: Michael Richardson
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Roll] [6lowpan] draft-bormann-ghc

+1

AB

---

From: Pascal Thubert <[email-masked]>
Date: Wed, 13 Jun 2012 16:55:00 -0700

+1

Pascal

Le 12 juin 2012 à 12:28, Michael Richardson <[email-masked]> a écrit :

> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll

---

From: Laurent Toutain <[email-masked]>
Date: Thu, 14 Jun 2012 09:31:03 +0200

+1, but I thought the 6LP working group was closed !

Laurent

-- 
Laurent Toutain
+--- VoIP (recommended) ---+----------- Télécom Bretagne -----------+
| Tel: +33 2 22 06 8156    | Tel: + 33 2 99 12 7026                 | Visit
:
| Fax: +33 2 22 06 8445    | Fax: +33 2 99 12 7030                  |
http://class.touta.in
| [email-masked]         | [email-masked]    |
+--------------------------+----------------------------------------+

---

From: C Chauvenet <[email-masked]>
Date: Thu, 14 Jun 2012 09:54:26 +0000

+1 to adopt this doc as a WG item.
Saving bytes is the key. 
Go for it !

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 14 Jun 2012 12:19:13 +0200

On Jun 14, 2012, at 09:31, Laurent Toutain wrote:

> but I thought the 6LP working group was closed

...>>>>>...
Changing to WG chair mode for a moment:

The 6LoWPAN WG is alive and well and is in the process of closing its remaining two work items (6LoWPAN-ND, 6LoWPAN for BTLE).

However, you are right in that the 6LoWPAN WG no longer takes new work on.
The chairs, with the ADs and the chairs of other WGs, will ensure that interesting work finds an appropriate home.

Indicating whether you are interested in GHC is therefore important input.

Another comment:
Beyond the +1s, it would be useful to know, whether you (I'm addressing the WG here) would be interested in

-- reviewing versions of the draft as they progress
-- implementing the draft and relaying feedback.

...<<<<<...
I'm back to personal contributor mode now.

(Luckily, we won't have this hat-changing going on any more when we find the new home.)

I'm just in the process of receiving some more packet captures.
I would like to take this opportunity to remind people that the more packet captures we have to look at, the better we will be able to optimize this scheme before nailing it down.

A collection of packets I looked at is in

	http://svn.tools.ietf.org/svn/wg/6lowpan/packets

(and, of course, there is the discussion of these in the draft itself).

Grüße, Carsten

---

From: "Dijk, Esko" <[email-masked]>
Date: Thu, 14 Jun 2012 08:40:25 +0000

An official statement of the WG being closed or not would be nice!
In my perception the 6lowpan WG continues, only without any official meetings.

Esko

From: [email-masked] [mailto:[email-masked]] On Behalf Of Laurent Toutain
Sent: Thursday 14 June 2012 9:31
To: Pascal Thubert
Cc: Michael Richardson; [email-masked]; [email-masked]
Subject: Re: [6lowpan] [Roll] draft-bormann-ghc

Laurent
On Thu, Jun 14, 2012 at 1:55 AM, Pascal Thubert <[email-masked]<mailto:[email-masked]>> wrote:
+1

Pascal

Le 12 juin 2012 à 12:28, Michael Richardson <[email-masked]<mailto:[email-masked]>> a écrit :

> [email-masked]<mailto:[email-masked]>
_______________________________________________
Roll mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/roll

--
Laurent Toutain
+--- VoIP (recommended) ---+----------- Télécom Bretagne -----------+
| Tel: +33 2 22 06 8156    | Tel: + 33 2 99 12 7026                 | Visit :
| Fax: +33 2 22 06 8445    | Fax: +33 2 99 12 7030                  |  http://class.touta.in
| [email-masked]         | [email-masked]    |
+--------------------------+----------------------------------------+

________________________________
The information contained in this message may be confidential and legally protected under applicable law. The message is intended solely for the addressee(s). If you are not the intended recipient, you are hereby notified that any use, forwarding, dissemination, or reproduction of this message is strictly prohibited and may be unlawful. If you are not the intended recipient, please contact the sender by return e-mail and destroy all copies of the original message.

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 14 Jun 2012 12:59:55 +0200

> In my perception the 6lowpan WG continues, only without any official meetings.

Hi Esko,

I think our messages just crossed -- see http://www.ietf.org/mail-archive/web/6lowpan/current/msg03544.html

Grüße, Carsten

---

From: Abdussalam Baryun <[email-masked]>
Date: Thu, 14 Jun 2012 12:10:17 +0100

Hi Carsten, and All,

>+1, but I thought the 6LP working group was closed !

were there an announcement for close in the discussion list? I didn't find
it !
were there a good reason for such close? no clue !

>The 6LoWPAN WG is alive and well and is in the process of closing
> its remaining two work items (6LoWPAN-ND, 6LoWPAN for BTLE).
I don't know how the WG will not take new items while it is still working.
The IETF WGs are alive only when they have both input and output. If a WG
only has output then in some day it will be closed, but if a WG has input
without output that means it is not performing well ;)

>The chairs, with the ADs and the chairs of other WGs, will ensure that
interesting work finds an appropriate home.
Yes it is ok to organise where items go, but why blocking items to come in
this WG. I thought it was the decision of the WG to decide if they take in
new items or not, not others. IMHO, the chairs organise/guide the process
and WG makes decisions. Please advise, because I don't understand your
input even after reading the IETF procedures and best practices,

Regards

AB
===========================================

On Thu, Jun 14, 2012 at 11:19 AM, Carsten Bormann <[email-masked]> wrote:

> The 6LoWPAN WG is alive and well and is in the process of closing its
> remaining two work items (6LoWPAN-ND, 6LoWPAN for BTLE).
>
> The chairs, with the ADs and the chairs of other WGs, will ensure that
> interesting work finds an appropriate home.
>
> I would like to take this opportunity to remind people that the more
> packet captures we have to look at, the better we will be able to optimize
> this scheme before nailing it down.
>

---

From: Abdussalam Baryun <[email-masked]>
Date: Thu, 14 Jun 2012 12:16:14 +0100

Hi Dijk,

+1

I also think the memebrs are only authorised to decide if cotinue or not,
if there was no good reason announced ;)

AB

On Thu, Jun 14, 2012 at 9:40 AM, Dijk, Esko <[email-masked]> wrote:

> *From:* [email-masked] [mailto:[email-masked]] *On
> Behalf Of *Laurent Toutain
> *Sent:* Thursday 14 June 2012 9:31
> *To:* Pascal Thubert
> *Cc:* Michael Richardson; [email-masked]; [email-masked]
> *Subject:* Re: [6lowpan] [Roll] draft-bormann-ghc
>
>
>
> ------------------------------
> The information contained in this message may be confidential and legally
> protected under applicable law. The message is intended solely for the
> addressee(s). If you are not the intended recipient, you are hereby
> notified that any use, forwarding, dissemination, or reproduction of this
> message is strictly prohibited and may be unlawful. If you are not the
> intended recipient, please contact the sender by return e-mail and destroy
> all copies of the original message.
>

---

From: Michael Richardson <[email-masked]>
Date: Thu, 14 Jun 2012 09:43:13 -0400

>>>>> "Laurent" == Laurent Toutain <[email-masked]> writes:
    Laurent> +1, but I thought the 6LP working group was closed !

    >> adopted as a WG item.  I think that 6lowpan should adopt it,
    >> but I'm willing to discuss alternatives.

Thus my statement including: "discuss alternatives"
this includes going to 6man or roll or independant submission.

-- 
Michael Richardson <[email-masked]>, Sandelman Software Works 
IETF ROLL WG co-chair.    http://datatracker.ietf.org/wg/roll/charter/

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 14 Jun 2012 17:10:31 +0200

> if there was no good reason announced ;)

Well, that's not how the IETF works.

The IETF sets up WGs to solve specific, well-defined problems.
When that work is done, the WG is closed.
That doesn't mean everything is going away -- often, e.g., the mailing list stays open.

6LoWPAN is close to achieving all the work it was tasked for (actually, looking at http://datatracker.ietf.org/wg/6lowpan/charter/ you can see all our milestones are already marked as done; however, there is some shepherding to be done while the last two documents are on their way to RFC).
So, indeed, it is close to being closed.

By the way, it is the prerogative of the IESG to set up and close down WGs.
WG chairs come into play only to run the WG.
(Of course, when it became clear that it is becoming time to shut down 6LoWPAN, we were asked about our opinion, but it wasn't our decision.)

Yes, it would be nice to know where continuing work on the INT area aspects of constrained node/networks is to be done.  We have a new INT AD that has expressed interest in solving that problem together with the existing responsible AD for 6LoWPAN.  But there is no rush -- 6LoWPAN is around and alive, and the work on the interesting documents can continue on the 6LoWPAN mailing list (with a subscriber count currently north of 700).  I would expect we know the way forward by the end of Vancouver IETF.

So now let's return from the process discussion to the technical work of reviewing the draft, finding things that can be left out from the design to further simplify it, and gaining simulation (from packet captures) and implementation experience.

Grüße, Carsten