Subject: [6lowpan] Does the 6lowpan WG want to close?

From: Ines Robles <[email-masked]>
Date: Sat, 16 Jun 2012 18:28:30 -0300

Hello,

I am just thinking that  a new  Milestone or Goal  would be:   802.15.7
(Li-Fi)  +  6lowPAN.

What do you think about it?

Thanks and Regards,

Ines Robles.

> Hi Carsten,
>
> I agree that it was good to complete the tasks and solve the specific
> issues, and it may be a good reason for close, but I also think the working
> group can decide if they want to bring more tasks in and continue (I don't
> see a role in IETF to MUST close WG if completes the specific problems,
> if I am wrong please refer me to a page reference?), and if they want to
> solve other problems related to the group purpose. I think that the
> community drives works/inputs in IETF WGs.
>
> IMO, the IESG is only to decide to requests of open or close, after they
> get an input with reason. I don't think they are prerogative to decide the
> input and decide the output as well. IMO IESG are prerogative to decide the
> outcome. The inputs are decided by the WG, and the WG may not decide the
> outcome-result of such input. So I think if we want to request for
> continue/close we see the community input for 6Lowpan WG, then if they
> wanted to continue we input to IESG for their approval, if they want to
> close then it will be without an input request.
>
> There is a possibility that I don't know how the IETF works, but I read the
> IETF procedures, and see that there is no good reason for close without the
> WG consensus or input of this issue.
>
> Regards
>
>

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 17 Jun 2012 01:23:51 +0200

On Jun 16, 2012, at 23:28, Ines Robles wrote:

> I am just thinking that  a new  Milestone or Goal  would be:   802.15.7 (Li-Fi)  +  6lowPAN.

I haven't seen any document out of 802.15.7 yet, so I don't know how well the fit would be.
Certainly a technology to watch.

Another PHY/MAC lined up is DECT-ULE.
draft-mariager-6lowpan-v6over-dect-ule-02.txt

Grüße, Carsten

---

From: Ines Robles <[email-masked]>
Date: Sun, 17 Jun 2012 02:06:09 -0300

> Certainly a technology to watch.

Yes, I started recently reading about it, I keep looking how would be the
fit.

Thank you for the draft about, DECT-ULE, I'm going to look into it.

Regards,

Ines Robles.
UTN-FRM
Argentina

---

From: Abdussalam Baryun <[email-masked]>
Date: Mon, 18 Jun 2012 13:42:39 +0200

Hi Ines,

+1

> What do you think about it?

It is an interesting technology, I think an I-D submission for this
and discussions will make things fit. Discussions and submitting new
I-D will continue the active WG :)

AB
==============

---

From: Jens Toftgaard Petersen <[email-masked]>
Date: Mon, 18 Jun 2012 14:03:22 +0000

In the market space of home automation and security we see a lot of interest for our proposed 6LoWPAN over DECT-ULE. In many cases the radio propagation characteristics of DECT-ULE MAC complements the other existing MAC/PHY. 
We have working "6LowPan over DECT-ULE" lab prototypes and public show is expected within a few month. Silicon has been available for a while. ETSI and supporting companies are currently putting a lot of resources in standardizing the lower layers of DECT-ULE. The standard will be public this year. 
We certainly would like to see the DECT-ULE included as part of the 6LoWPAN family and hope that the 6lowpan WG facilitate this. 

Best regards,
  Jens

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Carsten Bormann
Sent: 17. juni 2012 01:24
To: Ines Robles
Cc: 
Subject: Re: [6lowpan] Does the 6lowpan WG want to close?

Grüße, Carsten

_______________________________________________
6lowpan mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/6lowpan

---

From: "Benjamin A. Rolfe" <[email-masked]>
Date: Mon, 18 Jun 2012 11:09:30 -0700

802.15.7 was published in Sept 2011 by IEEE and is now available via the 
"get 802" program
You can get it from "free 802" 
http://standards.ieee.org/about/get/802/802.15.html
There are no ongoing projects to amend 802.15.7 at this time.
-B

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 18 Jun 2012 20:30:54 +0200

> There are no ongoing projects to amend 802.15.7 at this time.

Thanks Ben.

So is there any other activity for getting IP going on top of Li-Fi?

A quick check seems to indicate:
-- as this re-uses 802.15.4's MAC, they'd need something like our dispatch scheme.
-- fragmentation is needed for PHY 1 (PHY frame size limited to 1023 B), not for the higher ones.
-- HC would probably help with the slower PHY 1, not so much with the faster ones.

Which of the PHYs is actually real?

Whether the 6LoWPAN network model (and thus 6LoWPAN-ND) fits is not clear to me -- much of Li-Fi's use will be unidirectional, as a fill-in for some other connectivity, and there will be a lot of star topology usage (see page 6).  Mesh forwarding (route-over/-under) usage appears less obvious to me.

Of course, the most important question is whether there are people interested in doing the work.
If there is energy and a clear objective, we will find a way to make this happen (in whatever WG the IETF chooses to do this).

Grüße, Carsten

---

From: "Benjamin A. Rolfe" <[email-masked]>
Date: Mon, 18 Jun 2012 11:56:30 -0700

I'm not an expert on 802.15.7, although I did read the draft when it was 
balloting.
It doesn't exactly "re-use" the802.15.4 MAC it seems fair to say it 
borrows substantially ;-).  I'm not really sure what might be going on 
outside of 802.15 with respect to higher layer adaptations, 
implementations, conformance procedures, certification, etc.  A quick 
look at
https://mentor.ieee.org/802.15/documents?is_group=0007
will give you some idea who contributed which is often a clue as to who 
cares the most ;-).

There has been quite a lot of activity in 802.15 over the last few 
years, with a lot of it focused on 802.15.4.  There are now 3 published 
amendments which add a variety of new PHYs to choose from, and a lot of 
added MAC capabilities (I would think 802.15.4e-2012 would be of 
interest to many on this group).  While no specification or advice is 
given in the standard regarding IP implementations, knowledge that many 
people are and will be running IP layers on top of 15.4 definitely has 
influenced the work of recent task groups.

I too am interested in how visible light can be used to form mesh 
topologies, but haven't done much more than wonder - can't wait to hear 
more informed opinions!

Hope that helps some.

B

---

From: Abdussalam Baryun <[email-masked]>
Date: Tue, 19 Jun 2012 11:40:53 +0200

+1

AB

On 6/18/12, Jens Toftgaard Petersen <[email-masked]> wrote:
> In the market space of home automation and security we see a lot of interest
> for our proposed 6LoWPAN over DECT-ULE. In many cases the radio propagation
> characteristics of DECT-ULE MAC complements the other existing MAC/PHY.
> We have working "6LowPan over DECT-ULE" lab prototypes and public show is
> expected within a few month. Silicon has been available for a while. ETSI
> and supporting companies are currently putting a lot of resources in
> standardizing the lower layers of DECT-ULE. The standard will be public this
> year.
> We certainly would like to see the DECT-ULE included as part of the 6LoWPAN
> family and hope that the 6lowpan WG facilitate this.
>
> Best regards,
>   Jens
>
>