Subject: [6lowpan] Mesh under routing and Neighbor Discovery

From: Damien Roth <[email-masked]>
Date: Mon, 4 Jun 2012 14:03:19 +0200

Hello,

I continue my investigations the neighbor discovery protocol for 6LoWPAN (draft-ietf-6lowpan-nd-18), and there is one point that remains unclear to me.

With 6LoWPAN, two routing mechanisms can be used : route over and mesh under. Everything is OK with the route over mechanism but I'm locked with mesh-under. In mesh-under routing, there is only two entities, the 6LBR (border router) and the hosts. Multiple hops may be needed to for hosts to reach the 6LBR.

My problem is in multihop configuration : how the multicast Router Solicitation messages, used by the neighbor discovery protocol, can reach the 6LBR ?
Does it depends on the routing protocol used ?

Regards,

-- 
Damien ROTH - PhD student
Strasbourg University, France

---

From: Samita Chakrabarti <[email-masked]>
Date: Mon, 4 Jun 2012 20:10:17 -0400

Hi Damien,

Please find responses in-line.

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Damien Roth
Sent: Monday, June 04, 2012 5:03 AM
To: [email-masked]
Subject: [6lowpan] Mesh under routing and Neighbor Discovery

Hello,

====> In mesh under case, the assumption is that all hosts are directly IP-reachable from 6LBR. How the packets are flown from a host to the 6LBR ( using a L2-mechanism) is out of scope of the document. Currently I don't know of  L2-routing protocols for mesh-under network - however, there might be some proprietary ones.

====>  Please check the section 10 (Examples) to get an understanding how the routers and hosts bootstrap in the multi-hop 6lowpan networks.  Initial multicast RS is sent only to the local subnet  and taken care by the local 6LR router in case of route-over scenario.

-Samita

---

From: Myung Jong Lee <[email-masked]>
Date: Tue, 5 Jun 2012 12:40:57 +0900

Hi Damien and all,

Though I am not an active member for 6lowpan, I just like to note that
there  is a "mesh under" routing standard, IEEE 802.15.5 a recommended
practice, completed in 2009. You may take a look at it. It is built on IEEE
802.15.4b and sitting below IP layer.    I believe it could be one of the
feasible approaches for mesh under technologies. For the details, you may
refer to the standard itself or the paper, " IEEE 802.15.5 WPAN mesh
standard-low rate part: meshing the wireless sensor networks," IEEE JSAC,
Vol 28, No. 7, 2010 .

Thanks,

Myung

On Tue, Jun 5, 2012 at 9:10 AM, Samita Chakrabarti <
[email-masked]> wrote:

> **
>  ------------------------------
> *From:* [email-masked] [mailto:[email-masked]] *On
> Behalf Of *Damien Roth
> *Sent:* Monday, June 04, 2012 5:03 AM
> *To:* [email-masked]
> *Subject:* [6lowpan] Mesh under routing and Neighbor Discovery
>
> Hello,
>
> I continue my investigations the neighbor discovery protocol
> for 6LoWPAN (draft-ietf-6lowpan-nd-18), and there is one point that remains
> unclear to me.
>
> With 6LoWPAN, two routing mechanisms can be used : route over and mesh
> under. Everything is OK with the route over mechanism but I'm locked with
> mesh-under. In mesh-under routing, there is only two entities, the 6LBR
> (border router) and the hosts. Multiple hops may be needed to for hosts to
> reach the 6LBR.
>
> ====> In mesh under case, the assumption is that all hosts are directly
> IP-reachable from 6LBR. How the packets are flown from a host to the 6LBR (
> using a L2-mechanism) is out of scope of the document. Currently I don't
> know of  L2-routing protocols for mesh-under network - however, there might
> be some proprietary ones.
>
> My problem is in multihop configuration : how the multicast Router
> Solicitation messages, used by the neighbor discovery protocol, can reach
> the 6LBR ?
> ====>  Please check the section 10 (Examples) to get an understanding how
> the routers and hosts bootstrap in the multi-hop 6lowpan networks.  Initial
> multicast RS is sent only to the local subnet  and taken care by the local
> 6LR router in case of route-over scenario.
>
>
>
> -Samita
>
> _______________________________________________
> 6lowpan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6lowpan
>
>

-- 
Myung J. Lee, Ph.D
Professor
Dept. of Electrical and Computer Engineering
City University of New York, City College
140th Street, New York, NY 10031
(O)+1-212-650-7260
(E) [email-masked]

---

From: Robert Moskowitz <[email-masked]>
Date: Fri, 08 Jun 2012 10:07:12 -0400

Further on this.

My understanding is that 802.15.5 is NOT being used by anyone.

Zigbee has their own mesh methodology.  I do not have the documents, but 
as it was described to me, it is based on path discovery after network 
admission.

There is a new Mesh Under Routing Interest Group in 802.15, with a call 
for submissions for for the July 15th meeting.  This IG is not yet on 
the document server, it seems the submissions are being posted under the 
WNG SG:

https://mentor.ieee.org/802.15/documents?is_group=wng0

So far there is one submission:

https://mentor.ieee.org/802.15/dcn/12/15-12-0268-01-wng0-l2-routing-demands-for-fan.ppt

Mesh under IS out of scope for IETF and 6lowpan.  It IS in scope for 
802.15.  Unfortunately to play in IEEE, you have to pay.  That is attend 
a meeting. Though the document server is publicly available.

Oh the chair for this study group is Clint Powell, [email-masked].

On 06/04/2012 11:40 PM, Myung Jong Lee wrote:
> practice, completed in 2009. You may take a look at it. It is built on 
> IEEE 802.15.4b and sitting below IP layer.    I believe it could be 
> one of the feasible approaches for mesh under technologies. For the 
> details, you may refer to the standard itself or the paper, " IEEE 
> 802.15.5 WPAN mesh standard-low rate part: meshing the wireless sensor 
> networks," IEEE JSAC, Vol 28, No. 7, 2010 .
>
> Thanks,
>
> Myung
>
>
> On Tue, Jun 5, 2012 at 9:10 AM, Samita Chakrabarti 
> <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     Hi Damien,
>     ------------------------------------------------------------------------
>     *From:* [email-masked] <mailto:[email-masked]>
>     [mailto:[email-masked]
>     <mailto:[email-masked]>] *On Behalf Of *Damien Roth
>     *To:* [email-masked] <mailto:[email-masked]>
>     for 6LoWPAN (draft-ietf-6lowpan-nd-18), and there is one point
>     that remains unclear to me.
>
>     With 6LoWPAN, two routing mechanisms can be used : route over and
>     mesh under. Everything is OK with the route over mechanism but I'm
>     locked with mesh-under. In mesh-under routing, there is only two
>     entities, the 6LBR (border router) and the hosts. Multiple hops
>     may be needed to for hosts to reach the 6LBR.
>     ====> In mesh under case, the assumption is that all hosts are
>     directly IP-reachable from 6LBR. How the packets are flown from a
>     host to the 6LBR ( using a L2-mechanism) is out of scope of the
>     document. Currently I don't know of  L2-routing protocols for
>     mesh-under network - however, there might be some proprietary ones.
>
>     Solicitation messages, used by the neighbor discovery protocol,
>     can reach the 6LBR ?
>     ====>  Please check the section 10 (Examples) to get an
>     understanding how the routers and hosts bootstrap in the multi-hop
>     6lowpan networks.  Initial multicast RS is sent only to the local
>     subnet  and taken care by the local 6LR router in case of
>     route-over scenario.
>     -Samita
>
>     [email-masked] <mailto:[email-masked]>
> (E) [email-masked] <mailto:[email-masked]>
>
>

-- 
Robert Moskowitz
Senior Technical Advisor
Security & Standards
Verizon Business Systems
C:248-219-2059
F:248-968-2824
E:[email-masked]

There's no limit to what can be accomplished if it doesn't matter who 
gets the credit

---

From: "Benjamin A. Rolfe" <[email-masked]>
Date: Fri, 08 Jun 2012 09:17:27 -0700

Thanks Myung and Robert for bringing attention to the work already
done and being considered in 802.15. I would like to add a couple
clarifying points to help people understand how to participate.

Robert correctly points out that there is a fee to attend 802
plenary meetings (face to face physical meetings).  In Working Group
(WG) 802.15, there is also a fee for attending the interim meetings.
The current rules require physical attendance to achieve voting
status in a working group. However, that is not the only way one can
participate and contribute.  Traditionally much of the work occurs
between meetings via the email reflector and teleconferences, which
are open to anyone who wishes to participate.   All contributions
used during development of a draft are posted to the open document
server, and WG 15 allows anyone to post documents (you need an IEEE
"login" which you can free even if you are not an IEEE member). In
the past many significant contributions have been made by folks
unable to attend physical meetings.  Generally if a good idea is
presented in any of the various mediums (physical, TC, email) the
group will take it and run with it.

Establishment of an Interest Group (IG) is not an indication that
the WG has decided if the proposed idea fits within scope of a
particular standard or recommended practice.  At this point, it has
not been decided if L2 routing is "in scope" of 802.15.4 PHY/MAC
standard.  I expect we will hear more than on opinion on this, and
perhaps some enthusiastic discussion.  There are several paths it
may take, the IG is the first step in figuring out where to start.

Hope this helps!

-Ben

Further on this.

Zigbee has their own mesh methodology.  I do not have the
documents, but as it was described to me, it is based on path
discovery after network admission.

There is a new Mesh Under Routing Interest Group in 802.15, with a
call for submissions for for the July 15th meeting.  This IG is
not yet on the document server, it seems the submissions are being
posted under the WNG SG:

Mesh under IS out of scope for IETF and 6lowpan.  It IS in scope
for 802.15.  Unfortunately to play in IEEE, you have to pay.  That
is attend a meeting. Though the document server is publicly
available.

Hi Damien and all,

Though I am not an active member for 6lowpan, I just like
to note that there  is a "mesh under" routing standard, IEEE
802.15.5 a recommended practice, completed in 2009. You may
take a look at it. It is built on IEEE 802.15.4b and sitting
below IP layer.    I believe it could be one of the feasible
approaches for mesh under technologies. For the details, you
may refer to the standard itself or the paper, " IEEE 802.15.5
WPAN mesh standard-low rate part: meshing the wireless sensor
networks," IEEE JSAC, Vol 28, No. 7, 2010 .

Thanks,

Myung

On Tue, Jun 5, 2012 at 9:10 AM,
Samita Chakrabarti <[email-masked]>
wrote:

Hi Damien,

From: [email-masked]
[mailto:[email-masked]] On

Behalf Of Damien Roth

To: [email-masked]

Subject: [6lowpan] Mesh under routing and
Neighbor Discovery

Hello,

I continue my investigations the neighbor
discovery protocol
for 6LoWPAN (draft-ietf-6lowpan-nd-18), and there is
one point that remains unclear to me.

With 6LoWPAN, two routing mechanisms can be used
: route over and mesh under. Everything is OK with
the route over mechanism but I'm locked with
mesh-under. In mesh-under routing, there is only two
entities, the 6LBR (border router) and the hosts.
Multiple hops may be needed to for hosts to reach
the 6LBR.

====>
In mesh under case, the assumption is that
all hosts are directly IP-reachable from 6LBR. How
the packets are flown from a host to the 6LBR (
using a L2-mechanism) is out of scope of the
document. Currently I don't know of  L2-routing
protocols for mesh-under network - however,
there might be some proprietary ones.

My problem is in multihop configuration : how the
multicast Router Solicitation messages, used by the
neighbor discovery protocol, can reach the 6LBR ?

====>
Please check the section 10 (Examples) to get an
understanding how the routers and hosts bootstrap
in the multi-hop 6lowpan networks.  Initial
multicast RS is sent only to the local subnet  and
taken care by the local 6LR router in case of
route-over scenario.

-Samita

6lowpan mailing list

[email-masked]

--

Myung J. Lee, Ph.D

Professor

(O)+1-212-650-7260

(E) [email-masked]

--

Robert Moskowitz

Senior Technical Advisor

Security & Standards

Verizon Business Systems

C:      248-219-2059

F:      248-968-2824

E:      [email-masked]

There's no limit to what can
be accomplished if it doesn't matter who gets the credit