Subject: Re: [6lowpan] [Roll] draft-bormann-ghc

From: Yoshihiro Ohba <[email-masked]>
Date: Wed, 05 Sep 2012 14:16:38 +0900

It would be appreciated if someone can answer to my technical review
of GHC draft which I sent to the list:

http://www.ietf.org/mail-archive/web/6lowpan/current/msg03513.html

Thanks,
Yoshihiro Ohba

(2012/08/25 13:58), Carsten Bormann wrote:
> I don't know -- it could be handled as AD sponsored.  I'm confident we'll find a way.
> 
> More interesting is *when* it should go.  I'm in the process of obtaining research results that might improve the performance with DTLS packets a bit (with minimal implementation impact). We could rush GHC before that is complete, wait a couple of months for these results, or even try to get more input.  What is the best timing? We need input from implementers to decide this.
> 
> Sent from Mobile
> 
> On 24.08.2012, at 21:52, Michael Richardson <[email-masked]> wrote:
> 
>>
>>>>>>> "Carsten" == Carsten Bormann <[email-masked]> writes:
>>     Carsten> Changing to WG chair mode for a moment:
>>
>>     Carsten> The 6LoWPAN WG is alive and well and is in the process of
>>     Carsten> closing its remaining two work items (6LoWPAN-ND, 6LoWPAN
>>     Carsten> for BTLE).
>>
>>     Carsten> However, you are right in that the 6LoWPAN WG no longer takes new work on.
>>     Carsten> The chairs, with the ADs and the chairs of other WGs, will
>>     Carsten> ensure that interesting work finds an appropriate home.
>>
>> ...? where will GHC go?
>>
>> -- 
>> Michael Richardson
>> -at the cottage-
>> _______________________________________________
>> 6lowpan mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/6lowpan
> _______________________________________________
> 6lowpan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6lowpan
>

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 5 Sep 2012 09:24:19 +0200

> http://www.ietf.org/mail-archive/web/6lowpan/current/msg03513.html

Hi Yoshihiro,

I read that comment as an editorial suggestion, so I didn't see the need to discuss it in detail on the list.

I actually don't believe munching up all the variable bits into "***" makes the exposition clearer.
So far, all people I have talked to didn't have a misunderstanding about what was meant by, say, 11nnnkkk.
The "***" style may be more pedantically "correct", but I think it is actually less clear.
(And implementers mostly read the examples to figure out stuff anyway...)

Grüße, Carsten

---

From: Yoshihiro Ohba <[email-masked]>
Date: Wed, 05 Sep 2012 17:05:51 +0900

Hi Carsten,

Thank you for your response.

Why do you think the *** style is less clear?

Thanks,
Yoshihiro Ohba

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 5 Sep 2012 10:13:48 +0200

> Why do you think the *** style is less clear?

because 11nnnkkk turns into 11****** -- this loses visual access to the bit allocation.

Again, this is all about the exposition, not about the technical content of the proposal, so I'm not sure we need good consensus on what is the best style (we only need to make sure there is no potential for misinterpretation).

Grüße, Carsten

---

From: Yoshihiro Ohba <[email-masked]>
Date: Thu, 06 Sep 2012 08:39:12 +0900

Hi Carsten,

> Again, this is all about the exposition, not about the technical content of the proposal, so I'm not sure we need good consensus on what is the best style (we only need to make sure there is no pot…

I don't care if this is technical and editorial, but I do care the 
quality of IETF specification.  Honestly I think the current 
representation is too loose, and I am afraid you would get the same 
comment from others.  If you think *** representation loses visual 
access to the bit allocation, there can be other ways of 
representation such as "| 1| 1|n0|n1|n2|k0|k1|k2|".

This is something to think about for general readers..

Thanks you,
Yoshihiro Ohba

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 6 Sep 2012 13:46:17 +0200

OK, OK, I went ahead and added a section 1.3 that defines the meaning of the notation in a slightly more rigorous way.
Thanks for insisting on this...

Htmlized:        http://tools.ietf.org/html/draft-bormann-6lowpan-ghc-05
Diff:            http://www.ietf.org/rfcdiff?url2=draft-bormann-6lowpan-ghc-05

Grüße, Carsten

---

From: Yoshihiro Ohba <[email-masked]>
Date: Sat, 08 Sep 2012 10:03:38 +0900

Hi Carsten,

The new version with the meaning of the nation looks great.

Thank you,
Yoshihiro Ohba