Subject: [6tisch-security] minimal security draft

From: peter van der Stok <[email-masked]>
Date: Thu, 09 Feb 2017 10:06:12 +0100

Dear authors,

For the transport of the link-layer keys have you thought about using a 
specific format?
Will you specify a content-format in the CoAP registry?
We should like to use that content format also in the est-coaps draft.

If you do, will it be possible to use CBOR and specifically binary 
arrays?

Greetings,

Peter

-- 
Peter van der Stok
vanderstok consultancy
mailto: [email-masked]
www: www.vanderstok.org
tel NL: +31(0)492474673     F: +33(0)966015248

---

From: Mališa Vučinić <[email-masked]>
Date: Thu, 9 Feb 2017 10:45:17 +0100

Hello Peter,

We use COSE Key Set structure to transport link-layer keys. Key set is a CBOR array, while each key in the array is specified as a CBOR map object. This is quite flexible and relies on the already standardized document (COSE). We then bundle Key Set object together with a short 15.4 address to create a response that fits within a single 15.4 frame. For more details refer to Section 4.4 of minimal-security draft.

For the content-format question, doesn’t it suffice to use application/cbor as content type? I don’t have much experience with content-format registration so please correct me if I am missing something.

Regards,
Mališa

> On 09 Feb 2017, at 10:06, peter van der Stok <[email-masked]> wrote:
> 
> Dear authors,
> 
> For the transport of the link-layer keys have you thought about using a specific format?
> If you do, will it be possible to use CBOR and specifically binary arrays?
> 
> Greetings,
> 
> Peter
> 
> -- 
> Peter van der Stok
> vanderstok consultancy
> _______________________________________________
> 6tisch-security mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tisch-security

---

From: Tero Kivinen <[email-masked]>
Date: Thu, 9 Feb 2017 15:15:34 +0200

Mališa Vučinić writes:
> Hello Peter,
> 
> We use COSE Key Set structure to transport link-layer keys. Key set
> is a CBOR array, while each key in the array is specified as a CBOR
> map object. This is quite flexible and relies on the already
> standardized document (COSE). We then bundle Key Set object together
> with a short 15.4 address to create a response that fits within a
> single 15.4 frame. For more details refer to Section 4.4 of
> minimal-security draft. 

You would also need to have 802.15.4 specific key identification
information, i.e. the KeyIdMode, KeyIndex (if KeyIdMode is not 0) and
KeySource (if KeyIdMode is 2 or 3).
-- 
[email-masked]

---

From: Mališa Vučinić <[email-masked]>
Date: Thu, 9 Feb 2017 14:58:28 +0100

Thanks, Tero. I created an issue in the bitbucket so we will resolve this with the next published version.

For minimal, I propose that we limit the document to either implicit or KeyIndex mode and use the kid parameter of COSE_Key struct to identify the value of the index. If kid is not present -> use implicit mode, if kid is present use it for KeyIndex mode. What do you think?

Mališa

> On 09 Feb 2017, at 14:15, Tero Kivinen <[email-masked]> wrote:
>

---

From: peter van der Stok <[email-masked]>
Date: Fri, 10 Feb 2017 09:12:27 +0100

Hi Malisa,

thanks for the info.
> 
> For the content-format question, doesn’t it suffice to use
> application/cbor as content type? I don’t have much experience with
> content-format registration so please correct me if I am missing
> something.
> 
When several applications use the same format, it is better to define it 
at one place.
est-coaps probably wants to transport the same keys in the same format.
Also in the future, new formats can be added without changing the 
bootstrap protocol.

If you agree, I may do a proposal.

Peter

---

From: Mališa Vučinić <[email-masked]>
Date: Fri, 10 Feb 2017 09:52:13 +0100

Yes, please, go ahead.

Mališa

> On 10 Feb 2017, at 09:12, peter van der Stok <[email-masked]> wrote:
>