Subject: [84attendees] Vancouver Laundry Service that cater to downtown hotel guests

From: Thomas Herbst <[email-masked]>
Date: Tue, 31 Jul 2012 21:02:46 +0000

Wrapping up two weeks of travel, needed to get some laundry done.
To avoid the extreme charges in the hotel,  Yelp and google offered "Swan Laundry and Dry Cleaning"

For $50 they will pick up and delivery a load (~10pounds) from/to downtown hotels.
Discounts for dropping off and picking up.  As I did not know they would pick up, I walked to it at lunch today.
About 15 minutes.

They are at 1350 Burrard St, Vancouver, BC
604-684-0323

Fairmont, Hyatt and others seem to be a regular route for them.

tom

---

From: Randall Gellens <[email-masked]>
Date: Tue, 31 Jul 2012 14:44:36 -0700

There's also a laundrette that will wash your stuff if you drop off 
and pick up, on Davie street a block or two to the right from 
Burrard.  If you're at the Sheraton it may be closer.

At 9:02 PM +0000 7/31/12, Thomas Herbst wrote:

>  Discounts for dropping off and picking up.  As I did not know they 
> would pick up, I walked to it at lunch today.
>  About 15 minutes.
>
>  _______________________________________________
>  84attendees mailing list
>  [email-masked]
>  https://www.ietf.org/mailman/listinfo/84attendees

-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly selected tag: ---------------
It is easier to fight for one's principles than to live up to them.
                                                     --Alfred Adler