Subject: [85attendees] IPhone app for ietf

From: Mahesh Jethanandani <[email-masked]>
Date: Sun, 4 Nov 2012 22:25:33 -0500

My app is not updating for this meeting. What am I missing?

---

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 5 Nov 2012 07:15:53 -0500

Make sure you have the most recent version from iTunes. It should be
version 1.5 (you can see the version in the Settings app).

On Sun, Nov 4, 2012 at 10:25 PM, Mahesh Jethanandani <
[email-masked]> wrote:

> _______________________________________________
> 85attendees mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/85attendees
>

---

From: Mahesh Jethanandani <[email-masked]>
Date: Mon, 5 Nov 2012 09:27:02 -0500

This is more a question for the designers of the app. Is that intended
design - meaning update the app to get the latest meeting update? If it is,
it is unusual.

On Nov 5, 2012, at 7:16 AM, "Andrew G. Malis" <[email-masked]> wrote:

---

From: Randall Gellens <[email-masked]>
Date: Wed, 7 Nov 2012 12:03:00 -0800

At 7:15 AM -0500 11/5/12, Andrew G. Malis wrote:

>  Make sure you have the most recent version from iTunes. It should 
> be version 1.5 (you can see the version in the Settings app).

Sadly, 1.5 requires iOS 4.3 which is not available for an iPhone 3G 
(I know, time to upgrade).

-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly selected tag: ---------------
Trying to be happy is like trying to build a machine for which
the only specification is that it should run noiselessly.

---

From: Tom Pusateri <[email-masked]>
Date: Wed, 7 Nov 2012 15:17:05 -0500

On Nov 7, 2012, at 3:03 PM, Randall Gellens <[email-masked]> wrote:

>> Make sure you have the most recent version from iTunes. It should be version 1.5 (you can see the version in the Settings app).
> 
> Sadly, 1.5 requires iOS 4.3 which is not available for an iPhone 3G (I know, time to upgrade).
> 

Yep, it pained me to drop iOS 4.2 support but the SDK required it. I couldn't have both native iPhone 5 support for the new larger screen and iOS 4.2 support for the iPhone 3G so I chose the iPhone 5.

Tom

---

From: Randall Gellens <[email-masked]>
Date: Wed, 7 Nov 2012 12:33:45 -0800

At 3:17 PM -0500 11/7/12, Tom Pusateri wrote:

>  Yep, it pained me to drop iOS 4.2 support but the SDK required it. 
> I couldn't have both native iPhone 5 support for the new larger 
> screen and iOS 4.2 support for the iPhone 3G so I chose the iPhone 
> 5.

I understand.  Well, that just clinches it: I need to upgrade (I've 
been reluctant because I need to pay full price).

I'm curious why an update is needed to get information on new meetings?

-------------- Randomly selected tag: ---------------
Most people and their lazy, conventional ways of thinking wear
down our childlike thinking powers over time. And we help them.
                               --Marco Marsan, from 'Think Naked'

---

From: Tom Pusateri <[email-masked]>
Date: Wed, 7 Nov 2012 16:14:29 -0500

On Nov 7, 2012, at 3:33 PM, Randall Gellens <[email-masked]> wrote:

> I understand.  Well, that just clinches it: I need to upgrade (I've been reluctant because I need to pay full price).
> 

The app gets updated in the app store to include new maps, room numbers, Working Groups, BOFs, etc. typically once per meeting. The formats of the schedule sometimes change and it's really best if I can test it with the new agenda each meeting to find any unexpected crashes due to data format changes.

This was expedient for releasing the app but long term, this info could be downloaded on the fly. It is just a matter of defining a RESTful interface to the data, hosting it somewhere, and updating the app to pull it in.

Based on my schedule, I can do this but it hasn't been high priority. I would rather add new features.

Tom