Subject: [85attendees] IPhone app for IETF

From: Mahesh Jethanandani <[email-masked]>
Date: Sun, 4 Nov 2012 22:57:57 -0500

Resending, as I do not see my e-mail.

The ietf app for iPhone is not updating for this meeting. The last one
it shows is Vancouver. What am I missing?

---

From: Warren Kumari <[email-masked]>
Date: Sun, 4 Nov 2012 23:16:15 -0500

Click Meetings in the bottom right, then Meetings in the top left, then choose IETF85 and all should be fine...

W

Warren Kumari
------
Please excuse typing, etc -- This was sent from a device with a tiny keyboard.

On Nov 4, 2012, at 10:57 PM, Mahesh Jethanandani <[email-masked]> wrote:

> _______________________________________________
> 85attendees mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/85attendees
>

---

From: Ross Finlayson <[email-masked]>
Date: Mon, 5 Nov 2012 02:15:53 -0500

The IETF iPhone app is nice; however, there is a bug in the "Favorites" feature.

To reproduce:
1/ Go to the "Schedule" view.  Make sure the "Schedule" tab at the top of the view is selected.
2/ Tap on the grey star that's on the left hand side of one of the sessions.  The star will turn blue.
3/ Click on the "Favorites" tab.  The app will crash.

	Ross.

---

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 5 Nov 2012 07:49:40 -0500

Favorites works fine for me. I'm looking at my list of blue stars now.

Cheers,
Andy

---

From: Dan York <[email-masked]>
Date: Mon, 5 Nov 2012 08:07:01 -0500

Ross,

I'm not able to reproduce this on my iPhone 4S running iOS 6.0.  I've also not been able to reproduce it on an iPad 2. In both cases the application continues to run fine and I can see my list of favorites. 

Dan

---

From: Ross Finlayson <[email-masked]>
Date: Mon, 5 Nov 2012 08:36:02 -0500

> I'm not able to reproduce this on my iPhone 4S running iOS 6.0.

The issue appears to be iOS version related.  The crash happens repeatedly for me with an iPhone 4S running iOS version 5.1.1.

	Ross.

---

From: Igor Gashinsky <[email-masked]>
Date: Mon, 5 Nov 2012 09:00:07 -0500

I see the crash every time I click on the 'Favorites' tab as well. iOS 5.1.1 on iPhone 4S.

-igor

---

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 5 Nov 2012 09:14:34 -0500

Works fine (no crash) on iOS 6.0.1 on an iPod Touch 4th gen.

Cheers,
Andy

On Mon, Nov 5, 2012 at 9:00 AM, Igor Gashinsky <[email-masked]> wrote:

> > I'm not able to reproduce this on my iPhone 4S running iOS 6.0.  I've
> also not been able to reproduce it on an iPad 2. In both cases the
> application continues to run fine and I can see my list of favorites.
> >
> > Dan
> >

---

From: Roy Fielding <[email-masked]>
Date: Mon, 5 Nov 2012 06:19:20 -0800

I can reproduce it (started crashing last night).  iPhone 4 iOS 5.1.1.
It worked fine for me in Vancouver.

Just before the first crash, I added a favorite and then removed it.
The app crashed the first time I selected the favorites mode, and
every time since then.

....Roy

---

From: Carl Wallace <[email-masked]>
Date: Mon, 05 Nov 2012 09:27:03 -0500

I had a similar experience on an iPad with iOS 5.1.1 where the app would
crash almost immediately when I opened it.  I was able to get it to stop
crashing by quickly selecting a different day before the crash occurred.
It now opens without crashing.  It worked fine until I entered some
favorites.

---

From: Matthew Ford <[email-masked]>
Date: Mon, 5 Nov 2012 09:40:10 -0500

On 5 Nov 2012, at 02:15, Ross Finlayson <[email-masked]> wrote:

> The app will crash.

I see the same behaviour. I reinstalled the app yesterday to get the Atlanta update.

Mat

---

From: Philip Matthews <[email-masked]>
Date: Mon, 5 Nov 2012 10:18:38 -0500

I also see this issue on my (aging) iPhone 3GS running iOS 4.<mumble>
- Philip

---

From: Mahesh Jethanandani <[email-masked]>
Date: Mon, 5 Nov 2012 17:45:59 -0500

Realized one more bug in the app.

Alto meets on wed at 1440 in Salon C. But the app does not have that entry.

Sent from my iPhone

---

From: "Zuniga, Juan Carlos" <[email-masked]>
Date: Mon, 5 Nov 2012 10:39:32 -0500

Last night I tried on my colleague's brand new iPhone 5 and it worked
fine. However I have the same crashing issue on mine, which is a  3GS,
running iOS 5.0.1.

As of last meeting (app version?) the favourites feature used to work
fine for me.

Jc

> -----Original Message-----
> From: [email-masked] [mailto:85attendees-
> [email-masked]] On Behalf Of Philip Matthews
> Sent: Monday, November 05, 2012 10:19 AM
> To: Ross Finlayson
> Cc: [email-masked]
> Subject: Re: [85attendees] IPhone app for IETF
>

---

From: Tom Pusateri <[email-masked]>
Date: Wed, 7 Nov 2012 13:19:50 -0500

I fixed the bug yesterday. The next release will work for you again. It was a problem where new views enable auto layout by default which is only in iOS 6.

Tom

---

From: Philip Matthews <[email-masked]>
Date: Wed, 7 Nov 2012 13:29:10 -0500

Is the fixed version now available in the App Store?
- Philip

---

From: joel jaeggli <[email-masked]>
Date: Wed, 07 Nov 2012 13:32:31 -0500

> Is the fixed version now available in the App Store?

takes a while to get approved.

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 07 Nov 2012 13:33:30 -0500

> takes a while to get approved.

My paper schedule is working just fine. ;-)

/psa

---

From: "Pat Thaler" <[email-masked]>
Date: Wed, 7 Nov 2012 18:36:33 +0000

The function to make the paper schedule show only the favorites you marked doesn't work at all. They forgot to put the button in for it.  ;-)

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Peter Saint-Andre
Sent: Wednesday, November 07, 2012 10:34 AM
To: joel jaeggli Cc: Tom Pusateri; [email-masked]; Ross Finlayson; Philip Matthews; Zuniga, Juan Carlos
Subject: Re: [85attendees] IPhone app for IETF

/psa

---

From: Tom Pusateri <[email-masked]>
Date: Wed, 7 Nov 2012 13:36:58 -0500

If the IETF were to become an Enterprise Member, we could conceivably distribute the app ourselves from our own servers and update it on the fly.

As it stands now, we have to wait for review by Apple which takes approximately 9 days.

Tom

---

From: Dean Willis <[email-masked]>
Date: Wed, 7 Nov 2012 13:11:35 -0600

> As it stands now, we have to wait for review by Apple which takes approximately 9 days.

Apple's model is broken. I really can't see why any developer puts up with this sort of headache. Maybe it's just a case of "the only game in town".

OTOH, a native app for IETF makes little sense. Wouldn't a pure Web application be entirely adequate?

--
Dean

---

From: Tom Pusateri <[email-masked]>
Date: Wed, 7 Nov 2012 14:13:37 -0500

> OTOH, a native app for IETF makes little sense. Wouldn't a pure Web application be entirely adequate?

I love competition. There is no reason why we can't have both and let the users decide.

Tom

---

From: Dean Willis <[email-masked]>
Date: Wed, 7 Nov 2012 13:16:42 -0600

> I love competition. There is no reason why we can't have both and let the users decide.

With an approximate 9 day lead time on shipping a bug fix for a program with a 5-day usage window, what's to decide?

--
Dean

---

From: "Andrew G. Malis" <[email-masked]>
Date: Wed, 7 Nov 2012 14:29:16 -0500

It'll be ready for the next IETF! I'm just happy Tom is willing to put in
the investment to create the app and share it for free with the community -
thanks, Tom!

Regarding the Apple lag time, I have both iOS and Android devices, and I
appreciate the higher level of quality you typically see in iOS apps when
compared with Android apps. I'm just curious how Apple can keep scaling
their approval process.

Cheers,
Andy

On Wed, Nov 7, 2012 at 2:16 PM, Dean Willis <[email-masked]>wrote:

> With an approximate 9 day lead time on shipping a bug fix for a program
> with a 5-day usage window, what's to decide?
>
> --
> Dean
>

---

From: Philip Matthews <[email-masked]>
Date: Wed, 7 Nov 2012 14:53:43 -0500

On 2012-11-07, at 14:29 , Andrew G. Malis wrote:

> It'll be ready for the next IETF! I'm just happy Tom is willing to put in the investment to create the app and share it for free with the community - thanks, Tom!
> 

I would also like to thank Tom for the App.  This was the first time I used it, and I found it very helpful, despite the bug.  I have mostly not used the old paper "app" this meeting.

- Philip

---

From: Dean Willis <[email-masked]>
Date: Wed, 7 Nov 2012 13:58:16 -0600

> I would also like to thank Tom for the App.  This was the first time I used it, and I found it very helpful, despite the bug.  I have mostly not used the old paper "app" this meeting.

I haven't used the app --  my old iPhone is in the heap of not-in-use devices back in Texas.

I did sue the Android app a few times this meeting, and found myself using the "paper" app more than the Android app (although the Android app was very helpful when I misplaced my paper). 

Is there specific functionality to Tom's iPhone native app that makes it more useful than a web-app would be for the usage cases you users experienced here at IETF? Off-line use? Data cacheing?  Better GUI?

--
Dean

---

From: Randall Gellens <[email-masked]>
Date: Wed, 7 Nov 2012 12:05:40 -0800

> application be entirely adequate?

I really appreciate the ability to have an app that can cache data 
and be usable offline.

-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly selected tag: ---------------
I have the simplest tastes.  I am always satisfied with the best.
        --Oscar Wilde

---

From: "Andrew G. Malis" <[email-masked]>
Date: Wed, 7 Nov 2012 16:18:12 -0500

Yes, this is esp. important on an iPod Touch, which is what I use the app
on. There isn't always Wifi available when I access the app (such as on the
bus ride back from the social last night).

Cheers,
Andy

On Wed, Nov 7, 2012 at 3:05 PM, Randall Gellens <[email-masked]>wrote:

> I really appreciate the ability to have an app that can cache data and be
> usable offline.
>
> --
> Randall Gellens
> ______________________________**_________________
> 85attendees mailing list
> [email-masked]
> https://www.ietf.org/mailman/**listinfo/85attendees<https://www.ietf.org/mailman/listinfo/85attendees>
>

---

From: Adam Roach <[email-masked]>
Date: Wed, 07 Nov 2012 16:46:31 -0500

On 11/7/12 14:58, Dean Willis wrote:
> I did sue the Android app...

Dude. You've been hanging around the lawyers way too much.

/a

---

From: "John R Levine" <[email-masked]>
Date: 7 Nov 2012 17:23:01 -0500

> Apple's model is broken. I really can't see why any developer puts up with this sort of headache. Maybe it's just a case of "the only game in town".

It's to keep malware, of which there is an enormous amount, out of the app 
store.  If you have a better way to do that than auditing apps, I know 
some patent lawyers who'd like to talk to you.

> OTOH, a native app for IETF makes little sense. Wouldn't a pure Web application be entirely adequate?

Depends.  How much state can an iPad web app cache locally?  Can it run 
entirely from cached info?

Regards,
John Levine, [email-masked], Taughannock Networks, Trumansburg NY
"I dropped the toothpaste", said Tom, crestfallenly.