Subject: [99attendees] Changing money

From: Daniel Shaw <[email-masked]>
Date: Sun, 16 Jul 2017 16:13:07 +0200

Dear all,

I needed to change some cash, and followed the advice of my Airbnb hosts with good success.

The forex windows/stores adjacent at the Palladium mall (but on the street) have the best rates. I was recommended a specific one, but I saw a second with about the same rate.

They beat google/yahoo online rates and the Hilton by a bit, and the counters at the airport by a lot.

I used one yesterday, so I do not know if they are open on a Sunday.

Cheers,
Daniel

---

From: "Auditel s.r.o." <[email-masked]>
Date: Sun, 16 Jul 2017 17:07:33 +0200

Good rate for money exchange is also at office located close from Old Town Square.

If you print somewhere (Hilton business corner printer?) coupon you will have VIP rates.

See: 

https://www.exchange.cz <https://www.exchange.cz/>

BR

Tomas

> On Jul 16, 2017, at 4:13 PM, Daniel Shaw <[email-masked]> wrote:
> 
> Dear all,
> 
> _______________________________________________
> 99attendees mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/99attendees