Subject: [AAA-DOCTORS] RADIUS Documents in Last Call for Tue Jan 10 22:16:52 CET 2012

From: [email-masked]
Date: Tue, 10 Jan 2012 22:16:52 +0100 (CET)

From: Alan DeKok <[email-masked]>

  This is an automatically generated email.  It lists the IETF internet-drafts
which are WG items; in IETF Last Call, and which reference RADIUS.  Drafts
from the RADEXT and DIME working groups are not included.

--
draft-ietf-netext-radius-pmip6-06.txt  http://datatracker.ietf.org/doc/draft-ietf-netext-radius-pmip6-06/

---

From: Alan T DeKok <[email-masked]>
Date: Tue, 10 Jan 2012 22:19:07 +0100

Well, that seemed to work.  I'll poke it to get the correct URL, and
have cron send an email once a week.

[email-masked] wrote:
> _______________________________________________
> AAA-DOCTORS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/aaa-doctors
> 
>

---

From: Alan T DeKok <[email-masked]>
Date: Tue, 10 Jan 2012 22:27:57 +0100

For reference, the Makefile is attached.

  Alan DeKok.

all: mail.txt

.PHONY: sync
sync:
	@rsync -q -avz --delete ftp.rfc-editor.org::internet-drafts internet-drafts/

internet-drafts/all_id.txt: sync

last-call.txt: internet-drafts/all_id.txt
	@perl -ne 'next if !/^draft-ietf-/;next if /^draft-ietf-radext/;next if /^draft-ietf-dime/;next unless /In Last Call/;chop;split;next if ! -f "internet-drafts/$$_[0].txt";print "internet-drafts/",$$_[0],".txt\n";' < $< > $@

radius.txt: last-call.txt
	@grep -l RADIUS `cat $<` | sed 's,internet-drafts/,,' > $@

mail.txt: top.txt radius.txt 
	@cp top.txt $@
	@cat radius.txt | while read file; do \
		y=`echo $$file | sed 's/-..\.txt//'`; \
		echo "$$file  http://datatracker.ietf.org/doc/$$y/" >> $@; \
	 done

.PHONY: send
send:
	@mail -aFrom:[email-masked] -s "RADIUS Documents in Last Call for `date`" [email-masked] < mail.txt