Subject: RE: [AAA-WG]: Mobile IP Extension

From: "Haseeb Akhtar" <[email-masked]>
Date: Thu, 8 Mar 2001 16:50:45 -0600

Pat,

I would like to propose we generalize AMR and AMA 
so that both of these messages can be used between
all four entities involved (FA, AAAF, AAAH and HA) during
registration. That way, we can truly ignore the 
geographical proximity between them and focus on their
functional behavior.

So, this is what the flow would look like.

FA 		AAAF 		AAAH  	HA@visited_network
  -AMR->  		-AMR->
  	  		<-AMA-
			--------AMR-------->
			<--------AMA--------
  <-AMA-  		

Granted, there are differences between the functions that
needs to be performed after receiving AMR vs. HAR, however,
the Session ID can keep the servers stateful.

Also, you are having to open up the AAAF for both AMR/AMA 
and HAR/HAA interfaces in the option cited below. Combining
them into one interface will, in my opinion, make a better
protocol. 

Regards,

Haseeb

-----Original Message-----
From: Patrice Calhoun [mailto:[email-masked]]
Sent: Thursday, March 08, 2001 1:13 PM
To: aaa-wg; diameter
Subject: [AAA-WG]: Mobile IP Extension

All,

This is just a heads up on changes that are required in the Mobile IP
Extension,
as a result of the testing this week in San Jose.

The Mobile IP extension currently defines the following signalling 

FA       AAAF      AAAH      HA
   -AMR->    -AMR->    -HAR->
   <-AMA-    <-AMA-    <-HAA-

However, if the Home Agent is assigned in the visited network, the
following signalling is mandated:

FA       AAAF      AAAH      AAAF      HA
   -AMR->    -AMR->    -AMA->    -HAR->
   <------------AMA----------    <-HAA-
                        <-HAI-

We had originally decided to do this to reduce the number of round trips to
the AAAH. In the above scenario, the AAAH authenticates the mobile,
generates
keys, and replies back to the AAAF. The AAAH is not contacted again until
the
HAI is sent to inform the AAAH of the status of the request.

However, this scheme, while reducing round trips, does require that HAR-ish
AVPs are present in the AMA. This really makes the protocol quite
complicated,
and further requires that the HAI include some success result code. This
means that in order to save round trips, we end up abusing protocol
messages.

Therefore, after discussin this over with people that have implemented it,
we
decided that protocol complexity did not justify this, and we reverted back
to what was in the spec some time back, which is:
FA       AAAF      AAAH      AAAF      HA
   -AMR->    -AMR->    -HAR->    -HAR->
   <-AMA-    <-AMA-    <-HAA-    <-HAA-

This means that the signalling is exactly the same, whether the Home Agent
is
in the home or visited network. Furthermore, it makes it VERY simple to also
handle the case where the Home Agent is in a third network, as below:

                              (3rd domain)
FA       AAAF      AAAH      AAAF      HA
   -AMR->    -AMR->    -HAR->    -HAR->
   <-AMA-    <-AMA-    <-HAA-    <-HAA-

Anyone object to the above changes in the -02 of the Mobile IP extension?
Again,
implementors found this to be the simplest.

Thanks,

PatC

---

From: Tony Johansson <[email-masked]>
Date: Thu, 08 Mar 2001 15:22:10 -0800

Hi Haseeb,

I disagree with you. An AMR and an HAR are two different things. The AMR
deals with user authentication and the HAR deals with HA assignment. We
have been discussing this during the interop test even in San Jose and I
strongly believe that the most logic way of doing this is as Pat
describes it below.

BR,

/Tony

Haseeb Akhtar wrote:

> keys, and replies back to the AAAF. The AAAH is not contacted again
> until the
> Therefore, after discussin this over with people that have implemented
> it, we
> This means that the signalling is exactly the same, whether the Home
> Agent is
> Anyone object to the above changes in the -02 of the Mobile IP
> extension? Again,

---

From: "John Alayari" <[email-masked]>
Date: Fri, 9 Mar 2001 09:51:43 -0800

Hassib,

How are you doing? Having AMR and AMR do different functions based on the
session state is unusual. The implementation and maintenance of this in the
server will not be easy. Also, this mandates servers to be stateful. I agree
with Pat's solution so far.

John Alayari.
  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]]On Behalf Of
Tony Johansson
  Sent: Thursday, March 08, 2001 3:22 PM
  To: Haseeb Akhtar
  Cc: 'pcalhoun'; aaa-wg; diameter
  Subject: Re: [AAA-WG]: Mobile IP Extension

  Hi Haseeb,
  I disagree with you. An AMR and an HAR are two different things. The AMR
deals with user authentication and the HAR deals with HA assignment. We have
been discussing this during the interop test even in San Jose and I strongly
believe that the most logic way of doing this is as Pat describes it below.

  BR,

  /Tony

  Haseeb Akhtar wrote:

    Pat,

    Regards,

    Haseeb

    -----Original Message-----
    From: Patrice Calhoun [mailto:[email-masked]]
    Sent: Thursday, March 08, 2001 1:13 PM
    To: aaa-wg; diameter
    Subject: [AAA-WG]: Mobile IP Extension

    All,

    FA       AAAF      AAAH      HA
       -AMR->    -AMR->    -HAR->
       <-AMA-    <-AMA-    <-HAA-

    FA       AAAF      AAAH      AAAF      HA

    We had originally decided to do this to reduce the number of round trips
to
    the AAAH. In the above scenario, the AAAH authenticates the mobile,
generates
    keys, and replies back to the AAAF. The AAAH is not contacted again
until the
    HAI is sent to inform the AAAH of the status of the request.

    However, this scheme, while reducing round trips, does require that
HAR-ish
    AVPs are present in the AMA. This really makes the protocol quite
complicated,
    and further requires that the HAI include some success result code. This
    means that in order to save round trips, we end up abusing protocol
messages.

    decided that protocol complexity did not justify this, and we reverted
back

    This means that the signalling is exactly the same, whether the Home
Agent is
    in the home or visited network. Furthermore, it makes it VERY simple to
also
    handle the case where the Home Agent is in a third network, as below:

                                  (3rd domain)
    FA       AAAF      AAAH      AAAF      HA

    Thanks,

    PatC