Subject: [AAA-WG]: Comments on draft-ietf-aaa-diameter-mobileip-01.txt

From: "Martin Julien (ECE)" <[email-masked]>
Date: Fri, 9 Mar 2001 09:11:14 +0100

Hi Pat,

I sent it to the list yesterday, but for some reasons, it never made it apparently??? Let's try again!

Martin

> -----Original Message-----
> From:	Martin Julien (ECE) 
> Sent:	Thursday, March 08, 2001 9:11 PM
> To:	[email-masked]'
> Subject:	Comments on draft-ietf-aaa-diameter-mobileip-01.txt
> 
> Hi Pat,
> 
> I have some comments on this document, and hopefully they 
> might be useful.
> 
> 
> 1) I think that page 8 should be a new section about a Mobile 
> Node moving to a Foreign Network.
> 
> 2)Page 8, par.2, the MIP-Previous-FA-NAI must be change for 
> MIP-Previous-FA-FQDN. You should use find and replace for 
> this one, since there are more than one.
> 
> 3) Page 8, in figure 5, the message between the HA and AAAF 
> must be HAA, instead of HAR.
> 
> 4) Page 8, par.2, last sentence. I don't really understand 
> what you mean there. I guess you meant that Home Agent and 
> the requesting Foreign Agent are in different domain. The 
> thing is that it is likely that the Home Agent and the 
> MIP-Previous-FA-FQDN were in the same domain at the last 
> registration, right?
> 
> 5) In section 1.3, the meaning of home address 
> 255.255.255.255 is described, but the meaning of 0.0.0.0 
> should also be added for clarity. BTW, those conditions are 
> mentioned at several places in the document. I like the 
> concept of the state machine as in the Base spec.
> 
> 6) Section 1.4, the second paragraph suggests to release the 
> all resources in the Home Diameter server upon the receipt of 
> the STR from the Home Agent. I guess it should be clear that 
> the referred Home Agent is the "active" Home Agent, since 
> there might be 2 Home Agents at the same time while roaming. 
> During handoffs between different FAs in different domains, 
> and let's say that the Home Agent in the old Foreign domain 
> can not be maintained there, then a new Home Agent has to be 
> started in the Home Domain or the new Foreign domain and the 
> AAAH needs to send a STI to the old Home Agent, which replies 
> with a STR. In that case, the Home Diameter should not 
> release resources, right?
> 
> 7) Many references to MIP-Reg-Req should be changed for 
> MIP-Reg-Request. Find and replace.
> 
> 8) Many references to MIP-Reg-Rep should be changed for 
> MIP-Reg-Reply. Find and replace.
> 
> 9) Many references to Peer-SPI should be changed for 
> MIP-Peer-SPI . Find and replace.
> 
> 10) In section 2.3, a home address of 255.255.255.255 should 
> also request a new address.
> 
> 11) Section 2.3 par.2, "If a AAAF receives a HAR..." should 
> be "If a AAAF receives a AMA..." Right?
> 
> 12) Section 3.1, it it Hop-by-Hop Failures?, or Per-Hop 
> Failures? Should all those errors be sent through a DSI?
> 
> 13) Section 3.1, just wondering, why error numbers are 6xxx series?
> 
> 14) Section 4.6, A reference to Previous Foreign Agent 
> Notification Extension would be nice.
> 
> 15) Section 4.7, "If the mobile node sets the home agent 
> field equal to 0.0.0.0 ..." should also include 
> 255.255.255.255, like mentioned in section 1.3
> 
> 16) Section 4.7, "...Home-Address-Requested flag or the 
> Home-Agent-Request flag..." should rather be 
> "Mobile-Node-Home-Address-Requested flag or the 
> Home-Agent-Requested flag"
> 
> 17) "If the mobile node requests a home agent in the foreign 
> network by
>    setting the home address field to all ones,..." I guess it 
> should be home agent instead, right? Also, in the document, 
> 255.255.255.255 is used and some other places it is all ones. 
> Can it be one or the other for clarity?
> 
> 18) Section 5.0 par.2, "Absence or the AVP, or a value of 
> zero indicates infinity
>    (no timeout)." It the message definition, it says that 
> this AVP is mandatory.
> 
> 19) Section 5.0 par.2, "If no preferred SPI value is 
> indicated the registration keys the foreign agent needs..." I 
> think that the part "the registration keys the foreign agent 
> needs" does not really fit in this sentence.
> 
> 20) Section 5.1 par.3, "MIP-HA-to-MN-Key AVP in the AMR 
> message..." should be "in the AMA message" (reference to 
> section 1.3 p.7)
> 
> 21) Section 5.1 par.3, "When the AAAF receives the AMR,..." 
> should also be "the AMA"
> 
> 22) Section 5.1 par.5, "MIP-MN-to-HA-Key AVP into the AMR 
> message" should be "the AMA"
> 
> 23) Section 5.1 par.5, "...in the MIP-HA-to-MN-Key AVP from 
> the AVP received from AAAH, AAAF then recodes the 
> registration key into a new MIP-HA-to-MN-Key AVP ". Both 
> MIP-HA-to-MN-Key should be replaced by MIP-MN-to-HA-Key.
> 
> 24) Section 5.2 par.2, "...MIP-MN-to-FA-Key AVP in the AMR 
> message..." should be the "AMA message"
> 
> 25) Section 5.2 last par., "...key available to AAAF." should 
> be "available to FA"
> 
> 
> 26) Section 5.3 par.4, "...MIP-HA-to-FA-Key AVP as part of 
> the AMR..." should be "to the AMA"
> 
> 27)  Section 2.1, why is the Session-ID is required with {}, 
> but not with [], like in other messages?
> 
> 28) Section 2.1, why the "Authorization-Lifetime" required?
> 
> 29) I am wondering why the Destination-Realm AVP is required 
> in Answer messages?
> 
> 30) In section 2.2, the Origin-FQDN AVP and the Origin-Realm 
> AVP must be required.
> 
> 31) In section 2.5, what is the point of sending a HAI 
> without the MIP-Home-Agent-Address? Should it be required?
> 
> 32) In the case where a mobile node handoffs to a different 
> FA within the same administrative domain, is it required to 
> reach the Home server with the AMR?, or can it be handled in 
> the AAAF? It might be interesting to show this scenario, right?
> 
> 
> I think this is it for now.
> Cheers,
> Martin

---

From: Pat Calhoun <[email-masked]>
Date: Fri, 9 Mar 2001 06:37:15 -0800 (PST)

Martin,

Got them yesterday. I will go through them on Monday as I start getting -02
ready.

Thanks for the great comments,

PatC