Subject: RE: [AAA-WG]: End-2-End security

From: Yiwen Jiang <[email-masked]>
Date: Fri, 11 May 2001 14:48:09 -0400

Would this issue not leading back to whether a small diameter base protocol
with many plugin extensions should be defined ? Maybe if we settle on a
concensus on this issue, the question would answer itself?

> -----Original Message-----
> From: Pat Calhoun [mailto:[email-masked]]
> Sent: Friday, May 11, 2001 2:32 PM
> To: Thomas Panagiotis-PTHOMAS1
> Cc: [email-masked]'
> Subject: Re: [AAA-WG]: End-2-End security
> 
> 
> On Fri, May 11, 2001 at 01:29:25PM -0500, Thomas 
> Panagiotis-PTHOMAS1 wrote:
> > "2.0 Protocol Overview
> > ...
> > Diameter servers MUST support the Base protocol, which 
> includes Accounting,
> > and both the NASREQ and Mobile IP extensions. Diameter 
> Clients MUST support
> > the Base protocol, including Accounting, and MAY support 
> any other extension
> > that would be required to provide service."
> > 
> > So End-2-End security is a MAY for Clients and Servers, right?
> 
> The way the text currently reads, yes I guess so. How do others feel?
> 
> PatC
>

---

From: Pat Calhoun <[email-masked]>
Date: Fri, 11 May 2001 11:41:46 -0700

> concensus on this issue, the question would answer itself?

This *is* still supported by the protocol. However, the IESG is concerned
about Diameter servers coming out with some extensions, and not others,
causing confusion in the market. This is why they have asked that all
servers support NASREQ and Mobile IP extensions.

PatC