Subject: RE: [diameter] Re: [AAA-WG]: Re: questions and comments regarding the Diameter A PI draft

From: Cain Brian-BCAIN1 <[email-masked]>
Date: Thu, 3 May 2001 15:29:12 -0500

> -----Original Message-----
> From: James Kempf [mailto:[email-masked]]
> >
> >After taking a quick look at Erik's DTD, it seems to not include any
> >information about position/number/inclusion/exclusion of AVPs within
> >commands.  This would probably line up with your desire not 
...
> >
> 
> As a practical matter, I'd like to see commands and AVPs 
> defined in the
> same file. I believe the working group has decided to recommend
> standardizing AVPs and commands together in extensions, and not

My read of the DTD seemed to indicate that AVPs are defined in the same document as the commands, but whether (and where, and how often) they should be included in commands was absent.  And in keeping with the sense of a "dictionary", I guess that's a good thing.  But at least everything is defined in one place, like you suggest.

> 		jak

---

From: Pat Calhoun <[email-masked]>
Date: Thu, 3 May 2001 13:29:15 -0700

> My read of the DTD seemed to indicate that AVPs are defined in the same document as the commands, but whether (and where, and how often) they should be included in commands was absent.  And in keep…

I don't have a particular problem with including the command codes in the
dictionary, if that is the wish of the WG.

PatC