Subject: [AAA-WG]: Re: [Issue] Proxy Behavior

From: Pat Calhoun <[email-masked]>
Date: Tue, 29 May 2001 08:21:21 -0700

> The current base draft defines "Proxy Server" as a routing proxy, and 
> re-direct is also defined, but other proxy types aren't. The proxy draft, 
> http://www.ietf.org/internet-drafts/draft-ietf-aaa-proxies-01.txt also 
> takes a shot at this, but the terminology is not consistent with the base 
> draft or the transport draft. So at a minimum we need to clean up the 
> terminology and definitions so that all drafts are consistent. 

ok, this is occuring.

>
> However, I think we should probably aim higher. The operation of proxies 
> is so basic that it is hard to understand the base spec without a mental 
> model of how they work. So I think that the proxy draft material needs to 
> be consolidated with the base Proxy material on pp. 59-61, and this should 
> probably be moved closer to the front of the base draft.

I agree, but I wonder if you thought that some of the text in section 2 of
the proxy draft was sufficient. Section 3 describes the problems introduced
by proxies, and I am not really sure that this is really required in the
base protocol spec.

Thoughts?

PatC

---

From: Bernard Aboba <[email-masked]>
Date: Tue, 29 May 2001 22:38:29 -0700 (PDT)

> by proxies, and I am not really sure that this is really required in the

I re-read the proxy draft, as well as the text in Diameter base, and on
reflection, I'm not sure that pulling the proxy draft stuff into base is
the right thing. For one thing, I think that the base draft is more
comprehensive in some aspects (e.g. routing behavior) for what it
covers. And the proxy and base drafts are not always consistent in their
approach. 

So perhaps a better way to go after the definitions have been
clarified, is to complete any missing sections describing the behavior of
the various AAA intermediaries (re-direct, relay, proxy). 

Here is what I think needs to be covered:

1. Introduction to AAA intermediaries
	a. Re-direct
	b. Relays
	c. Proxies
        d. Stateless versus stateful

2. The routing process
	a. NAS as "stub" resolver
	b. Intermediaries as "full" resolver
	c. Organization of the Routing Information Base (RIB)
	d. Sources of routing information (SLP, DNS SRV, manual entries)
	
3. Re-directs
	a. Basic behavior
	b. Operations on routing AVPs
        c. Stateless behavior
        d. Extension advertisement behavior

4. Relay behavior
	a. Operations on routing AVPs
	b. Behavior with respect to encrypted AVPs
        c. Stateless behavior
        d. Extension advertisement behavior

5. Proxy behavior
	a. Operations on routing AVPs (if different from above types)
        b. Proxy-related AVPs (Proxy State, etc.)
	c. Behavior with respect to encrypted AVPs
	d. Stateless versus stateful proxies
	e. Permissible policy operations
	f. Error messages/AVPs/messages (e.g. RFC 2607-style proxy stop)
        g. Interactions with e2e security 
        h. Extension advertisement behavior