Subject: RE: [AAA-WG]: Question on MRI

From: Yiwen Jiang <[email-masked]>
Date: Thu, 3 May 2001 12:38:14 -0400

What about another error condition where none of the extensions that the
peer advertised via DRI message is supported by the receiving server?

> -----Original Message-----
> From: James Kempf [mailto:[email-masked]]
> Sent: Thursday, May 03, 2001 12:22 PM
> To: [email-masked]
> Subject: [AAA-WG]: Question on MRI
> 
> 
> Hi folks,
> 
> We've been discussing when to return an MRI and what the return
> code should be in order to determine when the API should signal
> an error locally.
> 
> It seems like there are clear MRI error returns when an AVP or a
> command is unrecognized. But there doesn't seem to any error code
> or error AVP for the following conditions:
> 
> 	1) Version number is unrecognized.
> 	2) Vendor code is unrecognized.
> 	
> Any ideas about what the appropriate return action
> to to the other peer should be?
> 
> 		jak
> 
>

---

From: Pat Calhoun <[email-masked]>
Date: Thu, 3 May 2001 14:28:18 -0700

> peer advertised via DRI message is supported by the receiving server?

That error condition is handled by the DSI, since it is handle on a per
hop basis, and a proxy could try another server.

> > 	2) Vendor code is unrecognized.

Both of these should also be handled. I will update the -03 spec.

PatC