Subject: [AAA-WG]: [issue] Add extension-id to the Diameter Header

From: Mark Eklund <[email-masked]>
Date: Fri, 18 May 2001 16:24:27 -0400 (EDT)

Submitter name: Mark Eklund
Submitter email address: [email-masked]
Date first submitted: 18-May-2001
Reference: 
Document: Base
Comment type: T
Priority: 2
Section: 3.1
Rationale/Explanation of issue:

* The following don't require either the Auth-Extension-Id nor
  the Acct-Extension-ID: STI STR STA DWR DWA DRI DSI

* The following commands have either the Auth-Extension-ID 
  or Acct-Extension-ID:  ACA ACR API ASI AAA ACI AAR ESSR ESSA 
                         AMA AMR HAA HAR

* In all likelyhood most commands in future extensions will require
  an extension ID.

* Routing uses the extension ID and type (AA or Acct) to make 
  routing decisions.

* The second set of attributes will likely be 99% of diameter traffic.

Requested change:

1. Move the extension ID to be a part of the Diameter Header. 
2. Add 0 extension for STI STR STA DWR DWA DRI DSI
3. Add an C flag to the Diameter Header to state that this is 
   an a(c)counting request.  (If the FAIR flags move to the command 
   code, this should move too.)

This should eliminate two searches for the Externsion-ID avps.

====================================================================

---

From: Mark Eklund <[email-masked]>
Date: Wed, 23 May 2001 17:50:29 -0400 (EDT)

Resolution of issue:

Since you have to also search for the Destination-Realm,
Destination-FQDN, and Username when routing, the efficiency
added by moving the Acct-Extension-Id and Auth-Extension-Id to
the header was outweighed by the inconsistency of having some
routing information in the header and some in AVPs.

This request was denied.

-mark