Subject: RE: [diameter] Re: [AAA-WG]: Re: questions and comments regarding the Diameter A PI draft

From: Cain Brian-BCAIN1 <[email-masked]>
Date: Thu, 3 May 2001 14:53:29 -0500

Mark,

After taking a quick look at Erik's DTD, it seems to not include any
information about position/number/inclusion/exclusion of AVPs within
commands.  This would probably line up with your desire not to have the
message's format validated by the DTD.  What I don't understand is why it's
desirable for this information to be absent.  Is there another file format
that is recommended for describing message formats?  I don't see why XML
wouldn't be able to describe it.  Does the information not architecturally
belong in a dictionary?

-Brian

> -----Original Message-----
> From: Mark Jones [mailto:[email-masked]]
> 
> If the goal is to define a DTD for Diameter dictionaries 
> purely for the
> purpose of attribute encoding/decoding (and NOT for 
> validating the message
> format) then I'm up for it.
> 
> Regards,
>        Mark
> 
> > -----Original Message-----
> > From: [email-masked] 
> [mailto:[email-masked]]On Behalf
> >
> >
> > So do we have any volunteers who want to push this separate draft
> forward?
> >
> > 		jak
> >

---

From: Pat Calhoun <[email-masked]>
Date: Thu, 3 May 2001 12:47:07 -0700

> wouldn't be able to describe it.  Does the information not architecturally

Well, not dictionary in the historical sense. If a Diameter dictionary is more
than just a list of AVPs, then perhaps it should.

My inclination is to leave that information out of the dictionary.

PatC