Subject: Re: [diameter] RE: [AAA-WG]: Extension version

From: Pat Calhoun <[email-masked]>
Date: Fri, 4 May 2001 06:53:35 -0700

On Fri, May 04, 2001 at 09:54:14AM -0400, Mark Jones wrote:
> Are extension versions expected to be backwards compatible? Is support of
> extension versions likely to be contiguous or will devices likely support
> v1 and v3 of an extension but not v2?
> 
> Depending on the answers, we could:
> 
> 1. Get a new id from IANA for a new version of the extension. The DRI must
> contain the extension id for every supported version.
> 
> 2. Replace Extension-ID in the DRI with a new Supported-Extension AVP.
> This would be a Grouped AVP consisting of the Extension-Id and
> Extension-Version AVPs. There would only be one per extension per DRI.
> Could we assume that the Extension-Version will NOT need to be issued by
> IANA since the 'owner' of the Extension-ID will issue them? (Do extensions
> even have a designated 'owner' such as the draft author?)
> 
> If extensions are always backwards compatible, I vote for (2) since it is
> more compact. If extension version support is unlikely to be contiguous
> then (1) is my preference.

I think that it would be really hard to determine at this point, or even
enforce, that future versions of extensions would be "backward" compatible.
If an extension is revised for security purposes, you wouldn't want to
provide both the insecure (for backward compatibility reasons), and the
secure version, right?

PatC

---

From: David Frascone <[email-masked]>
Date: Fri, 4 May 2001 09:14:01 -0500

> provide both the insecure (for backward compatibility reasons), and the

Good Point.

---

From: "Mark Jones" <[email-masked]>
Date: Fri, 4 May 2001 09:54:14 -0400

Regards,
       Mark

---

From: Balazs Czoma <[email-masked]>
Date: Fri, 4 May 2001 08:47:10 -0400

Extension ID identifies only the extension but not the version of an
extension.

For example Mobile IP extension version 2 in the future will probably
support commands/AVPs that are not supported by version 1. Both of them may
support the Base Protocol version 1.

Regards:
Balazs

> -----Original Message-----
> From: Fredrik Johansson [mailto:[email-masked]]
> Sent: Friday, May 04, 2001 08:41
> To: Balazs Czoma; [email-masked]; [email-masked]
> Subject: RE: [AAA-WG]: Extension version
> 
> 
> Hi Balazs
> 
> There is an AVP called ExtensionId AVP which is sent in the
> Device-Roboot-Indication message for this
> 
> /Fredrik
> 
> >-----Original Message-----
> >From: [email-masked] 
> [mailto:[email-masked]]On Behalf
> >Of Balazs Czoma
> >Sent: den 4 maj 2001 14:30
> >To: [email-masked]; [email-masked]
> >Subject: [AAA-WG]: Extension version
> >
> >
> >Hello,
> >
> >It shall be possible to identify/negotiate which extension version
> >a certain
> >application is supporting.
> >
> >I cannot find any hints regarding this in the Base Protocol. 
> I think it
> >would be necessary to define an AVP and procedures for this purpose.
> >
> >Regards:
> >Balazs
> >____________________________________________
> >Balazs Czoma
> >Siemens Telecom Innovation Centre
> >mailto:[email-masked]
> >____________________________________________
> >
> >
>

---

From: "Fredrik Johansson" <[email-masked]>
Date: Fri, 4 May 2001 14:52:02 +0200

Ok, I see what you mean, did not read the question thoroughly
/Fredrik
>From: Balazs Czoma [mailto:[email-masked]]
>Sent: den 4 maj 2001 14:47
>Cc: 'Fredrik Johansson'