Subject: [AAA-WG]: Question on MRI

From: James Kempf <[email-masked]>
Date: Thu, 3 May 2001 09:22:11 -0700 (PDT)

Hi folks,

We've been discussing when to return an MRI and what the return
code should be in order to determine when the API should signal
an error locally.

It seems like there are clear MRI error returns when an AVP or a
command is unrecognized. But there doesn't seem to any error code
or error AVP for the following conditions:

	1) Version number is unrecognized.
	2) Vendor code is unrecognized.
	
Any ideas about what the appropriate return action
to to the other peer should be?

		jak

---

From: Yiwen Jiang <[email-masked]>
Date: Fri, 4 May 2001 13:21:02 -0400

Hi Pat,

> > What about another error condition where none of the 
> extensions that the
> > peer advertised via DRI message is supported by the 
> receiving server?
> 
> That error condition is handled by the DSI, since it is 
> handle on a per
> hop basis, and a proxy could try another server.
I went read through the events listed under DSI, but couldn't find an event
that maps to the scenario above. :(

I'm not sure why this would be related to proxy though... You see, if peer A
tries to connect to a peer B that is completely incompatible (extension
wise) with A, where the Destination-FQDN AVP for the DRI message is peer B.
There will be no proxy involved, since proxying implies different realm,
right? Or did I mis-understood?

To me, this scenario is a valid one, and it is not being handled... Sorry
for asking the same question many times, I'm just a bit confused.. :(

---

From: Yiwen Jiang <[email-masked]>
Date: Fri, 4 May 2001 13:49:51 -0400

Hi again,

Sorry about this email... I was using -02 as a reference... I saw the answer
in -03.

Sorry again.

> -----Original Message-----
> From: Yiwen Jiang [mailto:[email-masked]]
> Sent: Friday, May 04, 2001 1:21 PM
> To: 'Pat Calhoun'
> Cc: 'James Kempf'; [email-masked]
> Subject: RE: [AAA-WG]: Question on MRI
> 
> 
> Hi Pat,
>