Subject: Re: [AAA-WG]: A resolution to the Accounting problem

From: Jari Arkko <[email-masked]>
Date: Thu, 03 May 2001 18:30:04 +0300

Getting back to the separate accounting
issue after a while. Pat wrote the following:

>So, could we not simply create a new AVP
>that is exchanged in the DRI, called
>the Accounting-Extension-Id? It would
>use the same address space as the existing
>Extension-Id AVP, but this would be ONLY
>for accounting purposes. This way a server
>could advertise that it wishes to receive
>both auth and acct messages for MIP ONLY,
>or perhaps only NASREQ and MIP acct messages,
>etc.
>
>This seems very flexible, and an even better
>solution to the old approach (read split acct
>from base) that would not allow a peer to
>advertise that it only wanted accounting
>messages for a particular application.

First, I support schemes to allow separate accounting
flows, based on seeing a number of important
applications that demand it. We really need to
do this!

Then, to your proposal Pat. I think it's good
and a like the dynamic no-configuration-in-the-
normal-case -approach in it. I would like to
add, though, that we also need to state clearly
in 11.0 and 13.1 that separate accounting flows
are allowed. In fact, that's perhaps the first
thing we must do, and then the Accounting-Extension-Id
AVP would be nice addition to it.

Here's some proposed text for the 13.1 case:

13.1  Server Directed Model

   The server directed model means that the device generating
   the accounting data gets information from either the
   authorization server (if contacted) or the accounting server
   regarding the way accounting data shall be forwarded.
   This information includes accounting record timeliness
   requirements.

What to do about the 11.0? Should we state at the beginning
that everything regarding the user sessions relates only
to situations deploying authorization/authentication, but
not when only accounting is used?

Jari

---

From: Pat Calhoun <[email-masked]>
Date: Thu, 3 May 2001 08:48:42 -0700

> applications that demand it. We really need to

good.

> AVP would be nice addition to it.

Right, so we need to take care of both these issues in -03.

>    This information includes accounting record timeliness

that works for me.

> not when only accounting is used?

I believe so. I guess 11.0 needs to support accounting-only applications. 
That means that state machine also needs to support this as well.

PatC