Subject: [AAA-WG]: Sessionless dialogue

From: "Victor Manuel Avila Gonzalez (ECE)" <[email-masked]>
Date: Thu, 10 May 2001 18:40:30 +0200

Following some discussions I would like to clarify this matter 

Only as I hypothesis,

	May I define a Diameter extension to do something that has nothing to do with authentication/authorization or accounting, e.g. to query a database?

	If that were possible, it would be unnecessary to have a session because the server would not be authorizing anything for a period of time. 

	In other words, may I establish a dialogue between two peers without following the user session state machine?

	Regards,

Victor
		e 
		Víctor M. Avila 
		Systems Engineer 
		UMTS/GSM Systems Management 

		Ericsson España, S.A.        Phone: +34 91 339 3050 
		Ombú, 3                            Fax: +34 91 339 2538 
		28045 Madrid, Spain        e-mail: [email-masked]

---

From: Bernard Aboba <[email-masked]>
Date: Thu, 10 May 2001 13:02:58 -0700 (PDT)

DIAMETER is being developed as a AAA protocol. Using it as a database
query transport is therefore out of the scope of applicability, and
ignoring the state machine would probably mean  that multiple
implementations would not interoperate.

As a result, such usage would not be conformant to the specification that
is being developed in this WG.