Subject: RE: [AAA-WG]: Re: questions and comments regarding the Diameter A PI draft

From: James Kempf <[email-masked]>
Date: Wed, 2 May 2001 14:49:51 -0700 (PDT)

OK, it sounds like you are in favor of having a dictionary file regardless
of the language.

Any other comments from WG members? 

		jak

>From: Yiwen Jiang <[email-masked]>
>To: "'James Kempf'" <[email-masked]>, [email-masked], [email-masked], 
[email-masked]
>Subject: RE: [AAA-WG]: Re: questions and comments regarding the Diameter A PI 
draft
>Date: Wed, 2 May 2001 11:08:37 -0400 
>
>Hi James,
>
>> In the current draft, there is no requirement for configuration files
>> for the C library. This is because different operating system 
>> platforms
>> may have different requirements. 
>I can see for the general aaa.conf file, the different OS may have different
>way of describing the file path, but I would argue that the dictionary file
>should exist regardless of the OS.  It is up to the implementor to ensure
>the AVP types are actually supported. This is because there are already
>well-defined AVPs and its types and for some, possible values. 
>
>Or am I missing something here?

---

From: David Frascone <[email-masked]>
Date: Wed, 2 May 2001 17:24:36 -0500

I'd like to have a standardized dictionary.   Preferably in XML.  But, I
think the other configuration files should be left out of the API.

---

From: "Mark Jones" <[email-masked]>
Date: Thu, 3 May 2001 11:51:10 -0400

> think the other configuration files should be left out of the API.

I agree. Standardizing on a dictionary format would be very useful for
device vendors and server implementors alike. I have vague recollections
of a Diameter draft which contained a DTD for dictionaries (an early
version of the API draft maybe?) but since I can't find it, here's one to
use as a starting point.

<?xml version="1.0" encoding="UTF-8"?>

<!ELEMENT DiameterDictionary (BaseDictionary, ExtensionDictionary*)>

<!ELEMENT BaseDictionary (DictionaryEntry*, GroupedDictionaryEntry*)>

<!ELEMENT ExtensionDictionary (DictionaryEntry*, GroupedDictionaryEntry*)>
<!ATTLIST ExtensionDictionary
	ExtensionId ID #REQUIRED
	ExtensionName CDATA #IMPLIED

<!ELEMENT DictionaryEntry EMPTY>
<!ATTLIST DictionaryEntry
	AVPCode CDATA #REQUIRED
	AVPName CDATA #REQUIRED
	AVPDataType (OctetString | Address | Integer32 | Integer64 | Unsigned32 |
Unsigned64 | Float32 | Float64 | Float128) #REQUIRED
	VendorSpecific (Y | N) "N"
	VendorId CDATA #IMPLIED

<!ELEMENT GroupedDictionaryEntry (DictionaryEntry+)>
<!ATTLIST GroupedDictionaryEntry
	AVPCode CDATA #REQUIRED
	AVPName CDATA #REQUIRED
	VendorSpecific (Y | N) "N"
	VendorId CDATA #IMPLIED

I did not include Protected and Mandatory attributes in the dictionary
entries since I assume their value would depend on the context in which
the AVP was being used. Is that correct?

Regards,
       Mark

---

From: Erik Guttman <[email-masked]>
Date: Thu, 3 May 2001 18:45:49 +0200 (MET DST)

> version of the API draft maybe?) but since I can't find it, here's one to

See Appendix A of draft-ietf-aaa-solutions-01.txt (version 1 of my XML)
I attach a new version.  It should've been posted as

  www.diameter.org/diameter.xml

Hopefully that will happen soon.

Work went into it (making sure its reasonably complete, correct, etc)
and there's lots more to do.  Unless its awefully broken, please start 
work from that base.
 
> the AVP was being used. Is that correct?

I think it is important to add the flags - to aid in automatic 
interpretation of what the AVPs *should* contain and how they 
should be stored, reresented on the wire, etc.  It is not the
goal of the XML to describe the wire syntax - but we do want
to capture all of the data which is associated with the particular
AVP type.

Erik

---

From: Erik Guttman <[email-masked]>
Date: Thu, 3 May 2001 19:14:56 +0200 (MET DST)

Mark,
 
> Did you have a spec in mind for your DTD? Base/API?

The initial cut at the DTD is included in the XML.
Please let me know how it can be improved.  If you
think we should separate these into two files, have
at it.

I really appreciate your help moving this forward.

Erik

---

From: "Mark Jones" <[email-masked]>
Date: Thu, 3 May 2001 13:01:32 -0400

Thanks Erik, I knew I'd seen it somewhere.

> and there's lots more to do.  Unless its awefully broken, please start

Of course. I was not proposing a competing schema. Just a starting point
if none existed.

The solutions draft includes the text:
"Once accepted, these solutions will find their way into the relevant
DIAMETER specifications."

Regards,
       Mark