Subject: RE: [AAA-WG]: Re: questions and comments regarding the Diameter A PI draft

From: James Kempf <[email-masked]>
Date: Wed, 2 May 2001 15:55:49 -0700 (PDT)

>> OK, it sounds like you are in favor of having a dictionary 
>> file regardless
>> of the language.
>> 
>> Any other comments from WG members? 
>
>I concur.  A standardized dictionary file syntax could only aid an
>implementor.  Is there any reason why the C API couldn't use an XML
>dictionary file, like the Java portion?  I would imagine there is probably
>no lack of publically available C XML parsers.
>

Well, as a purely practical matter, XML seems to be the logical choice for 
implementability reasons, doesn't it? I haven't investigated XML 
C parser availability in several years, but the last time I looked
there were a couple.

		jak

---

From: David Frascone <[email-masked]>
Date: Wed, 2 May 2001 18:46:25 -0500

Libxml is pretty common, and can be gotten here: http://xmlsoft.org