Subject: Re: [AAA-WG]: WECA 'extending' RADIUS?

From: Tom Weckström <[email-masked]>
Date: Mon, 27 Aug 2001 18:34:56 +0300

Hello folks.

I digged this thread from my ancient-old unread AAA emails.
Has there been any more news on the WISPr and its adventures lately?
Is there any draft specs available inside or outside WECA?
What is the timeframe for this project?
Have anyone of the AAA WG members been in contact or
otherwise involved in the WISPr work?

Best Regards,
		Tom

Glen Zorn wrote:
> 
> John Schnizlein [mailto:[email-masked]] writes:
> 
> > What is the fuss about?
> > The reporter discovered that using RADIUS accounting for 802.11b
> > wireless access exploits the benefits built into it for dial access.
> > Nice of him to notice, but not a technology breakthrough.
> 
> If it was just the reporter it wouldn't bother me, but it seems that WISPr
> itself is on a voyage of discovery through laboriously charted lands...
> 
> >
> > The article does not mention any extensions to RADIUS,
> > it simply describes a new use of RADIUS, especially its capability
> > for global roaming through what we have been calling proxy forwarding.
> > The "tag" the article mentions is just the home domain.
> 
> >From the article:
> 
> "Specifically, WISPr is looking to define a tag that users could tack onto
> their subscriber name.
>                                    ^^^^^^
> The tag will alert any WISP that the user requesting service is "owned" by
> some other provider."
> 
> RFC 2486.
> 
> >
> > The discussion about the importance of billing might create the
> > impression of something new, but it looks like RADIUS accounting to me.
> > And clearinghouse technology for RADIUS accounting has been used for
> > PPP and voice calls, so this is not new either.
> 
> >From the article, again:
> '"The billing systems are key to this," Homan said. "We're extending the
> RADIUS protocol with specific [new] attributes, such as user name, time
> spent online, bytes in or out, and so on. We'll also have information about
> where the user is, through a location code, so we can return site-specific
> services to that user.'
> 
> Of these, the only thing that is new is the "location code" (which poses
> significant privacy issues, BTW).  Note that this quote is from a WISPr
> "spokesman", not the reporter.  Although it's certainly possible that he was
> misquoted, if this statement is close to accurate we have people "extending"
> the RADIUS protocol with "features" already present in it...
> 
> >
> > Considering who has chimed in on this thread,
> > I am now wearing my flame-retardant shorts. ;-)
> >
> > John
> >
> > At 11:22 AM 6/1/2001, Bernard Aboba wrote:
> > >A good argument for "Expert review" as opposed to IANA assignment ;)
> > >
> > >On Fri, 1 Jun 2001, Randy Bush wrote:
> > >> via bert
> > >>
> > >> Story date(time): 05/29/2001(02:18 AM)
> > >> Effort afoot to provide wireless LAN roaming
> > >> InfoWorld Daily News via DowVision
> > >>
> > >> By John Cox, Network World Fusion InfoWorld.com
> >
> >

-- 
        Tom Weckström           Dynamics group
                                Helsinki University of Technology
                                [email-masked]
                                http://www.cs.hut.fi/Research/Dynamics/

---

From: Pat Calhoun <[email-masked]>
Date: Mon, 27 Aug 2001 10:34:22 -0700

> Has there been any more news on the WISPr and its adventures lately?

All I've heard is that they were meeting in Seattle this month, and it
was a closed door meeting (yes, I was told I couldn't attend) :(

> Is there any draft specs available inside or outside WECA?

perhaps within WECA, but not to the outside community.

> What is the timeframe for this project?

don't know

> otherwise involved in the WISPr work?

I've contacted the chair because I was a little surprised with the amount
of press WEP has been gathering that they would foolishly be looking at the
use of RADIUS, when it was clearly documented a couple of years ago how
it was inappropriate for use in roaming networks. I would have thought that
they would be looking at the AAA stuff, but alas, they are not.

If anyone has any insight on whether they are considering our work, and
not RADIUS, I would be most interested.

PatC

---

From: "Glen Zorn" <[email-masked]>
Date: Mon, 27 Aug 2001 21:18:36 -0700

A draft spedc is available to WECA members only.  I attended the last WISPr
meeting.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Tom Weckström
> Sent: Monday, August 27, 2001 8:35 AM
> To: [email-masked]
> Cc: John Schnizlein; Bernard Aboba; Randy Bush; [email-masked]
> Subject: Re: [AAA-WG]: WECA 'extending' RADIUS?
>
>
>
> Hello folks.
>

---

From: Jim Thompson <[email-masked]>
Date: Tue, 28 Aug 2001 09:37:47 -0500

> A draft spedc is available to WECA members only.  I attended the last WISPr

A recent version of the draft WISPr document was sent to me without
any duty of confidentiality, and with markings in the document that
claim that the distribution of said document is unlimited.

   ftp://ftp.smallworks.com/pub/Wisprdraft_0808011.doc (original)
   ftp://ftp.smallworks.com/pub/Wisprdraft_0808011.html (converted)

If you want to know what they're up to.  I have asked them to open their
process several times now, they have steadfastly refused.

Jim

---

From: Bernard Aboba <[email-masked]>
Date: Tue, 28 Aug 2001 09:56:32 -0700 (PDT)

Hmmm. This specification is in the format of an IETF "Best Common
Practice" (BCP) document. Yet it violates RFC 2486, requires
implementation of a location identifier in a format
different from GEOPRIV WG, and assigns RADIUS attribute
numbers without consulting IANA.

If it shows up in IETF last call, my recommendation would be "do not
publish".