Subject: RE: [AAA-WG]: Key disrtibutions in NASREQ...

From: <[email-masked]>
Date: Thu, 2 Aug 2001 17:12:14 -0500

Clients may speak URP. And the keys from AAAH may be delivered
to the user via URP messaging.

-Basavaraj
> 
> Since clients don't speak "Diameter", presumably the AAAH, which is
> participating in the EAP exchange, would send the keys to the user via
> an EAP message.
> 
> No issue is missing.
> 
> PatC
> On Wed, Aug 01, 2001 at 12:38:36PM -0700, Tony Johansson wrote:
> > All,
> > 
> > With NASREQ, if you want to encrypt the keys destined for 
> the client,
> > how is that supposed to be done? Unless I have missed 
> something, there
> > isn't anything describing how this should be done in the NASERQ
> > application draft. The only thing I found is how to encrypt the key
> > between the Diameter Server (AAAH) and the access device 
> (ie NAS), which
> > was simply to use the CMS Security application, but nothing 
> about how to
> > encrypt the key between the AAAH and the client. I will go ahead and
> > submit an issue if this is missing...
> > 
> > /Tony
> > 
>

---

From: Bernard Aboba <[email-masked]>
Date: Thu, 2 Aug 2001 16:28:13 -0700 (PDT)

> to the user via URP messaging.
So does DIAMETER require URP support?

---

From: Pat Calhoun <[email-masked]>
Date: Thu, 2 Aug 2001 16:30:11 -0700

> So does DIAMETER require URP support?

no.

PatC