Subject: [AAA-WG]: [issue] Accounting-Multi-Session-Id AVP in the HAR

From: Michael Chen <[email-masked]>
Date: Mon, 12 Nov 2001 10:51:49 -0800

Submitter name: Michael Chen
Submitter email address: [email-masked]
Date first submitted: 12-Nov-01
Reference:
Document: mobileip-08-alpha2
Comment type: editorial
Priority: 1
Section:  Mobileip 1.2 2.3 2.4

Rationale/Explanation of issue:
   In session 1.2 it state,
   "The Accounting-Multi-Session-Id AVP in the HAR MUST be included in
the HAA,
    which is then forwarded to the AAAH."
   As we can see in Session 2.3 and 2.4 HAR, HAA ABNF format,
    Accounting-Multi-Session-Id AVP is madatory in HAR but option in HAA

Requested change:
 Change Accounting-Multi-Session-Id AVP as option in HAR ABNF Format
 The text in Session 1.2 should be changed to something like
    If the Accounting-Multi-Session-Id AVP is in the HAR, Home Agent
must include
    this Avp in the HAA, which is then forwarded to the AAAH.

---

From: Pat Calhoun <[email-masked]>
Date: Mon, 12 Nov 2001 16:34:55 -0800

The reason why it is optional in the HAA is because a unsuccessful HAA 
wouldn't include this information.

Perhaps the text in 1.2 should instead state:

"The Accounting-Multi-Session-Id AVP in the HAR MUST be included in
an HAA whose Result-Code AVP indicates success, which is then forwarded to
the AAAH".

Thoughts?

PatC

---

From: Michael Chen <[email-masked]>
Date: Tue, 13 Nov 2001 09:59:08 -0800

Looks good to me.