Subject: RE: [AAA-WG]: Issue 215: use of hmac-md5 is incorrect

From: Thomas Panagiotis-PTHOMAS1 <[email-masked]>
Date: Thu, 8 Nov 2001 18:09:52 -0600

Hi Pat,

Please help me understand this issue. Does it mean that the keys
are computed as follows?

MD5/prefix+suffix:
  key = MD5(AAA-key | Key Material | home address | AAA-key)

HMAC-MD5:
  key = HMAC-MD5(AAA-key, Key Material | home address)

HMAC-SHA-1:
  key = HMAC-SHA-1(AAA-key, Key Material | home address)

Thanks,

-Panos

-----Original Message-----
From: Pat Calhoun [mailto:[email-masked]]
Sent: Thursday, October 25, 2001 7:33 PM
To: [email-masked]
Subject: [AAA-WG]: Issue 215: use of hmac-md5 is incorrect

Submitter name: Pat Calhoun
Submitter email address: [email-masked] 
Date first submitted: 25-Oct-01 
Reference:  
Document: base, aaa-keys
Comment type: Technical 
Priority: 1
Section: 7.1
Rationale/Explanation of issue: 

Need to make use that the use of md5 and hmac-md5 is consistent across
both drafts. The latest aaa-keys uses hmac-md5, but uses the incorrect
function prototype (it uses hmac-md5 with a prefix+suffix mode).

---

From: Pat Calhoun <[email-masked]>
Date: Thu, 8 Nov 2001 19:15:10 -0800

yes

PatC