Subject: [AAA-WG]: Issue: Remove Route_Record Avp in all the Answer message

From: Michael Chen <[email-masked]>
Date: Mon, 05 Nov 2001 10:51:20 -0800

Submitter name: Michael Chen
Submitter email address: [email-masked]
Date first submitted: 5-Nov-01
Reference:
Document: base-08-alpha2,  mobileip-08-alpha2,  nasreq-08-alpha2
Comment type: editorial
Priority: 1
Section:  Base: 8.3.2   8.4.2   8.5.2  9.7.2
          Mobileip 2.2  2.4  8.1
          Nasreq 3.1.2  4.2.2  10.1
Rationale/Explanation of issue:
   Only Request Message include Route-Record Avp

Requested change:
  Reove all the Route-Record Avp in all the ABNF Answer message
   (Base: RAA,  STA, ASA, ACA)
   (Mobileip: AMA, HAA, Command Avp Table)
   (Nasreq: AAA, DEA, Command Avp Table)

---

From: Michael Chen <[email-masked]>
Date: Mon, 05 Nov 2001 11:03:02 -0800

Submitter name: Michael Chen
Submitter email address: [email-masked]
Date first submitted: 5-Nov-01
Reference:
Document: mobileip-08-alpha2
Comment type: editorial
Priority: 1
Section:  Mobileip  6.1   6.2  6.7

Rationale/Explanation of issue:
   Reuse the AVP which we have defined.

Requested change:
   Remove 6.7 and replace Mip-Peer-Spi with
Mip-FA-to-MN-Spi/Mip-FA-to-HA-Spi.
   In other words, see below

      MIP-FA-to-MN-Key ::= < AVP Header: 326 >
                           { MIP-FA-to-MN-SPI }
                           { MIP-Algorithm-Type }
                           { MIP-Session-Key }
                         * [ AVP ]

      MIP-FA-to-HA-Key ::= < AVP Header: 328 >
                           { MIP-FA-to-HA-SPI }
                           { MIP-Algorithm-Type }
                           { MIP-Session-Key }
                         * [ AVP ]

---

From: Michael Chen <[email-masked]>
Date: Mon, 05 Nov 2001 11:19:36 -0800

Section:  Mobileip  2.2   2.3   8.1

Rationale/Explanation of issue:
   We need show how to use MIP-Key-Lifetime Avp

Requested change:
   Add [ MIP-Key-Lifetime ] to the ABNF of Home-Agent-MIP-Request
    and AA-Mobile-Node-Answer
   Add MIP-Key-Lifetime to Command Avp Table

                                 +-----------------------+
                                 |      Command-Code     |
                                 |-----+-----+-----+-----+
   Attribute Name                | AMR | AMA | HAR | HAA |
   ------------------------------|-----+-----+-----+-----+
   MIP-Key-Lifetime              | 0   | 0-1 | 0-1 | 0   |