Subject: [Ace] Call for adoption for draft-somaraju-ace-multicast-02

From: "Kepeng Li" <[email-masked]>
Date: Thu, 23 Feb 2017 17:48:11 +0800

Hello all,
 
This note begins a Call For Adoption for draft-somaraju-ace-multicast-02 [1]
to be adopted as an ACE working group item, and added in the charter. The
call ends on Mar 7, 2017.
 
Keep in mind that adoption of a document does not mean the document as-is is
ready for publication. It is merely acceptance of the document as a starting
point for what will be the final product of the ACE working group. The
working group is free to make changes to the document according to the
normal consensus process.
 
Please reply on this thread with expressions of support or opposition,
preferably with comments, regarding accepting this as a work item.
 
Thanks,
 
Kind Regards
Kepeng (ACE co-chair)

[1] https://datatracker.ietf.org/doc/draft-somaraju-ace-multicast/

---

From: Göran Selander <[email-masked]>
Date: Fri, 24 Feb 2017 07:34:00 +0000

I’m in favour of adopting a profile of the ACE framework [1] providing the functionality outlined in this draft.

It was acknowledged in the latest ACE interim that this draft will be transformed into an ACE profile, but currently the mapping to ACE is not very clear:

- Many of the "Requirements on Profiles” (Appendix C of [1]) are not fulfilled, e.g. how is the "resource server" of the ACE framework mapped? Is it the KDC?
- Will the proposed ACE-DTLS profile [2] be used or will we have different methods for authorising DTLS in different profiles?

There has been a lot of discussion of this draft, whereas "non-controversial” profiles of ACE ([2], [3], [4]) has been disregarded in the process. If one profile is being adopted without consideration of other profiles it may lead to duplication of specification, or different mechanisms being defined doing the same thing.

Chairs: What is the plan for coordinating the functionality in the different ACE profiles being adopted?

Göran

[1]  https://tools.ietf.org/html/draft-ietf-ace-oauth-authz
[2] https://tools.ietf.org/html/draft-gerdes-ace-dtls-authorize
[3] https://tools.ietf.org/html/draft-seitz-ace-oscoap-profile
[4] https://tools.ietf.org/html/draft-sengul-kirby-ace-mqtt-tls-profile

From: Ace <[email-masked]<mailto:[email-masked]>> on behalf of Kepeng Li <[email-masked]<mailto:[email-masked]>>
Date: Thursday 23 February 2017 at 10:48
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: Kathleen Moriarty <[email-masked]<mailto:[email-masked]>>, Hannes Tschofenig <[email-masked]<mailto:[email-masked]>>
Subject: [Ace] Call for adoption for draft-somaraju-ace-multicast-02

Hello all,

This note begins a Call For Adoption for draft-somaraju-ace-multicast-02 [1] to be adopted as an ACE working group item, and added in the charter. The call ends on Mar 7, 2017.

Keep in mind that adoption of a document does not mean the document as-is is ready for publication. It is merely acceptance of the document as a starting point for what will be the final product of the ACE working group. The working group is free to make changes to the document according to the normal consensus process.

Please reply on this thread with expressions of support or opposition, preferably with comments, regarding accepting this as a work item.

Thanks,

Kind Regards

Kepeng (ACE co-chair)