Subject: [Ace] EST over CoAP PKCS#10 encoding

From: Julien Vermillard <[email-masked]>
Date: Thu, 30 Mar 2017 16:08:09 +0200

Hi,
I'm currently implementing EST over CoAP.

I wonder why, on simple enrollment, the payload is put in a CBOR binary
string?
I understand why dropping base64, but just putting the PKCS#10 binary in
the CoAP payload is technically enough. What is the benefit of CBOR
encapsulation?

BTW you have a GitHub or something where I can post issues/comments?
--
Julien Vermillard

---

From: peter van der Stok <[email-masked]>
Date: Thu, 30 Mar 2017 09:16:32 -0500

HI Julien,

> I'm currently implementing EST over CoAP.

Great, that is good news.

> 
> I wonder why, on simple enrollment, the payload is put in a CBOR
> binary string?
> I understand why dropping base64, but just putting the PKCS#10 binary
> in the CoAP payload is technically enough. What is the benefit of CBOR
> encapsulation?

Yes, that was a choice. I first had the simple binary in my mind, but 
then I thought that to use CBOR encapsulation would help to distinguish 
from other (future) versions of pkcs#10.
> BTW you have a GitHub or something where I can post issues/comments?

I do have a Github but I am a very conservative user.
> 
> --
> Julien Vermillard
> _______________________________________________
> Ace mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ace

---

From: Julien Vermillard <[email-masked]>
Date: Thu, 30 Mar 2017 16:23:24 +0200

Hi,
Thanks for your answer.

I think content negotiation should be done using the Content-Format option
like other CoAP based protocols.
And would also match the HTTP way to do it.

--
Julien Vermillard

On Thu, Mar 30, 2017 at 4:16 PM, peter van der Stok <[email-masked]>
wrote:

> Yes, that was a choice. I first had the simple binary in my mind, but then
> I thought that to use CBOR encapsulation would help to distinguish from
> other (future) versions of pkcs#10.
>
>>

---

From: peter van der Stok <[email-masked]>
Date: Thu, 30 Mar 2017 09:29:37 -0500

Hi,

Right, will look into it.
The github address is: https://github.com/SanKumar2015/EST-coaps

Peter

Julien Vermillard schreef op 2017-03-30 09:23:
> Hi,
> Thanks for your answer.
> 
> I think content negotiation should be done using the Content-Format
> option like other CoAP based protocols.
> On Thu, Mar 30, 2017 at 4:16 PM, peter van der Stok
> <[email-masked]> wrote:
> 
>> HI Julien,
>> 
>> Yes, that was a choice. I first had the simple binary in my mind,
>> but then I thought that to use CBOR encapsulation would help to
>> distinguish from other (future) versions of pkcs#10.
>> 
>>> https://www.ietf.org/mailman/listinfo/ace [1]
> 
> 
> 
> Links:
> ------
> [1] https://www.ietf.org/mailman/listinfo/ace