Subject: [Ace] IKEA uses CoAP and DTLS for their smart lights

From: Ludwig Seitz <[email-masked]>
Date: Fri, 28 Apr 2017 15:31:20 +0200

FYI

https://mjg59.dreamwidth.org/47803.html

/Ludwig
-- 
Ludwig Seitz, PhD
Security Lab, RISE SICS
Phone +46(0)70-349 92 51

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 28 Apr 2017 15:44:51 +0200

> https://mjg59.dreamwidth.org/47803.html

Yes.

There has been a flurry of activity in the tinydtls and libcoap projects in the last weeks, as these seem to be the implementations of choice to talk to the devices (if you are not using Californium).
Lots of hackers/makers are now putting libcoap support into their various home hub/home bridge projects.
This also has further increased the mindshare of LWM2M, which the IKEA application is based on.

The interesting part is that the whole setup makes IKEA TRADFRI a quite secure implementation of IoT, compared to what’s on the market today.
Maybe we are witnessing the tipping point towards the real Internet of Things.

Grüße, Carsten