Subject: Re: [Ace] Proof-of-Possession Key Semantics for CBOR Web Tokens (CWTs)

From: Michael Richardson <[email-masked]>
Date: Mon, 22 May 2017 14:16:49 -0400

Come to the discussion late, cleaning my inbox.

section 3 says:

     "The value of the cnf claim is a JSON object and the members of that object
     identify the proof-of-possession key."

And somehow, I think that the claim ought to be a CBOR object?
Same for the paragraph of 3.4.

I found the next paragraph about whether the sub or iss is the presenter to
be obtuse.  Maybe it is lacking some ACE RS/C/AS terminology?

I am trying to figure out if the nonce-full mechanism that we describe
in draft-ietf-anima-bootstrapping-keyinfra or anima-voucher, and later to
be re-interpreted as CWT in draft-ietf-6tisch-dtsecurity-secure-join should
reference RFC 7800 and this document instead.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Mike Jones <[email-masked]>
Date: Mon, 22 May 2017 18:34:52 +0000

Thanks for the catch. Yes, this should be a CBOR map. I failed to make this change when transforming RFC 7800 into this draft. I'll correct it in the next version.

– Mike

From: Michael Richardson<mailto:[email-masked]>
Sent: Monday, May 22, 2017 2:19 PM
To: Mike Jones<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Ace] Proof-of-Possession Key Semantics for CBOR Web Tokens (CWTs)

section 3 says: