Subject: [Ace] Early warning: Rewrite of vanderstok-ace-coap-est

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 13 Nov 2017 02:55:21 +0000

Hi all,

I had provided comments on the EST over CoAP document in the past. Unfortunately, my recommendations have been ignored and instead the document went into the other direction getting more complex with every draft version.

I need something that just allows me to run EST over CoAP - nothing more. As a result, I don't want profiling, don't want normative dependency to the ANIMA work, and don't want any relationship to IEEE 802.15.4. EST over CoAP should be able to run in a variety of context and over a number of networks.

For this purpose I am planning to write a new draft during this week that covers only one thing, namely carrying EST over CoAP without any profiling and without any new functionality.
If someone is interested in collaborating with me please drop me a note.

Ciao
Hannes

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: peter van der Stok <[email-masked]>
Date: Mon, 13 Nov 2017 04:18:18 +0100

Hi Hannes,

thanks for the early warning.
Looking forward to reading your version.
Let's see afterwards how we continue ( one document or two complementary 
documents)

cheerio,

peter

Hannes Tschofenig schreef op 2017-11-13 03:55:
> Hi all,
> 
> I had provided comments on the EST over CoAP document in the past.
> Unfortunately, my recommendations have been ignored and instead the
> document went into the other direction getting more complex with every
> draft version.
> 
> I need something that just allows me to run EST over CoAP - nothing
> more. As a result, I don't want profiling, don't want normative
> dependency to the ANIMA work, and don't want any relationship to IEEE
> 802.15.4. EST over CoAP should be able to run in a variety of context
> and over a number of networks.
> 
> For this purpose I am planning to write a new draft during this week
> that covers only one thing, namely carrying EST over CoAP without any
> profiling and without any new functionality.
> 
>   IMPORTANT NOTICE: The contents of this email and any attachments are
> confidential and may also be privileged. If you are not the intended
> recipient, please notify the sender immediately and do not disclose
> the contents to any other person, use it for any purpose, or store or
> copy the information in any medium. Thank you.
> _______________________________________________
> Ace mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ace

---

From: "Panos Kampanakis (pkampana)" <[email-masked]>
Date: Mon, 13 Nov 2017 04:13:34 +0000

Hi Hannes,
I think the current draft offers that. The BRSKI EST APIs are not mandatory to implement by any means. The bindings of just the EST (RFC7030) APIs explained in the doc would suffice. If you are saying that the current doc is too complicated, may that is something that can be addressed. If you are saying that there need to be two docs, one for pure EST and one for the BRSKI EST messages, maybe it makes sense. The list can chime in on that.
Looking forward to your draft.
Panos

From: Ace [mailto:[email-masked]] On Behalf Of Hannes Tschofenig
Sent: Sunday, November 12, 2017 9:55 PM
To: [email-masked]
Subject: [Ace] Early warning: Rewrite of vanderstok-ace-coap-est

Hi all,

Ciao
Hannes

---

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 13 Nov 2017 05:40:08 +0000

I disagree with you, Panos.

The normative reference, include among other things, [I-D.ietf-anima-bootstrapping-keyinfra].

As you will see with my write-up there is a way to offer EST over CoAP support without creating any such dependency. This will allow for generic uses of EST over CoAP, very much in spirit of the original spec EST spec

Ciao
Hannes

From: Panos Kampanakis (pkampana) [mailto:[email-masked]]
Sent: 13 November 2017 12:14
To: Hannes Tschofenig; [email-masked]
Subject: RE: Early warning: Rewrite of vanderstok-ace-coap-est

Hi Hannes,

Hi all,

Ciao
Hannes