Subject: [addr-select-dt] Status of address selection related drafts?

From: Tim Chown <[email-masked]>
Date: Mon, 14 Mar 2011 14:02:33 +0000

Hi,

Just a quick mail to ask thoughts on what remains to be done in Prague for address selection drafts.

Update to RFC3484 Default Address Selection for IPv6
draft-ietf-6man-rfc3484-revise-02
- looks good to WGLC?

Distributing Address Selection Policy using DHCPv6
draft-ietf-6man-addr-select-opt-00
- looks good to WGLC?

Solution approaches for address selection problems
draft-ietf-6man-addr-select-sol-03
- useful discussion of the classes of solutions
- currently expired

Considerations for IPv6 Address Selection Policy Changes
draft-ietf-6man-addr-select-considerations-02
- justification for the approaches taken for 3484 updates and dhcp-based policy distribution solution
- currently expired - I will refresh it to active status - is it worth publishing?

Considerations of Address Selection Policy Conflicts
draft-arifumi-6man-addr-select-conflict-02
- useful discussion of how such conflicts could be handled
- currently expired

It's also worth noting that draft-troan-multihoming-without-nat66-00, which we felt included many of the issues we were looking at in this DT, offered one way to take the work forward, but it has also expired.   This draft cites the DHCP policy draft.

So as it stands we look set to get the 3484-bis and DHCP policy drafts WGLC'd, but the other docs are all likely to lapse unless we decide there is useful discussion captured in them worth publishing.   

Did I miss any drafts? Thoughts?

Tim

---

From: Arifumi Matsumoto <[email-masked]>
Date: Thu, 17 Mar 2011 14:16:30 +0900

Hi,

> draft-ietf-6man-rfc3484-revise-02

Yes, I think WGLC on this item should be started at Prague.

> draft-ietf-6man-addr-select-opt-00

WGLC in pararel with rfc3484-revise should be fine.

> - useful discussion of the classes of solutions

I feel, this time, the above two documents should be focused.

> - currently expired - I will refresh it to active status - is it worth publishing?

If the first 2 documents go well, this document needs not necessarily published.

> - useful discussion of how such conflicts could be handled

This item explored advanced way of policy merging.
But, basically we've reached a conclusion that the any kinds of policy merging 
involves conflict, so the policy merging should be avoided by default.

> It's also worth noting that draft-troan-multihoming-without-nat66-00, which we felt included many of the issues we were looking at in this DT, offered one way to take the work forward, but it has a…

This document was accepted as wg item in v6ops.

> Did I miss any drafts? Thoughts?

Thanks for summarizing these up.

> 
> Tim
> 
> _______________________________________________
> addr-select-dt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/addr-select-dt