Subject: [addr-select-dt] draft-ietf-6man-rfc3484-revise-02

From: Arifumi Matsumoto <[email-masked]>
Date: Wed, 9 Mar 2011 19:38:51 +0900

All,

here attached the -02 version of RFC 3484 revision work.
I'm very sorry about the long suspension on this item,
despite your commitment on it.

If you can comment on it, I think I can incorporate it
before the cut-off.

Kindest regards,

--
Arifumi Matsumoto
  NGN System Architecture Project
  NTT Service Integration Laboratories
  E-mail: [email-masked]
  TEL +81-422-59-3334 FAX +81-422-59-6364

---

From: Tim Chown <[email-masked]>
Date: Wed, 9 Mar 2011 11:06:20 +0000

Hi,

This is very important.  I'll take a look tonight hopefully.

What about the dhcp draft?

--
Tim

On 9 Mar 2011, at 10:38, Arifumi Matsumoto <[email-masked]> wrote:

> <draft-ietf-6man-rfc3484-revise-02.txt>
> 
> --
> Arifumi Matsumoto
> _______________________________________________
> addr-select-dt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/addr-select-dt

---

From: Tim Chown <[email-masked]>
Date: Fri, 11 Mar 2011 00:16:31 +0000

Hi,

I have edited the txt file, largely to tidy up the English in a few places.   There's nothing I disagree with in the text.   So you could diff the file with yours to see if you want to apply the changes.

Some other comments:

We don't cite draft-ietf-6man-addr-select-sol-03 or draft-ietf-v6ops-addr-select-req-07 - would this be worth doing?    Should probably have a final pass through those to ensure everything is captured in the 3484 bis text?

Note the address selection considerations reference is now a WG item: draft-ietf-6man-addr-select-considerations-02; this needs updating in your text.

I found this sentence a little clumsy:
"When a destination address DA, DB, and the source address of DA
   Source(DA) are on the same subnet and Source(DA) == Source(DB), DNS
   round robin load-balancing cannot function. "
Maybe it can be written a little more clearly?

Quite a few of the citations (reference labels) appear after the full stops in sentences, not before.   Corrected in the attached text.

Do we want to add a rule for 2001:db8:: ?     If 3ffe:: is in there...

And I would still love to see a way to add a rule to put privacy address preference in there.   This would be a great way to help answer the concerns in long email threads currently running in other lists :)

Tim

---

From: Arifumi Matsumoto <[email-masked]>
Date: Thu, 17 Mar 2011 11:31:46 +0900

Tim,

> I have edited the txt file, largely to tidy up the English in a few places.   There's nothing I disagree with in the text.   So you could diff the file with yours to see if you want to apply the ch…

Thank you for your review and comments.
I'm sorry that I could not addressed all issues in -02.

> We don't cite draft-ietf-6man-addr-select-sol-03 or draft-ietf-v6ops-addr-select-req-07 - would this be worth doing?    Should probably have a final pass through those to ensure everything is captu…

The rfc3484-revise does not mention about the whole problem related to address selection, but it does focus on the present issues for RFC 3484 itself.

It may be helpful if we mention about the whole problem for the readers to grasp the big picture, too. I'll put some texts about them in the introduction, where problem statement and requirement, and the solution documents will be referenced.

> Note the address selection considerations reference is now a WG item: draft-ietf-6man-addr-select-considerations-02; this needs updating in your text.

Applied.

> Maybe it can be written a little more clearly?

Sorry, writing clear english is always an assignment for me. X(

How about the following text ?

"When a destination address DA, DB and the source address S are on the
same subnet, the present longest matching rule always choose the same
destination address."

> Quite a few of the citations (reference labels) appear after the full stops in sentences, not before.   Corrected in the attached text.

I hope all were corrected.

> Do we want to add a rule for 2001:db8:: ?     If 3ffe:: is in there...

I do not know.
Do we see 2001:db8:: addresses on a real packets ?

> And I would still love to see a way to add a rule to put privacy address preference in there.   This would be a great way to help answer the concerns in long email threads currently running in othe…

Do you think it should be addressed in RFC 3484 revision, or in the policy distribution draft, or totally different way ?

Kindest regards,

> 
> Tim
> 
> <draft-ietf-6man-rfc3484-revise-02-tc.txt>
>

---

From: Ruri Hiromi <[email-masked]>
Date: Fri, 25 Mar 2011 14:44:01 +0900

Hi list,

I did only read original Arifumi's document.

I also feel DA,DB and S description is a little bit confusing.
My understanding is here;

             DA(s,d)         DB(s',d')

              |              |
 subnet P(S,D) -------------------------

 prefix P is same for DA,DB and it can be described as s == s'. Is this
true? If yes, how about write their network factor into small letter?

But as for DNS round robin, current major OSs follows RFC3484 Rule9 and
neglect DNS information. RFC3483 rule9 is first and if someone wants to
utilize DNS round robin, 3484 policy table(disable subnet
prioritization) can be changed is the better indication I suppose.

Informative Referece; http://support.microsoft.com/kb/968920

Don't you put some note above that?

-- 
----------
Ruri Hiromi
INTEC Systems Institute, Inc.

---

From: Arifumi Matsumoto <[email-masked]>
Date: Fri, 25 Mar 2011 15:23:34 +0900

Hiromi-san,
thank you for your comment.

First of all, you are commenting about the following rule, right ?

> true?

I failed to see what DA(s,d) means here.
Also the meaning of P(S,D).

> If yes, how about write their network factor into small letter?

I appreciate if you can elaborate on this.

> prioritization) can be changed is the better indication I suppose.

What you mean here is that you want a switch to enable/disable rule 9, 
that is the longest matching rule, and want to switch on/off it remotely, right ?

My understanding about this issue of rule 9 is,
- This is basically a remote side policy.
  That is, it should be a server side policy, whether rule 9
  is preferable or not.
- The local network administrator basically does not care about this
  behavior of destination address selection, as far as the destination
  site is not in his administration site. 

So, I suppose there is not so much need of local switch of rule 9.
What we need to discuss is what the universal rule about longest
match should be.

> Don't you put some note above that?

Thank you for information.
I do not quite understand what this configuration does.
If if I put this in my registry, my machine disables rule 9 ?
I do not think such a thing is fully described by the word
"subnet prioritization" in this page.

Regards,

--
松本 存史 <[email-masked]>
 NTTサービスインテグレーション基盤研究所
 次世代ネットワーク方式SEプロジェクト
  ネットワークアーキテクチャグループ
  TEL 0422-59-3334  FAX 0422-59-6364

---

From: Brian Haberman <[email-masked]>
Date: Fri, 25 Mar 2011 07:42:59 -0400

All,
     This discussion should be occurring on the 6man mailing list.  As
the chairs noted a few months ago, the DT has completed its task and the
resulting documents should be discussed with the entire WG.  Please move
this discussion to the [email-masked] mailing list so that the entire WG
can participate.

Regards,
Brian & Bob

---

From: Arifumi Matsumoto <[email-masked]>
Date: Sat, 26 Mar 2011 00:27:37 +0900

Thanks, Brian.

Technical discussion should be moved to 6man ML.

Let me start another non-technical coordination.
I'lll prepare some slides for Monday session.
Suresh, or Tim,
please make a presentation for me.
Please change the slides anyway you like.

Kindest regards,

---

From: Arifumi Matsumoto <[email-masked]>
Date: Sun, 27 Mar 2011 18:39:06 +0900

I put together slides for Monday.
Please take a look at the attached file.

It looks Tim did not respond to me, so
Suresh may be the only person who is in Prague.

If you have any question about the slides, please ask me.
I'll try to be available on jabber.
[email-masked]

Kindest regards,

---

From: Bob Hinden <[email-masked]>
Date: Sun, 27 Mar 2011 11:53:01 +0200

Arifumi-san,

Thanks for the slides.

Is Suresh going to do the presentation?

Thanks,
Bob

On Mar 27, 2011, at 11:39 AM, Arifumi Matsumoto wrote:

> <ietf80-rfc3484.ppt>

---

From: Tim Chown <[email-masked]>
Date: Sun, 27 Mar 2011 11:02:28 +0100

Hi Arifumi,

I was about to write some slides this morning, apologies for not confirming that before.

I will be in Prague, so can present the slides if necessary.  Let me know Suresh.

I'll review the slides now and maybe add one or two slides at the front listing the status of the 5 related drafts that I posted to the list a couple of weeks ago.  The 15 minute slot should be fine.

And as Brian says, we should have all future discussion on the 6man list.

Tim

---

From: Bob Hinden <[email-masked]>
Date: Sun, 27 Mar 2011 12:05:31 +0200

Tim,

Please let me know who will give the talk and send me any updated slides later today.

Thanks,
Bob

---

From: Tim Chown <[email-masked]>
Date: Sun, 27 Mar 2011 11:30:52 +0100

Hi all,

Here's a version of the slides including two slides to clarify where all the drafts stand (i.e. we'd like to push the 3484-bis and DHCP distribution drafts to WGLC together, and the other drafts can expire, with v6ops taking up multihoming-wthout-nat66).     Also minor tweaks to the other slides.

I am fine to present, but also very happy for Suresh to do so.

Tim

---

From: Arifumi Matsumoto <[email-masked]>
Date: Sun, 27 Mar 2011 19:39:52 +0900

Tim,
thank you!

I agree it's nice to add your slides to the front to help people understand the whole story.

On 2011/03/27, at 19:30, Tim Chown wrote:

> <ietf80-rfc3484-update.ppt>
>

---

From: Suresh Krishnan <[email-masked]>
Date: Sun, 27 Mar 2011 07:36:40 -0400

Hi Tim,
  Great intro slides. If you will be there, I prefer that you present because I will be the minute taker for the 6man meeting.

Thanks
Suresh

> -----Original Message-----
> From: Tim Chown [mailto:[email-masked]] 
> Sent: Sunday, March 27, 2011 12:31 PM
> To: Bob Hinden
> Cc: Arifumi Matsumoto; Suresh Krishnan; [email-masked]
> Subject: Re: [addr-select-dt] draft-ietf-6man-rfc3484-revise-02
> 
> Hi all,
> 
> Here's a version of the slides including two slides to 
> clarify where all the drafts stand (i.e. we'd like to push 
> the 3484-bis and DHCP distribution drafts to WGLC together, 
> and the other drafts can expire, with v6ops taking up 
> multihoming-wthout-nat66).     Also minor tweaks to the other slides.
>

---

From: Bob Hinden <[email-masked]>
Date: Sun, 27 Mar 2011 13:50:05 +0200

OK, I will assume Tim is the speaker.

Thanks,
Bob

---

From: Tim Chown <[email-masked]>
Date: Mon, 28 Mar 2011 10:10:33 +0200

So just a quick update from this morning's presentation.

* On privacy extensions, two people (one was Dave Thaler) made firm statements that policy should only be able to be set with appropriate auth
* On ULAs, Brian Carpenter observed the complexity of use of ULAs between multiple sites
* There were no new issues raised.
* There was agreement we can move to WGLC once the two outstanding issues are sorted.

So I think we should now progress two separate issue threads on the 6man list for privacy and ULAs for 3484-bis, close those and request WGLC on both.

I had confirmation from Ralph that the dhc option would be WGLC'ed in 6man and flagged in dhc for interested people to check the 6man last call.

So we may finally be close to finishing the work :)

Tim