Subject: Re: open issues in agentX MIB

From: "Smitha Gudur" <[email-masked]>
Date: Fri, 31 Jul 1998 15:29:41 PDT

>From [email-masked] Fri Jul 31 15:03:58 1998
>Received: from mithatch-ultra.cisco.com (mithatch-ultra.cisco.com 
[171.69.50.33]) by pleco.cisco.com (8.8.4-Cisco.1/8.6.5) with ESMTP id 
PAA29758; Fri, 31 Jul 1998 15:02:54 -0700 (PDT)
>Received: from cisco.com (localhost [127.0.0.1]) by 
mithatch-ultra.cisco.com (8.8.5-Cisco.2-SunOS.5.5.1.sun4/CISCO.WS.1.2) 
with ESMTP id PAA12637; Fri, 31 Jul 1998 15:02:54 -0700 (PDT)
>Sender: [email-masked]
>Message-ID: <[email-masked]>
>Date: Fri, 31 Jul 1998 15:02:53 -0700
>From: Mike Thatcher <[email-masked]>
>X-Mailer: Mozilla 4.03C-CISCOENG [en] (X11; U; SunOS 5.5.1 sun4u)
>MIME-Version: 1.0
>To: Smitha Gudur <[email-masked]>
>Subject: Re: open issues in agentX MIB
>References: <[email-masked]>
>Content-Type: text/plain; charset=us-ascii
>Content-Transfer-Encoding: 7bit
>
>Smitha Gudur wrote:
>
>> Hi, Mike,
>>
>> There is relationship between sessionID defined in RFC2257 and
>> the agentxSessionIndex.
>>
>> Current description for agentxSessionIndex includes:
>>
>> "Index values assigned for a given registration are constant for the
>> lifetime of this table."
>>
>> is inappropriate and needs to be removed.
>>
>> The other part of the description is consistent with the RFC.
>>
>> "A unique index for the subagent session. Note that if a
>> subagent's session with the master agent is closed for
>> any reason its index should not be re-used, therefore,
>>
>
>However the RFC does not restrict the reuse of sessionID.
I agree, it does not restrict the usage but says that it should
be globally unique over all its sessions if master agent supports
multiple transports. 

The description has to be changed to make it unique across all the 
sessions that the master agent supports instead of saying it cannot be 
reused. 

smitha

>MikeT

______________________________________________________
Get Your Private, Free Email at http://www.hotmail.com

---

From: Randy Presuhn <[email-masked]>
Date: Fri, 31 Jul 1998 16:43:08 -0700 (PDT)

Hi - 

> Date: Fri, 31 Jul 1998 18:58:35 -0400
> To: Martin Jacobsson <[email-masked]>
> From: Bob Natale <[email-masked]>
> Cc: Smitha Gudur <[email-masked]>, [email-masked]
> References: <[email-masked]>
> 
> >At 7/31/98 11:56 PM, Martin Jacobsson wrote:
> 
> Hi Martin,
> 
> >Section 2, goal 4 says:
> >
> >- Provide statistics about the protocol operation such
> >as the number of packets to and from each subagent
...
> First, let me note that there is considerable sentiment to
> keep this MIB relatively minimal.
...

A counter-proposal to consider: delete goal 4 in section 2.

 -----------------------------------------------------------------------
 Randy Presuhn           Email: [email-masked]      http://www.bmc.com     
 Voice: +1 408 616-3100  BMC Software, Inc.           965 Stewart Drive
 Fax:   +1 408 616-3101  Sunnyvale, California 94086  USA
 -----------------------------------------------------------------------
 In accordance with the BMC Communications Systems Use and Security
 Policy, I explicitly state that although my affiliation with BMC may be
 apparent, implied, or provided, my opinions are not necessarily those
 of BMC Software and that all external representations on behalf of
 BMC must first be cleared with a member of "the top management team."
 -----------------------------------------------------------------------