Subject: Re: AbentX MIB: maxTimeOut issue

From: Randy Presuhn <[email-masked]>
Date: Tue, 6 Jul 1999 17:23:35 -0700 (PDT)

Hi -

> Date: Mon, 05 Jul 1999 12:50:58 -0400
> To: "Bert Wijnen" <[email-masked]>, [email-masked]
> From: Bob Natale <[email-masked]>
> Subject: AbentX MIB: maxTimeOut issue
> Cc: [email-masked]
...
> Right...I think we can just re-state the semantics of the
> agentxDefaultTimeout object as applying a maxTimeOut value
> as well.  In other words, if a sub-agent does not specify
> a specific timeout value, the agentxDefaultTimeout value will
> be applied to requests to that sub-agent.  If a sub-agent does
> supply a specific timeout value and it is *less than* the
> agentxDefaultTimeout value, then it will be used for such
> requests.  Otherwise, if it is higher than agentxDefaultTimeout,
> then it will simply be retained for use should the value of
> agentxDefaultTimeout be administratively increased to a value
> higher than the sub-agent's specific timeout value.
...

PLEASE don't change the default to behave as a maximum.
If you're convinced of the value of an agent-wide upper
bound that can be controlled through SNMP, then add a
new object dedicated to that function.

 ------------------------------------------------------------------------
 Randy Presuhn           [email-masked]     http://www.bmc.com/
 Voice: +1 408 616-3100  BMC Software, Inc.           965 Stewart Drive
 Fax:   +1 408 616-3101  Sunnyvale, California 94086  USA
 ------------------------------------------------------------------------
 Any relationship between my opinions and BMC's is probably coincidental.
 ------------------------------------------------------------------------

---

From: Mike Daniele <[email-masked]>
Date: Wed, 07 Jul 1999 11:05:18 -0400

> new object dedicated to that function.

I think the 3 timeout objects defined in the -03 MIB draft are correctly defined.

I also think, as stated in previous mail, that we need to loosen the wording in the
protocol spec around how timeouts are handled.  But that wording should not state
that the master's default must be an upper bound.

(I just think that some master agent implementations will always honor
the subagent's timeout values, and some won't, due to implementation
considerations or other unforeseen external circumstances [like SNMP over TCP,
or SNMPv4 messages that include a timeout value ...]).

Mike