Subject: Sub-Agent Status ....

From: [email-masked]
Date: Thu, 12 Aug 1999 19:50:02 +0530

Hi ,
     Is there any way to check out from SNMP manager 
whether associated sub-agent is up/down. Like for 
checking the status of Master,  sub-agent sends Ping 
PDU , how to achieve the reverse ? As in Agentx MIB 
also there is support for information which will be replied
by Master itself mean to say that if i query for any OID 
related to Agentx MIB, master from its database will reply
 to it without consulting the sub-agent. So i am not left with
any OID that can get me status of Sub-agent.

Thanks,
Ravinder.

PS: I have added line break in mail message , if still
readability problem is there , let me know. Also there is 
some problem with POP3 mail server so i can not do
anything for mail address UUCP style display.

---

From: Mike Daniele <[email-masked]>
Date: Thu, 12 Aug 1999 15:23:43 -0400

> any OID that can get me status of Sub-agent.

A subagent, its sessions, and its registrations are represented in various
rows of the various tables in the AgentX MIB.  This tells you the status
(from the standpoint of the master agent) of all subagents, as well as
the state of their configurations.

If a connection exists, the subagent has connected.

If sessions exists for that connection, the subagent has sent the AgentX Open
pdu.

If registrations exist, ...

The master agent should update its mib data when subagents
unregister, close sessions, disconnect, etc.

Hope this helps,
Mike

---

From: Matt White <[email-masked]>
Date: Fri, 13 Aug 1999 10:39:30 -0400

I think the question was:  How do you tell if a particular subagent is
responsive?

Off the top of my head, I cannot think of a generic way of doing this
besides having the master make a query against a registered OID.  Not too
pretty though I am not sure just how big a problem this is in real life.

-Matt

--On Thursday, August 12, 1999, 3:23 PM -0400 Mike Daniele
<[email-masked]> wrote:

> If sessions exists for that connection, the subagent has sent the AgentX
> Open pdu.
>

---

From: [email-masked]
Date: Fri, 13 Aug 1999 18:24:58 -0400 (EDT)

Hi,
    Ya my question was absolutely the one mentioned
by Matt. But as per Matt response i think i should
stop considering in this direction :-). Mike replied 
my question to some extent but problem may occur if
interaction between Master and Sub-agent is not through 
TCP but through IPC say message Queues , i prefer IPC
when Master and sub-agent both are on same board/Processor.

Thanks & Regards,
Ravinder.