Subject: Re: Thanks & Confusion ........

From: Randy Presuhn <[email-masked]>
Date: Thu, 5 Aug 1999 15:18:44 -0700 (PDT)

Hi -

> Date: Thu, 05 Aug 1999 17:56:34 -0400
> From: Mark Ellison <[email-masked]>
> To: Randy Presuhn <[email-masked]>
> CC: [email-masked], Mark Ellison <[email-masked]>,
>         Mike Daniele <[email-masked]>
> Subject: Re: Thanks & Confusion ........
> References: <[email-masked]>
...
> I've re-read RFC 2257, sxn 7.1.5 (4).  My interpretation still comes up as
> 'duplicate', not 'overlapping'.  Specifically, the first paragraph of RFC 2275, sxn
> 7.1.5. (4) says:
> 
>       If r.region (or any of its set of Object Identifiers, if r.range
>       is non-zero) is exactly the same as any currently registered value
>       of r.region (or any of its set of Object Identifiers), this
>       registration is termed a duplicate region.
> 
> Would you interpret this "operative text" differently?  I also think the distinction
> of 'dulplicate' and 'overlapping' was maintained across 2257 to rfc-update-00.

They're defined differently in the two documents.

In the text you quote, "r.region" of the registration request must be
"exactly the same" as a current registration.  For the sequence of
registrations Dave Harrington described, this would not be true, and
the following paragraph in 7.1.5 would apply, resulting in the
registration being classified as "overlapping".

The corresponding text in the draft defines "duplicate" so that it
includes this case, thus avoiding the conundrum in dispatching.

 ------------------------------------------------------------------------
 Randy Presuhn           [email-masked]     http://www.bmc.com/
 Voice: +1 408 616-3100  BMC Software, Inc.           965 Stewart Drive
 Fax:   +1 408 616-3101  Sunnyvale, California 94086  USA
 ------------------------------------------------------------------------
 Any relationship between my opinions and BMC's is probably coincidental.
 ------------------------------------------------------------------------

---

From: Bob Natale <[email-masked]>
Date: Thu, 05 Aug 1999 19:16:13 -0400

>At 8/5/99:06:18 PM, Randy Presuhn wrote:

Hi Randy,

Too bad this thread got stuck on this particular "Subject:" label!

Mark said:
>>'duplicate', not 'overlapping'.  Specifically, the first paragraph of RFC 
>>2275, sxn 7.1.5. (4) says:
>> 

Randy said:
>"exactly the same" as a current registration.

I read the parenthetical comment "(or any of its set of Object Identifiers)"
as covering the set of ranged OIDs...such that:

>For the sequence of registrations Dave Harrington described,

S3 would have definitely been a duplicate of one of S2 ranged registrations.

>includes this case, thus avoiding the conundrum in dispatching.

Good...all's well that ends well.

Cordially,

BobN
------------ ISO 9001 Registered Quality Supplier -----------
Bob Natale         | ACE*COMM              | 301-721-3000 [v]
Dir, Net Mgmt Prod | 704 Quince Orchard Rd | 301-721-3001 [f]
[email-masked]| Gaithersburg MD 20878 | www.acecomm.com
------------- Free downloads at www.winsnmp.com -------------