Subject: Timeout .....

From: [email-masked]
Date: Wed, 18 Aug 1999 02:58:27 +0530

Hi,

	I am finding following issues  while implementing Agentx , may be implementation specific but still to be on safe side i want a bit clarification :
	
1. My subagent has sent any pkt (open/index allot/Reg ) now problem is how long the sub-agent should wait for response from Master assuming there is no pkt loss as connection oriented but still Master may be overloaded and may take time in responding , this blocks my sub-agent con-current PDU processing if it waits for particular PDU's reponse sent by it to Master. If answer to this is you should have timer for getting response, then managing timer will be a overhead for every PDU sent.

2. The sub-agent has allocated index before registering and is mentioned in RFC if response for this Registration is "duplicateRegistration" then deallocate the index. In this scenario index-deallocation is clear , but say i have sent an unregister PDU for a fully qualified row in a table , now  shall the sub-agent should send corresponding index-deallocation PDU to free the index for that row or Master will take care of it. If Master then RFC also says that while allocating index master need not aware of type of index , so master is finding it difficult to free by seeing just the OID.

Thanks & Regards,
Ravinder.

---

From: Randy Presuhn <[email-masked]>
Date: Tue, 17 Aug 1999 16:31:15 -0700 (PDT)

Hi -

(I re-formatted the original message for readability)

> From: [email-masked]
> From: future.futsoft.com!ravinderv (Ravinder Verma)
> To: [email-masked] ('agentx')
> Cc: [email-masked] ('mike')
> Subject: Timeout .....
> Date: Wed, 18 Aug 1999 02:58:27 +0530
> 
> Hi,
> 
> 	I am finding following issues  while implementing Agentx , may
> 	be implementation specific but still to be on safe side i want
> 	a bit clarification :
> 
> 1. My subagent has sent any pkt (open/index allot/Reg ) now problem is
> how long the sub-agent should wait for response from Master assuming
> there is no pkt loss as connection oriented but still Master may be
> overloaded and may take time in responding , this blocks my sub-agent
> con-current PDU processing if it waits for particular PDU's reponse sent
> by it to Master. If answer to this is you should have timer for getting
> response, then managing timer will be a overhead for every PDU sent.

Blocking while expecting a response is rarely a good idea.
Consider the case where the master agent dispatches a get
request after your subagent sends its request.  Will it
know what to do?

> 2. The sub-agent has allocated index before registering and is mentioned
> in RFC if response for this Registration is "duplicateRegistration" then
> deallocate the index. In this scenario index-deallocation is clear , but
> say i have sent an unregister PDU for a fully qualified row in a table
> , now  shall the sub-agent should send corresponding index-deallocation
> PDU to free the index for that row or Master will take care of it. If
> Master then RFC also says that while allocating index master need not
> aware of type of index , so master is finding it difficult to free by
> seeing just the OID.
...

Index allocation and registration should be completely decoupled
in a master agent.  Registration requests should have no effect
on index alllocation, and vice versa.

 ------------------------------------------------------------------------
 Randy Presuhn           [email-masked]     http://www.bmc.com/
 Voice: +1 408 616-3100  BMC Software, Inc.           965 Stewart Drive
 Fax:   +1 408 616-3101  Sunnyvale, California 94086  USA
 ------------------------------------------------------------------------
 Any relationship between my opinions and BMC's is probably coincidental.
 ------------------------------------------------------------------------