Subject: Thanks & Confusion ........

From: [email-masked]
Date: Thu, 5 Aug 1999 11:30:08 +0530

Hi,
	First of all thanks a lot for prompt reply. I think i am unable to put clearity in my question so the same follows below :

	I have the following doubt in table sharing ::

	Suppose a subagent S1 has registered full Interfaces( 1.3.6.1.2.1.2 ) subtree/region. Now a subagent S2 tries to register                        an individual row in the IF table as 1.3.6.1.2.1.2.2.1.[1-22].7. Will the master agent allow this registeration?. 
	If yes, how the master agent knows previously that, this row was not registered by subagent S1 as while registering S1 	need not allocate index for row registration since it has registered full table.
       
	In the same above scenario Is there need for S1 to allocate index for each row it is supporting ?

Bye
Ravinder.

----------
From: 	Randy Presuhn[SMTP:dorothy.bmc.com!rpresuhn]
Sent: 	Thursday, August 05, 1999 1:31 AM
To: 	dorothy.bmc.com!agentx 
Subject: 	Re:  Table Sharing

Hi -

> From: [email-masked]
> To: [email-masked] ('agentx')
> Subject: Table Sharing 
> Date: Wed, 4 Aug 1999 15:16:45 +0530
..
> 	When a Agentx Subagent registers a MIB region containing a sharable table like ifTable , then how the rest of the agentx subagents will get themselves registered for a particular row.  As per the RFC rows cannot be shared then how the second or so subagent can register itself for that table. 
..

See RFC 2257, especially clause 7.1.5.1.  Since the registrations for
individual rows will have more sub-identifiers than the registration
for the table as a whole, there is no problem; it's not even necessary
to resort to looking at the priority field to resolve the requests.

I'm curious as to what you mean by "rows cannot be shared".  While this
would certainly be unusual, at a protocol level it is indeed possible
for different subagents to take responsibility for different columns
in the same table, resulting in a situation where different subagents
will end up with resposibility for different objects in the same
conceptual row.

 ------------------------------------------------------------------------
 Randy Presuhn           [email-masked]     http://www.bmc.com/
 Voice: +1 408 616-3100  BMC Software, Inc.           965 Stewart Drive
 Fax:   +1 408 616-3101  Sunnyvale, California 94086  USA
 ------------------------------------------------------------------------
 Any relationship between my opinions and BMC's is probably coincidental.
 ------------------------------------------------------------------------

---

From: Mark Ellison <[email-masked]>
Date: Thu, 05 Aug 1999 13:48:55 -0400

Hi, Ravinder

In your example, a compliant master agent would allow both the registration from S1 and the registration from S2.  Your example shows an overlapping registration.  A compliant master agent will dispatch to S1 for all requests that fall under 1.3.6.1.2.1.2  except for the portion registered by S2, namely
1.3.6.1.2.1.2.2.1.[1-22].7.  Here, the compliant master agent would dispatch to S2

The Elements of Procedure specifies the master agent reject duplicate registrations and allow overlapping registrations.

Possibly sections 7.1.4, "Processing the agentx-Register-PDU" and
 7.2.1, "Dispatching AgentX PDUs", expecially the part about "Honoring the registry" will help here.

You're encouraged to keep at this while any confusion remains :-)

Regards,

Mark