Subject: RE: Thanks & Confusion ........

From: "Harrington, David" <[email-masked]>
Date: Thu, 5 Aug 1999 14:31:02 -0400

Hi Ravinder,

I haven't been very involved with agentX, and maybe my understanding is
incorrect, so please realize that I could be wrong in what follows.

If I remember correctly, the master agent determines which subagent gets the
priority based on the specificity of the OID used during registration, in a
manner similar to View-based ACM. 

While S1 registered for 1.3.6.1.2.1.2, S2 registered for
1.3.6.1.2.1.2.2.1.[1-22].7 which is more specific. Therefore requests that
would fall into the more specific area would be sent to S2. 

S1 registers 1.2.3
S2 registers 1.2.3.[4-6]
S3 registers 1.2.3.4.5

if the request is in the 1.2.3.4.5 branch, use S3, ELSE
if the request is in the 1.2.3.[4-6] branch, use S2, ELSE
if the request is in the 1.2.3     branch, use S1.
		
Hope this helps,
dbh

> -----Original Message-----
> From: Mark Ellison [mailto:[email-masked]]
> Sent: Thursday, August 05, 1999 1:49 PM
> To: [email-masked]
> Cc: 'agentx'; Mark Ellison
> Subject: Re: Thanks & Confusion ........
> 
> 
> Hi, Ravinder
> 
> In your example, a compliant master agent would allow both 
> the registration from S1 and the registration from S2.  Your 
> example shows an overlapping registration.  A compliant 
> master agent will dispatch to S1 for all requests that fall 
> under 1.3.6.1.2.1.2  except for the portion registered by S2, namely
> 1.3.6.1.2.1.2.2.1.[1-22].7.  Here, the compliant master agent 
> would dispatch to S2
> 
> The Elements of Procedure specifies the master agent reject 
> duplicate registrations and allow overlapping registrations.
> 
> Possibly sections 7.1.4, "Processing the agentx-Register-PDU" and
>  7.2.1, "Dispatching AgentX PDUs", expecially the part about 
> "Honoring the registry" will help here.
> 
> You're encouraged to keep at this while any confusion remains :-)
> 
> Regards,
> 
> Mark
> 
> 
> [email-masked] wrote:
> 
> > Hi,
> >         First of all thanks a lot for prompt reply. I think 
> i am unable to put clearity in my question so the same follows below :
> >
> >         I have the following doubt in table sharing ::
> >
> >         Suppose a subagent S1 has registered full 
> Interfaces( 1.3.6.1.2.1.2 ) subtree/region. Now a subagent S2 
> tries to register                        an individual row in 
> the IF table as 1.3.6.1.2.1.2.2.1.[1-22].7. Will the master 
> agent allow this registeration?.
> >         If yes, how the master agent knows previously that, 
> this row was not registered by subagent S1 as while 
> registering S1  need not allocate index for row registration 
> since it has registered full table.
> >
> >         In the same above scenario Is there need for S1 to 
> allocate index for each row it is supporting ?
> >
> > Bye
> > Ravinder.
> >
> > ----------
> > From:   Randy Presuhn[SMTP:dorothy.bmc.com!rpresuhn]
> > Sent:   Thursday, August 05, 1999 1:31 AM
> > To:     dorothy.bmc.com!agentx
> > Subject:        Re:  Table Sharing
> >
> > Hi -
> >
> > > From: [email-masked]
> > > To: [email-masked] ('agentx')
> > > Subject: Table Sharing
> > > Date: Wed, 4 Aug 1999 15:16:45 +0530
> > ..
> > >       When a Agentx Subagent registers a MIB region 
> containing a sharable table like ifTable , then how the rest 
> of the agentx subagents will get themselves registered for a 
> particular row.  As per the RFC rows cannot be shared then 
> how the second or so subagent can register itself for that table.
> > ..
> >
> > See RFC 2257, especially clause 7.1.5.1.  Since the 
> registrations for
> > individual rows will have more sub-identifiers than the registration
> > for the table as a whole, there is no problem; it's not 
> even necessary
> > to resort to looking at the priority field to resolve the requests.
> >
> > I'm curious as to what you mean by "rows cannot be shared". 
>  While this
> > would certainly be unusual, at a protocol level it is 
> indeed possible
> > for different subagents to take responsibility for different columns
> > in the same table, resulting in a situation where different 
> subagents
> > will end up with resposibility for different objects in the same
> > conceptual row.
> >
> >  
> --------------------------------------------------------------
> ----------
> >  Randy Presuhn           [email-masked]     
> http://www.bmc.com/
> >  Voice: +1 408 616-3100  BMC Software, 
> Inc.           965 Stewart Drive
> >  Fax:   +1 408 616-3101  Sunnyvale, California 94086  USA
> >  
> --------------------------------------------------------------
> ----------
> >  Any relationship between my opinions and BMC's is probably 
> coincidental.
> >  
> --------------------------------------------------------------
> ----------
>

---

From: Mark Ellison <[email-masked]>
Date: Thu, 05 Aug 1999 16:16:57 -0400

Hi, David

Yes, the master agent determines the "authoritative region" and dispatches as
you've described (essentially longest matching subtree, ties broken by priority
value).

However, in your example, if the registration from S3 and S2 had the same
priority and occurred in the order S1, S2, S3....Then S3 would be rejected as a
duplicate of S2.  The registrations of S1 and S2 (alternatively S1 and S3) are
overlapping.

Regards,

Mark